LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Console resolution problem (http://www.linuxquestions.org/questions/slackware-14/console-resolution-problem-4175421062/)

mariano 08-08-2012 02:20 PM

Console resolution problem
 
Hi all!

Im using Slackware 13.37, when the system boots, the console res. goes to 1024x768, and I need 640x480 or 800x600.

Changing the lilo.conf only change the resolution of the first part of thr boot, after some point the system always goes to 1024x768.

I was looking at rc.modules, rc.S, rc.fonts to see if one of that is changind the configuration selected by the lilo.conf.

Someone can help me with this?

frieza 08-08-2012 02:23 PM

if you are using lilo, then yes, the setting would be in lilo.conf, there should be a line that has something like 'vga=791'
http://www.pendrivelinux.com/vga-boo...en-resolution/
should have more information

Mike_M 08-08-2012 02:30 PM

It sounds like KMS (Kernel Mode Setting) may be causing your issue. If that is the case, it will override any changes you may make to the "vga" parameter. Try adding

Code:

append = "nomodeset"
to /etc/lilo.conf, run lilo as root, and reboot your system.

(If there is already an append line in your lilo.conf file, add the nomodeset option to that existing line.)

mariano 08-08-2012 03:52 PM

Thats was exactly the problem Mike_M, thanks!

kikinovak 08-08-2012 04:09 PM

Quote:

Originally Posted by mariano (Post 4749200)
Hi all!

Im using Slackware 13.37, when the system boots, the console res. goes to 1024x768, and I need 640x480 or 800x600.

For 800x600, you need this in lilo.conf:

Code:

vga=788

volkerdi 08-08-2012 04:12 PM

Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.

Didier Spaier 08-08-2012 04:47 PM

Quote:

Originally Posted by volkerdi (Post 4749297)
Disabling KMS is going to cause trouble with running X.

Not here, Sir.

I just launched Slackware 13.37 with "Linux nomodeset" and after "startx" X took care of inserting the nouveau module and its dependencies, including drm_kms_helper.

This is with a nVidia GPU of course and I can't say a word for other brands and drivers.

kikinovak 08-08-2012 04:55 PM

Quote:

Originally Posted by Didier Spaier (Post 4749326)
I just launched Slackware 13.37 with "Linux nomodeset" and after "startx" X took care of inserting the nouveau module and its dependencies, including drm_kms_helper.

You sure about this? Until now, AFAIK, nouveau worked with KMS. With NVidia cards, I only specify 'nomodeset' with the proprietary driver (which I always use). Plus, I also blacklist 'nouveau', which is sort of redundant, but just to be on the safe side that there is no conflict with nouveau.

This morning I setup X on an old Panasonic Toughbook with an Intel Express card. Had to fiddle around a bit with it, since I have to edit mkinitrd.conf and specify the Intel modules explicitly like this, to be included in the initrd:

Code:

MODULES="ext4:intel_agp:i915"
Unless configured like this, with KMS, this card for example won't work properly.

kikinovak 08-08-2012 05:05 PM

Quote:

Originally Posted by volkerdi (Post 4749297)
Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.

Thanks for that one! Been trying for quite some time to enlarge those super-tiny fonts with KMS enabled, but to no avail.

Immer wenn du glaubst, es geht nicht mehr,
Kommt von irgendwo ein Lichtlein her.

:hattip:

Didier Spaier 08-08-2012 05:14 PM

Well, let's put it this way: I was half wrong :confused:

I mean that I have no problem launching X, but the vesa driver for X is used instead of nouveau, though the nouveau kernel module be loaded.

This is probably because KMS was disabled, as I see in X logs this error message:
Code:

(EE) [drm] failed to open device
And before somebody suggests me to RTFM, yes I did read this page. But maybe I did misread it ;)

Mike_M 08-08-2012 05:21 PM

Quote:

Originally Posted by volkerdi (Post 4749297)
Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.

Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.

kikinovak 08-08-2012 05:38 PM

Quote:

Originally Posted by Didier Spaier (Post 4749345)
Well, let's put it this way: I was half wrong :confused:

Half right is not bad either :hattip:

kikinovak 08-08-2012 05:41 PM

Quote:

Originally Posted by Mike_M (Post 4749350)
Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.

As far as my experience with various hardware goes, you need KMS...

- with NVidia cards if you intend to use the 'nouveau' driver
- with most Intel graphic cards

Correct me if I'm wrong.

volkerdi 08-08-2012 06:11 PM

Quote:

Originally Posted by Mike_M (Post 4749350)
Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.

Since the OP had verified that disabling KMS fixed the console, the driver for that video chipset was clearly using KMS. And at this point, I think any driver that can use KMS requires it. It's not universal though. There are still drivers that don't use KMS.

Didier Spaier 08-09-2012 02:45 AM

For nouveau users there is also the possibility of blacklisting the nouveau kernel module, still keeping xf86-video-nouveau installed. No framebuffer will be used during startup, the nouveau kernel module will be inserted after X starts and X will use the nouveau driver. But after that the console will use the nouveau framebuffer as well, which may not be what the OP wants. Just wanted to mention that because this is my setting right now.

PS This is with vga=normal.


All times are GMT -5. The time now is 06:57 PM.