LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-01-2004, 05:40 PM   #1
sethgeekx86
Member
 
Registered: Jan 2004
Distribution: Slackware 9.1 SUSE 9.0
Posts: 131

Rep: Reputation: 15
Build Errors.


Every time i try to compile programs i download i get build Errors.
Like Make Error 1 leaving Dir
I Re-installed Slackware and it still does it. What is the best thing to do , get a GCC 3.3 Slackware Pkg.

Last edited by sethgeekx86; 04-01-2004 at 05:42 PM.
 
Old 04-01-2004, 06:04 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Whats the actual errors your getting. Usually the Make line is after the actual error. Sometimes you might get a list of make errors, and above them will be the error that caused the make to fail.

Since so much is failing, It might be you don't have some basic libraries installed, or you dont have the include headers files. So what you might be looking for is development versions of the packages.
 
Old 04-01-2004, 06:42 PM   #3
sethgeekx86
Member
 
Registered: Jan 2004
Distribution: Slackware 9.1 SUSE 9.0
Posts: 131

Original Poster
Rep: Reputation: 15
make[2]: Leaving directory `/home/seth/pkg/shorten-3.5.2/src'
make[1]: Leaving directory `/home/seth/pkg/shorten-3.5.2/src'
Making all in tests
make[1]: Entering directory `/home/seth/pkg/shorten-3.5.2/tests'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/seth/pkg/shorten-3.5.2/tests'
make[1]: Entering directory `/home/seth/pkg/shorten-3.5.2'
make[1]: Nothing to be done for `all-am'.
make[1]: Leaving directory `/home/seth/pkg/shorten-3.5.2'

This is the stuff i get.
 
Old 04-01-2004, 06:47 PM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
According to what you've put there it looks like its already compiled.

Nothing to be done means that all the files make has for building are done. So its leaving the directories. Theres no errors.

So you've done
./configure
make

All thats left is to type make install as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wxpython build errors bmfan Linux - Software 1 11-21-2005 07:01 AM
Skencil build errors drewblay Linux - Software 3 04-15-2005 05:32 AM
First kernel build and getting boot errors astender Linux - General 1 11-22-2004 03:20 PM
Superkaramba 0.34 build errors Kramer Linux - Software 6 09-11-2004 12:28 AM
Crazy @$$ build errors Twiggy794 Red Hat 1 09-26-2003 03:35 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration