LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-23-2006, 03:57 AM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,563
Blog Entries: 1

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
boot loader (grub - slackware)


Hello,

I have XP/fedora core 5 /slackware
I installed slackware 10.2 but decieded to not to install
lilo. Now I need to edit fedora's grub.conf to include slackware.
Something's not working

My grub.conf

default=0
timeout=5
splash blablablablabal
hiddenmenu

title Fedora
root (hd0,2)
kernel /boot/vmllinuz-2........ ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2....img

title windows
rootnoverify (hd0,0)
chainloader +1

title slackware
rootnoverify (hd0,5)
kernel /boot/vmlinuz-ide-2.4.31 ro root=LABEL=/1 rhgb quiet
initrd ?????????????????????????????


I edited the slackware entry but something is wrong.
I don't know if the kernel line is correct, and have
no idea what to put in the initrd line.

the files in my /boot directory:
config -> config-ide-2.4.31
config-ide-2.4.31
diag1.img
System.map -> System.map-ide-2.4.31
vmlinuz -> vmlinuz-ide-2.4.31
vmlinuz-ide-2.4.31



So the grub loader works ok for xp and fedora, I can't boot slackware, obviously because of that entry in grub.conf
When I boot into fedora I can mount slackware partition and access the data, so everything seems to be ok with slackware itself.

thanks
 
Old 05-23-2006, 04:41 AM   #2
bit128_linux
Member
 
Registered: Dec 2005
Location: Brasov, Romania
Distribution: Slackware, Bluewhite64
Posts: 49

Rep: Reputation: 15
Hi. I think the correct lines would be something like:

title Slackware
root (hd0,5)
kernel /boot/vmlinuz-ide-2.4.31 root=/dev/hda6 ro

You should not need initrd, unless you use filesystems like reiserfs, xfs..
The "/dev/hda6" which I wrote above is just a guess of mine from (hd0,5). You should replace that with your apropiate entry . This configuration works, at least for me .

Last edited by bit128_linux; 05-23-2006 at 04:50 AM.
 
Old 05-23-2006, 05:32 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,563
Blog Entries: 1

Original Poster
Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
thanks,
when i come back from work, I wil try it
 
Old 05-24-2006, 06:52 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,563
Blog Entries: 1

Original Poster
Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
thanks, it works fine
 
Old 06-11-2006, 02:34 AM   #5
dmcg3
LQ Newbie
 
Registered: Jan 2006
Location: Long Beach
Distribution: Fedora Core 3, Ubuntu, Hopefully Slack soon
Posts: 2

Rep: Reputation: 0
And the search feature works again! Thanks bit128! I haven't been able to boot into my slackware partition for months! I was also trying to needlessly pass it an initrd file and an init= line on the kernal line and it panicked every time. It wasn't a particularly knawing problem as I dual boot with Fedora so I hadn't really tried to fix it until tonight. And now it works! Thanks!
 
Old 06-11-2006, 04:17 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,226

Rep: Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019
Folks, you would do well to do some reading and seek to understand the difference in grub command lines.
Particularly if you intend to stray from Fedora/Redhat.
 
Old 06-11-2006, 04:45 AM   #7
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Second syg00ś comment...

Learning to properly edit the grub.conf file opens whole new worlds.

Bob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
GRUB boot loader blocking windows boot julienroger Linux - Newbie 3 10-12-2004 01:11 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
Need help with boot loader. Multi boot questions. Grub? 1993gt40 Linux - Software 1 10-16-2003 08:28 PM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 02:22 AM


All times are GMT -5. The time now is 10:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration