LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-18-2005, 08:24 AM   #1
psrini_vasan
LQ Newbie
 
Registered: Mar 2005
Location: chennai,india
Posts: 1

Rep: Reputation: 0
Arrow wireless Keyboard not working to select boot options (Grub boot loader)


i have successfully installed fedora core 3 linux on my machine which is also having winxp. But i couldn't able to select the boot option with my keyboard. the boot loader automatically loads the default boot. i want to know is it necessary to buy a ps/2 keyboard or could i select option with wireless keyboard(any software to be installed??)
 
Old 03-18-2005, 08:45 AM   #2
Ricky2004
Member
 
Registered: Apr 2004
Distribution: Fedora, Ubuntu, Puppy
Posts: 37

Rep: Reputation: 15
is it a usb keyboard? maybe the BIOS doesn't have the minimal drivers to handle it. I have a PS/2 wireless keyboard and it works quite well (i.e., like a driverless normal keyboard).
Try using a USB>PS/2 adapter, or making the bootloader wait a few seconds more (to give the BIOS more time to interpret whatever the keyboard is doing). But I could be WAY wrong about this.
Can you access the BIOS with your wireless keyboard? Regular keyboards can, but a fancy one may have trouble without drivers. If you can't, then you won't be able to use the bootloader anyway... I hope this is making sense to you.
 
Old 04-28-2006, 09:12 AM   #3
chipix
LQ Newbie
 
Registered: Dec 2002
Location: Athens, HELLAS
Distribution: Fedora Core 4
Posts: 22

Rep: Reputation: 15
Same problem with Creative wireless keyboard.
I have no problems managing the BIOS using either keyboard or mouse (both wireless). However, I canot use it with GRUB.

Any suggestions?
 
Old 01-03-2007, 05:11 AM   #4
nDray
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
You should browse for some wireless/usb keyboard activation option in your BIOS, so that it can try to recognize those devices right on start-up....


EDIT: Sorry, this was the result of a google search, didn't realise it was so old.......

Last edited by nDray; 01-03-2007 at 05:20 AM.
 
Old 06-14-2008, 07:28 PM   #5
ferperezd
LQ Newbie
 
Registered: Jun 2008
Location: Guadalajara, Mexico
Distribution: UBUNTU Ultimate 8.04
Posts: 1

Rep: Reputation: 0
Thumbs up Using your wireless keyboard on GRUB

I had the same problem, I was able to use my wireless keyboard to access BIOS setup utility but not on GRUB, so what I did was, on the BIOS setup utility, I enabled the option: USB Kerboard support and also USB mouse support. That fixed it, now the Microsoft Desktop receiver stays on always and you can use the keyboard on GRUB to select the OS you wanna boot with. Hope that helps you brother.

Be well,
 
Old 06-15-2008, 03:19 AM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
The Bios should mention the keyboard during boot , if not the BIos do not support a USB KEyboard and mouse
Read the BIOS message during boot to see if the mouse and keyboard is there.

all the best
 
Old 11-19-2009, 10:21 PM   #7
MarkvanderPol
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
Same problem here. Not much use on the 'net for answers.

Here is how to solve it.

Unplug all your other USB devices, except the USB keyboard

If you've already done that, open your case, and unplug the internal memory card reader.

Presto - USB keyboard works as standard legacy devices.

I have no idea why some of these internal memory card readers have this effect. I had the same trouble with a SanDisk external reader, but of course, that is easier to unplug.

It is only at boot time, and only if you select USB Legacy Support (or equivalent 'USB Keyboard Support', etc, in the BIOS). After the OS has booted, everything works fine.
 
Old 12-16-2009, 05:45 PM   #8
NeilMacK123
LQ Newbie
 
Registered: Dec 2009
Location: Ochiltree, scotland
Distribution: Ubuntu 9.10
Posts: 1

Rep: Reputation: 0
Setting the usb legacy option to yes worked for me. Thanks..
 
  


Reply

Tags
grub


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB boot loader "kernel" options?? registering Mandriva 4 08-18-2005 07:12 AM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
Select boot options in shutdown menu? dominik81 Mandriva 7 02-21-2004 03:21 AM
Anyone know the file that the xp boot loader calls when I select Ms Win Xp H edition? Bensoft Kill MS Linux - General 1 10-05-2003 11:11 PM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 02:22 AM


All times are GMT -5. The time now is 05:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration