LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-16-2006, 03:21 AM   #1
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Rep: Reputation: 15
bios screen not aligned to the left (resolution problem?)


hello, ive just changed from Vectorlinux to Slackware 11. i have a problem with the bios text not being aligned to the left, which when i start vi to edit text files, i cannot see the top of the text file as it is off the top of the screen, and i have to arrow key down 5-10 times before i see the cursor. im guessing its a resolution problem, but i dont know how to fix it
by the way, my graphics card is a 'S3 prosavage 8A25 (16mb ram)'

Last edited by soldan; 10-16-2006 at 03:34 AM.
 
Old 10-16-2006, 06:54 AM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Your post is a bit vague:
Bios and vi don't combine in one sentence, so I assume you're talking about the normal text screens and not about the bios screen.
Next your title is indicating horizontal alignment (left) while your post refers to vertical alignment (top of screen).

First you can use the controls on the monitor to adjust width and height.

Further you might have choosen an incorrect 'resolution' in the lilo config file. Below is mine (taken from a slack 10.1 box); try to use 'vga=normal'.
Code:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
 
Old 10-16-2006, 08:04 AM   #3
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Wim Sturkenboom
Your post is a bit vague:
Bios and vi don't combine in one sentence, so I assume you're talking about the normal text screens and not about the bios screen.

that is correct, i meant to say boot message screen, not bios.


Quote:
Next your title is indicating horizontal alignment (left) while your post refers to vertical alignment (top of screen).

my apologies for not making myself clear. when linux boots, the text messages that are printed to the screen are not aligned vertically to the left, they seem to be in a curved shape. also, i dont see the penguin logo at the top of the screen, it seems to be above my viewing area.


Quote:
First you can use the controls on the monitor to adjust width and height.

it does not appear to be this.


Quote:
Further you might have choosen an incorrect 'resolution' in the lilo config file. Below is mine (taken from a slack 10.1 box); try to use 'vga=normal'.
Code:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal

my lilo.conf had the same entrys as above, i then commented out 'vga = 773', and uncommented 'vga = normal', restarted the computer, but the boot message screen was the same.
 
Old 10-17-2006, 12:04 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Quote:
the text messages that are printed to the screen are not aligned vertically to the left, they seem to be in a curved shape
I can not 100% visualize the curved shape but I think that I know what you say. You can definitely adjust that on the monitor itself. It depends on the exact shape, but more than likely it's (only) pincushion distortion.
Quote:
it does not appear to be this.
How do you mean? Did you try to adjust it and could not get it right or ... ?? Are you using a very old monitor that maybe only supports some fixed frequencies? Maybe you can post a link to the specs. I'm not sure if I can help further.
 
Old 10-17-2006, 12:17 AM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Quote:
Originally Posted by soldan
my lilo.conf had the same entrys as above, i then commented out 'vga = 773', and uncommented 'vga = normal', restarted the computer, but the boot message screen was the same.
You've to run lilo in order to apply changes in /etc/lilo.conf.
 
Old 10-17-2006, 09:55 AM   #6
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Wim Sturkenboom, i was wary about changing my monitor settings, as i thought it might affect the appearence of my xp install (im duel booting slackware and xp), however i tried adjusting the pincushion while using slack, and it worked to bring the boot message text onto the screen properly and with left alignment, and although the text is small, i can live with that. also i booted xp and it doesnt seem to have affected that at all, which is suprising to me.
my monitor specs are -->

iiyama vision master 452 MF901V (19" CRT)

horizontal 30-96khz
vertical 50-180khz.

however, i seem to be having another resolution problem,in that when i run fluxbox, i cannot use 800x600 which i would like to use, as im restricted due to a black bar which the mouse stops at, and which covers (going from left to right) the first third of the screen. also, there are horizontal lines flashing on the screen.

gbonvehi, i tried to run Lilo by typing '/sbin/lilo', at the commandline, but i get this error

'Added windows *
syntax error at or above line 39 in file '/etc/lilo.conf'
'

here is a copy of my lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
# vga=773
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
label = Windows
table = /dev/hda
vga=788
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda3
label = Linux
read-only
vga=788
# Linux bootable partition config ends
 
Old 10-17-2006, 11:32 AM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Comment both vga=788 lines down there (add a # at the beggining), Windows won't accept that parameter and you want to use vga=normal for Linux (that's stated above) instead of vga=788.
 
Old 10-17-2006, 03:06 PM   #8
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Wim Sturkenboom and gbonvehi, the boot text messages are large and on the screen properly, thanks for your help

Last edited by soldan; 10-17-2006 at 03:07 PM.
 
Old 10-18-2006, 12:03 AM   #9
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Why run 800x600 on a 19" CRT? But OK, you will have your reasons. With regards to your black bar at 800x600, can't it be adjusted with the monitor controls?

With regards to 'influencing'. In simple terms:
Monitors (not the old-old ones) can store a number of configurations at the same time. They decide which one to use based on the input signal. So an adjustment for 640x480 will not influence 800x600 or 2048x1536.

The problem might come when you use the same resolutions (in combination with refresh rates) in Windows and Linux where the signals might slightly differ but the same configuration will be used. In that case a different refresh rate (for one of the two) might solve the problem.
 
Old 10-18-2006, 04:33 PM   #10
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Wim, you were right, the black bar can be removed with the monitor controls, and it now looks fine, and there are no flashing lines (i should have tried this).
i like to use 800x600 because 1024x768 makes my programs small, with small fonts which i cant read very well.
also if i run xrandr i only see '800x600' @refresh rate of 75hz, and '640x480' @refresh rate of 85hz.
i have tried to set the resolution to '1024x768' just as a test, by doing this 'xrandr -s 1024x768', but it doesnt work. by the way, i can get a resolution of 800x600 @refresh rate of 100hz in win xp, so that should be possible in slackware right?

Last edited by soldan; 10-18-2006 at 04:39 PM.
 
Old 10-19-2006, 12:54 AM   #11
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Yep, if WinXP can do it, Slack can do it.

There are three things that will make that you can not get the desired resolution. Wrong driver, wrong monitor settings and resolution not defined.

First of all, make a backup of /etc/X11/xorg.conf (I usually call it xorg.conf.org or xorg.conf.wim).
All of the following needs to be done as root and probably without X running. I have added examples of my slackware 10.1 box.

Monitor settings:
From one of your earlier posts:
Quote:
horizontal 30-96khz
vertical 50-180khz
Open /etc/X11/xorg.conf and look for the lines with HorizSync and VertRefresh (they are in the monitor section). Those lines should reflect the above given values; if not, adjust.
Code:
Section "Monitor"
#DisplaySize      320   240     # mm
Identifier   "Monitor0"
VendorName   "DEL"
ModelName    "DELL P790"
HorizSync    31.0 - 92.0
VertRefresh  50.0 - 150.0
Option      "DPMS"
EndSection
PS it's not kHz for vertical, but Hz

Resolution:
Search for the section Screen and look at the defaultdepth. Remember it and find a subsection display with the same depth. If the desired resolution is there, you can stop, else add it.
Code:
Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
modes     "1280x960" "1024x768"
EndSubSection
EndSection
When X starts, it will try the given resolutions in sequence and use the one that will fit with the refresh rates and the video driver.

Driver:
Next search for the section Device. The driver must either be vesa or one specific for your videocard. You can either modify the driver (to vesa) or you can close the file and run xorgsetup. xorgsetup will try to detect your video hardware.

The vesa driver should definitely work, so you can stick initially to that. If you want to use all fancy options of your videocard, you need to use the dedicated driver.

If you use xorgsetup, you can check the result in the xorg.conf file. It's my experience that xorgsetup can 'screw up' the earliear changes for monitor and resolution, so you have to check them.
Code:
Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option     "SWcursor"                  # [<bool>]
#Option     "HWcursor"                  # [<bool>]
#Option     "NoAccel"                   # [<bool>]
#Option     "ShadowFB"                  # [<bool>]
#Option     "UseFBDev"                  # [<bool>]
#Option     "Rotate"                    # [<str>]
#Option     "VideoKey"                  # <i>
#Option     "FlatPanel"                 # [<bool>]
#Option     "FPDither"                  # [<bool>]
#Option     "CrtcNumber"                # <i>
Identifier  "Card0"
Driver      "nv"
VendorName  "nVidia Corporation"
BoardName   "NV6 [Vanta/Vanta LT]"
BusID       "PCI:1:0:0"
EndSection
Now you can (re)start the X-server.

There is another utility to create an xorg configuration; it's xorgconfig. It however does more than only the video (mouse, kb etc). It however allows you to go through a list of supported video cards and pick the (correct) one.
If I don't come write with xorgsetup, I run xorgconfig and later manually copy/paste some stuff between backup and newly generated file.

Quote:
i like to use 800x600 because 1024x768 makes my programs small, with small fonts which i cant read very well.
That's definitely the case. It was just that you have a magnificent monitor that can handle a lot more than that (and that is what I would buy it for).
On a 17" monitor, I usually run 1152x864 (not in above config); for me, that's still readable.
But as said, it's your preference.

Last edited by Wim Sturkenboom; 10-19-2006 at 01:00 AM.
 
Old 10-19-2006, 05:12 PM   #12
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Wim, i followed your guide (modifying the horizontal and vertical settings in the 'monitor' section of 'xorg.conf', and i also modified the default depth (24) modes to include "1024x768" and "800x600". on 'startx', i did the 'xrandr' command, and it showed many more choices of resolution, and by doing 'xrandr -s 1024x768' i was able to use that resolution, although i changed back to 800x600. although there were more resolution options in 'xrandr', the highest refresh rate i see is '85', and although i can change the refresh rate to lower than '85', i cannot make it higher to '100', i get this error:

'XError of failed request: Badvalue (integer parameter out of range for operation)
Major opcode of failed request: 156 (RANDR)
Minor opcode of failed request: 2 (RRSetScreenConfig)
Value in failed request: 0x5a
Serial number of failed request: 12
Current Serial number in output stream: 12'.

so then i ran 'xorgconfig', and at the video card stage i chose 'S3 Savage (generic) as my prosavage card was not available. i then saved the 'xorg.conf', restarted x, ran 'xrandr' and it gave me the list of resolutions, but again the highest refresh rate was '85'.
 
Old 10-19-2006, 11:01 PM   #13
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I will revoke the first line of my previous post

I don't know why you can't get higher; this might be a driver thing that only supports up to 85Hz.

I can't help you further, sorry.
 
Old 10-20-2006, 03:03 AM   #14
soldan
Member
 
Registered: Feb 2006
Distribution: slackware 11
Posts: 110

Original Poster
Rep: Reputation: 15
Wim,i will do some more reading and try to find out why i cant get a higher refresh rate. thanks again for all your help during this thread, i now have a nice looking, usable slackware, and ive learnt alot too
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
screen resolution problem kristof_v Linux - Software 6 10-19-2006 06:08 PM
solution for non-aligned screen? revoked Linux - Newbie 6 08-03-2006 03:57 AM
Screen Resolution Problem Landon Linux - Laptop and Netbook 12 12-30-2005 11:48 AM
problem with screen resolution thorney Slackware 2 11-25-2005 02:35 PM
help!! screen resolution problem unitcoed Linux - Newbie 4 06-30-2003 10:52 PM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration