LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2005, 07:14 PM   #1
jcdrywater
LQ Newbie
 
Registered: Nov 2005
Location: St. Louis, MO
Distribution: Slackware 10.2
Posts: 2

Rep: Reputation: 0
Alt key combinations not working in mc, Slackware 10.2


I am no longer able to use ALT key functions in midnight commander since installing Slackware 10.2. This was not a problem in Slackware 10.1 and I haven't had this problem before in other distros. I am using xterm and I have set TERM=xterm. Pressing ALT-T in mc should change the display but instead generates a funny "o" with an carrot on top at the command line. I've tried rerunning xorgconf with a few different keyboard settings, but all have the same result. Anyone have any ideas?

Thanks.

- Jeffrey Drywater
 
Old 11-18-2005, 06:43 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Just some wild guesses, do you have rc.keymap enabled and if so, which keymap is being used?

Second, as you are using mc in an xterm window, do you experience the same results if you use mc in a non-X/GUI environment?
 
Old 11-19-2005, 11:31 AM   #3
jcdrywater
LQ Newbie
 
Registered: Nov 2005
Location: St. Louis, MO
Distribution: Slackware 10.2
Posts: 2

Original Poster
Rep: Reputation: 0
It appears that this has something to do with how xterm is compiled on Slackware 10.2. I've been using xterm as my terminal for years. I tried rxvt and the KDE "konsole" program and the problem doesn't exist. So, I'm just going to switch to rxvt, which has the features I like and it a little less bloated than xterm anyway, and my problem is solved. Thanks.

- Jeffrey Drywater
 
Old 11-21-2005, 05:28 AM   #4
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
your .Xresources or .Xdefaults are the same of slack 10.1 ? I dont know if it right but I think to remember that there are a option in xterm to enable it as a rxvt ... or you may try setting you TERM variable to rxvt and see if the problem continues

[ ]'s
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALT+B, ALT+F key combinations in xterm don't work nIMBVS cAos 4 12-15-2011 01:52 AM
Macomedia Flash - Alt key not working deVas Linux - Software 2 11-21-2005 02:05 PM
Key combinations that will stop a boot? txtedmacs Linux - General 11 08-22-2005 07:03 PM
Alt Gr key isn't working in Fluxbox jaakkop Linux - Software 0 04-03-2005 11:07 AM
ALT+ Combinations XPediTioN Slackware 2 07-24-2003 06:37 PM


All times are GMT -5. The time now is 07:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration