LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-29-2004, 07:33 PM   #1
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Rep: Reputation: 30
3D acceleration


I just installed tuxkart and it's very laggy. How can i test if my 3D acceration is working and find out what is wrong?
 
Old 07-29-2004, 08:02 PM   #2
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
type :

glxinfo | grep direct

if it says direct rendering : Yes , then ur 3d is working

what graphic card do u have ? if its nvidia or ati then u need to install their drivers
 
Old 07-29-2004, 08:06 PM   #3
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
it says no. How can i turn it on. I'm using the Nvidia drivers.
 
Old 07-29-2004, 08:08 PM   #4
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
check this site out to help u with the nvidia drivers as i have ati

http://shilo.is-a-geek.com/slack/nvidia5.html
 
Old 07-29-2004, 08:10 PM   #5
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
I have already done everything mentioned on that site. Any other suggestions?
 
Old 07-29-2004, 08:16 PM   #6
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
is there anything i have to enable in the xorg.conf to get 3D to work?
 
Old 07-29-2004, 08:24 PM   #7
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
sorry for the three consecutive posts. I had 3D acceleration before i updated the Mesa Libraries and Header. Any Ideas?

Last edited by zaicheke; 07-29-2004 at 09:07 PM.
 
Old 07-29-2004, 09:11 PM   #8
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
forgot to post my glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: Brian Paul
server glx version string: 1.4 Mesa 6.0.1
server glx extensions:
GLX_MESA_copy_sub_buffer, GLX_MESA_pixmap_colormap,
GLX_MESA_release_buffers, GLX_ARB_get_proc_address, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_SGI_video_sync, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer
client glx vendor string: Brian Paul
client glx version string: 1.4 Mesa 6.0.1
client glx extensions:
GLX_MESA_copy_sub_buffer, GLX_MESA_pixmap_colormap,
GLX_MESA_release_buffers, GLX_ARB_get_proc_address, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_SGI_video_sync, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer
GLX extensions:
GLX_MESA_copy_sub_buffer, GLX_MESA_pixmap_colormap,
GLX_MESA_release_buffers, GLX_ARB_get_proc_address, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_SGI_video_sync, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer
OpenGL vendor string: Brian Paul
OpenGL renderer string: Mesa X11
OpenGL version string: 1.5 Mesa 6.0.1
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_occlusion_query,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
GL_EXT_depth_bounds_test, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
GL_EXT_histogram, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_polygon_offset,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_shared_texture_palette, GL_EXT_stencil_two_side,
GL_EXT_stencil_wrap, GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_APPLE_packed_pixels, GL_ATI_texture_env_combine3,
GL_ATI_texture_mirror_once, GL_HP_occlusion_test,
GL_IBM_multimode_draw_arrays, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
GL_MESA_pack_invert, GL_MESA_program_debug, GL_MESA_resize_buffers,
GL_MESA_ycbcr_texture, GL_MESA_window_pos, GL_NV_blend_square,
GL_NV_fragment_program, GL_NV_light_max_exponent, GL_NV_point_sprite,
GL_NV_texture_rectangle, GL_NV_texgen_reflection, GL_NV_vertex_program,
GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table,
GL_SGI_texture_color_table, GL_SGIS_generate_mipmap,
GL_SGIS_pixel_texture, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
GL_SGIX_pixel_texture, GL_SGIX_shadow, GL_SGIX_shadow_ambient,
GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x22 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x25 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x27 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x28 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x29 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2a 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2b 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2c 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2d 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2e 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x2f 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x30 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x31 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x32 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x33 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x34 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x35 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x36 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x37 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
0x38 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 16 0 0 None
 
Old 07-29-2004, 10:53 PM   #9
kmoffat
Member
 
Registered: Jul 2003
Location: near Seattle
Distribution: Debian/Ubuntu/Suse
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
I'd reinstall the nvidia drivers, assuming you used the .run file from their site. Mesa probably reconfigured or overwrote something.
 
Old 07-30-2004, 06:23 PM   #10
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Original Poster
Rep: Reputation: 30
thanks it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with 3D acceleration habanerosky Fedora 1 02-27-2005 11:27 PM
3d acceleration yelo Linux - Software 11 02-20-2004 05:27 PM
3D Acceleration darin3200 Linux - General 12 07-02-2003 09:58 AM
3d Acceleration? metaxa Linux - Laptop and Netbook 3 05-30-2003 05:55 PM
3d acceleration? vector Slackware 5 03-02-2003 03:51 PM


All times are GMT -5. The time now is 02:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration