LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-22-2009, 04:18 PM   #1
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Arrow [Solved] Sound problem in Slackware 13 Current KDE 4.3


I just upgraded from Slackware 13 to Slackware 13 current. My sound card, which is ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01), Worked perfectly before the upgrade. Now when I boot up I get the message "The audio playback device ATI IXP rev 1 with unknown codec (ATI IXP AC97) does not work. Falling back to.

I have done alsa configure and alsa mixer they both work. Kmix on the other hand does not. When I try to run kmix from a console as root I get <unknown program name>(3886)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

<unknown program name>(3885)/: KUniqueApplication: Pipe closed unexpectedly.

I also have done a little research through the console. An lscpi -v gives me this for the sound card:

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller(rev01)
Subsystem: Hewlett-Packard Company Device 3085
Flags: bus master, 66MHz, slow devsel, latency 64, IRQ17
Memory at b0003400 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] MSI: Enable- Count=1/1 Maskable- 64bit-
Kernel driver in use: ATI IXP AC97 controller
Kernel modules: snd-atiixp

Everything appears normal to me so far. I am stumped here, and have been for almost a week. This is driving me insane. I know they have had some problems with KDE4 and sound but this is ridiculous. The worst part is I have sound but nothing else works.I can not control anything about it.

Any help will appreciated. I do not care if the idea is off the wall throw it out there and I might try it.

Last edited by AuroraZero; 11-22-2009 at 07:57 PM. Reason: Marked Solved
 
Old 11-22-2009, 04:45 PM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by AuroraZero View Post
The audio playback device ATI IXP rev 1 with unknown codec (ATI IXP AC97) does not work. Falling back to.
Failed upgrade.

Have you read the change logs regarding phonon & qt?
Have you checked the packages installed match exactly with what is now in current?
Have you tried removing ~/.kde and restarting kde?
 
Old 11-22-2009, 06:09 PM   #3
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Original Poster
Rep: Reputation: 31
I have read those change logs and they did not give me a hint. I also checked the packages twice just to make sure I had it correct. As for the deleting of ~/.kde I just did this and it did nothing but change my theme.
 
Old 11-22-2009, 06:38 PM   #4
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Original Poster
Rep: Reputation: 31
Upon further investigation I have found this problem only in user mode. When I log into the root account everything works as it should.
 
Old 11-22-2009, 07:56 PM   #5
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Original Poster
Rep: Reputation: 31
I finally solved this problem. As it turned out the owner of the /.dbus/ folder was screwed up. I used chown user:user /home/user/.dbus/ -R to fix it and rebooted. Worked like a charm.
 
Old 11-22-2009, 09:41 PM   #6
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,454
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
after your upgraded in current you must also do a slackpkg install-new
let me know if you did that.
 
Old 11-22-2009, 11:49 PM   #7
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Original Poster
Rep: Reputation: 31
Yes I did do that.I just think it was a fluke that caused this.
 
Old 04-20-2010, 06:39 PM   #8
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Rep: Reputation: 44
Question

AuroraZero,

I'm glad you got it fixed! However, I have the exact same problem.... I tried to change the owner of .dbus and all recurrent folder/files to my user ID and GID but no success....

I reinstalled alsa and xine (using slackpkg reinstall alsa & xine) but still no success....

I can lauch alsamixer as root, but no effect...

I am using Slack 13 32bit and KDE Version 4.3.1 that I updated from the stock 4.2 or so....

Any clue whats going on?? thats irritating.. no music, no movies, no web media AHH!

Thanks1
 
Old 04-20-2010, 06:45 PM   #9
rfernandez
Member
 
Registered: Mar 2010
Location: Brazil
Distribution: Slackware64
Posts: 264

Rep: Reputation: 40
Are you in the "audio" group?
 
Old 04-20-2010, 07:55 PM   #10
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Rep: Reputation: 44
Cool

YOU SAVED ME!!!!

I wasnt member of "audio!"..

Thanks!!!
 
Old 04-21-2010, 03:36 AM   #11
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Should be no need for the audio group.

Perhaps your missing the 'plugdev' group which is responsible for a lot more.
 
Old 04-21-2010, 08:09 AM   #12
rfernandez
Member
 
Registered: Mar 2010
Location: Brazil
Distribution: Slackware64
Posts: 264

Rep: Reputation: 40
I really don't know why, but if you login to KDE as root (yes, I've done that before), and login as user after that, you lost the sound privileges. In that case, putting myself on the audio group solved this problem for me.
 
Old 04-21-2010, 01:30 PM   #13
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,242

Rep: Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614
Quote:
Originally Posted by wildwizard View Post
Should be no need for the audio group.

Perhaps your missing the 'plugdev' group which is responsible for a lot more.
Code:
$ ls -l /dev/audio
crw-rw---- 1 root audio 14, 4 2010-04-21 14:14 /dev/audio
$ ls -l /dev/snd/
total 0
crw-rw---- 1 root audio 116,  0 2010-04-21 10:13 controlC0
crw-rw---- 1 root audio 116,  4 2010-04-21 10:13 hwC0D0
crw-rw---- 1 root audio 116, 24 2010-04-21 10:13 pcmC0D0c
crw-rw---- 1 root audio 116, 16 2010-04-21 10:13 pcmC0D0p
crw-rw---- 1 root audio 116, 25 2010-04-21 10:13 pcmC0D1c
crw-rw---- 1 root audio 116, 17 2010-04-21 10:13 pcmC0D1p
crw-rw---- 1 root audio 116, 26 2010-04-21 10:13 pcmC0D2c
crw-rw---- 1 root audio 116,  1 2010-04-21 14:14 seq
crw-rw---- 1 root audio 116, 33 2010-04-21 10:13 timer
$ ls -l /dev/dsp
crw-rw---- 1 root audio 14, 3 2010-04-21 14:14 /dev/dsp
I would say there most certainly is a reason to put yourself in the audio group.
 
Old 04-21-2010, 05:27 PM   #14
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Rep: Reputation: 44
Quote:
Should be no need for the audio group.
Maybe, but it did it! I dont understand KDE enough to comment, but I thought to let people know that it worked like a charm!!
 
Old 04-21-2010, 05:42 PM   #15
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,190

Rep: Reputation: Disabled
Quote:
Originally Posted by wildwizard View Post
Should be no need for the audio group.

Perhaps your missing the 'plugdev' group which is responsible for a lot more.
In order to use audio hardware your user needs to be in the "audio" group. Especially if you boot your computer to runlevel 4 (graphical login).
When logging in from the console, your user will implicitly be added to the "audio" group (and others - and only for the duration of your console session) in order to be able to use the local hardware peripherals. These enhanced privileges will not always carry through into X-Window, and that's why it is recommended to add your user explicitly.

Eric
 
  


Reply

Tags
alsa, ati, kde4, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 4.3.2 is available on Slackware-current Didier Spaier Slackware 3 10-23-2009 07:04 AM
problem slackware-current kde 4.2 elmana Slackware 1 04-11-2009 03:38 AM
KDE problem using Slackware "12.1" -->current version phodopus Slackware 1 02-07-2008 03:25 AM
KDE sound system crashing with SIGSEGV, slackware-current, 2.6.17.13 StarsAndBars14 Linux - Desktop 0 03-09-2007 07:40 PM
Problem with KDE 3.5.3 on Slackware-Current KeithE Slackware 11 06-07-2006 09:29 AM


All times are GMT -5. The time now is 11:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration