LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-02-2013, 07:37 PM   #1
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Rep: Reputation: Disabled
ATI/AMD FGLRX graphics driver is activated but not currently in use.


Hello all,

I've had problems with this(these) driver(s) since day one. Currently in the Additional Drivers utility it says that the driver is activated but not currently in use. When I look in the system settings, it says my Graphics are VESAVST. When I look in the xorg.conf file it says load "glx". Should I just change that "glx" to "fglrx" in the text editor, save and reboot or is there somehting else I should be doing?

Thank you for your guidance.
 
Old 02-03-2013, 10:20 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,376

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
in xorg.conf or xorg.conf.d/* find the line that says
Code:
     Driver   vesa
in the video card section, and get it changed to
Code:
     Driver   fglrx
amd don't trust me on the D in Driver - it could be 'driver'
 
Old 02-03-2013, 01:42 PM   #3
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Thanks bu no joy. The only file that I can find a Driver line as you describe is call xorg.conf.failsafe (upper case D by the way). I backed that up then changed the driver to fglrx and rebooted but nothing has changed. I looked at all the scripts in xorg.conf.d/ as you suggested (which for anyone reading this is in /usr/share/X11/) but none includes a graphics driver line. Any other suggestions?
 
Old 02-03-2013, 03:26 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Run, as root, the command
Code:
aticonfig --initial
This will generate a proper xorg.conf for use with the driver. Then just reboot the system.
 
Old 02-03-2013, 05:16 PM   #5
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Huh! I was sure that was going to work but still no joy.

The command did in fact add a bunch of lines to my xorg.conf script (see below). But still, Graphics is still VESAVST and Driver is "activated but not currently in use." Maybe I should not be worried about this because I'm not having any real problems (that I know about). I just find it strange that I can't see to get this driver to engage.

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:0:1:0"
EndSection

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 02-03-2013, 06:18 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Please use code-tags to post config files and output of commands.

Anyways, have you rebooted the machine?
Please show us your /var/log/Xorg.0.log, it will be a large file, so please attach it to a post instead of posting the contents.
 
Old 02-04-2013, 10:18 PM   #7
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
What's a code-tag?
 
Old 02-04-2013, 10:30 PM   #8
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
xorg.0.log

I think it's attached.Xorg.0.log
 
Old 02-05-2013, 01:53 AM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Quote:
Originally Posted by CSA60 View Post
What's a code-tag?
See my signature.

Anyways, according to the log-file you are using the proprietary AMD driver and hardware acceleration is working, so I assume that the only problem is the Additional Drivers program showing you wrong information. If 3D acceleration is working I would just ignore that.
 
Old 02-05-2013, 04:09 AM   #10
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,376

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Quote:
Originally Posted by CSA60 View Post
What's a code-tag?
If you hit "Reply" at the top of the thread, it's that symbol '#' in the lineup. If you want to do it manually, it's CODE in [] to start and /CODE in [] to end
 
Old 02-05-2013, 10:34 AM   #11
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Should I mark this as solved. There still seems to be a bug somewhere in the OS and/or driver utility.
 
Old 02-06-2013, 03:18 AM   #12
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,376

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
If you really feel there's a bug, mark this solved, and get onto phoronix forums. The ati developers feel they can contact the world from there. Get on your forum and moan, but have your facts straight and follow instructions or you'll be ignored.
 
Old 02-06-2013, 04:34 AM   #13
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
The AMD developers have nothing to do with the Additional Driver program, that is developed by Canonical. Since the driver seems to work correctly I would report this as bug for the Additional Drivers software, not as driver bug.
 
Old 02-06-2013, 11:27 AM   #14
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Thanks. I'll mark this as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATi/AMD Proprietary FGLRX driver? "additional drivers" CrazyGuy158 Linux Mint 4 02-24-2012 11:21 AM
I activated the fglrx driver and now the system wont start, below is from syslog Daithi Linux - Newbie 4 06-10-2011 06:25 AM
ATI driver, fglrx - FATAL: Error inserting fglrx hubabuba Slackware 4 04-18-2009 01:27 PM
ati driver not activated - how do I do it? troublemaker05 Linux - Newbie 6 11-11-2008 11:35 PM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration