LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2008, 12:36 PM   #1
troublemaker05
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Rep: Reputation: 0
ati driver not activated - how do I do it?


Hello,
I have installed the latest ATI drivers for my radeon ati 9550 graphics card.
I did all the steps for sax2 to recognize the driver, which it does. But the catalyst control center has lots of bits greyed out and shows the bus setting as 0, when it should be 8. The OpenGl driver still shows as mesa.

I've been told it has something to do with the kernel and the driver not matching.
My kernel version is: 2.6.25.16-0.1
the fglrx driver versions are
ati-fglrx-kmp-default-8.522_2.6.25.16_0.1-1.1
x11-video-fglrxG01-8.522-2.6

How do I make x11-video-fglrxG01 match my kernel? When I try updating, it keeps installing the above versions.

I have never before installed a graphics card, so I don't know what to do at all.

Any help is greatly appreciated - I'm running suse11, btw.
 
Old 10-18-2008, 04:01 PM   #2
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
Hi mate

Can you give me the output of your /etc/X11/xorg.conf file? Chances are that although it's all installed, you haven't told X to use the fglrx driver so it's just using a standard ATI one.
 
Old 10-19-2008, 03:45 AM   #3
troublemaker05
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,
thanks for your reply, but I've given up on this subject now. Every step that has been suggested to me has failed. I've uninstalled fglrx.

Since I'm upgrading my mobo, I decided to get a new graphics card as well, this time an nvidia, because I've been told, there are less problems with nvidia and linux.

thanks anyway.
 
Old 10-19-2008, 10:27 AM   #4
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
No hassle installer script

Sorry, was for Debian only.

Link

Last edited by Junior Hacker; 10-19-2008 at 10:34 AM.
 
Old 11-11-2008, 03:15 PM   #5
neogeek23
Member
 
Registered: Jan 2006
Distribution: Kubuntu 8.10
Posts: 41

Rep: Reputation: 15
Same Problem

Hey I'm have that same problem... I think...

PHP Code:
# File generated by XFdrake (rev 247269)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
    
Identifier     "layout1"
    
Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         
"aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
    
InputDevice    "Keyboard1" "CoreKeyboard"
    
InputDevice    "Mouse1" "CorePointer"
EndSection

Section 
"Files"
EndSection

Section 
"Module"
    
Load  "dbe" # Double-Buffering Extension
    
Load  "v4l" # Video for Linux
    
Load  "extmod"
    
Load  "type1"
    
Load  "freetype"
    
Load  "glx" # 3D layer
    
Load  "dri" # direct rendering
EndSection

Section 
"ServerFlags"

    
#DontZap # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
 # allows the server to start up even if the mouse does not work
    
Option        "allowmouseopenfail"
EndSection

Section 
"InputDevice"
    
Identifier  "Keyboard1"
    
Driver      "kbd"
    
Option        "XkbModel" "pc105"
    
Option        "XkbLayout" "us"
    
Option        "XkbOptions" "compose:rwin"
EndSection

Section 
"InputDevice"
    
Identifier  "Mouse1"
    
Driver      "mouse"
    
Option        "Protocol" "ExplorerPS/2"
    
Option        "Device" "/dev/mouse"
EndSection

Section 
"Monitor"

    
# Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 89 dpi)
    
Identifier   "monitor1"
    
VendorName   "Plug'n Play"
    
ModelName    "HB191"
    
HorizSync    30.0 80.0
    VertRefresh  49.0 
75.0
    ModeLine     
"1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
    ModeLine     
"768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine     
"768x576" 63.1 768 800 960 1024 576 578 590 616
    ModeLine     
"1440x900_120" 229.8 1440 1552 1712 1984 900 901 904 965 -hsync +vsync
    ModeLine     
"1440x900_100" 187.6 1440 1544 1704 1968 900 901 904 953 -hsync +vsync
    ModeLine     
"1440x900_85" 156.8 1440 1536 1696 1952 900 901 904 945 -hsync +vsync
    ModeLine     
"1440x900_75" 136.5 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
    ModeLine     
"1440x900_60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    ModeLine     
"1440x900_50" 87.4 1440 1512 1664 1888 900 901 904 926 -hsync +vsync
    ModeLine     
"1280x800_120" 181.2 1280 1376 1520 1760 800 801 804 858 -hsync +vsync
    ModeLine     
"1280x800_100" 147.9 1280 1376 1512 1744 800 801 804 848 -hsync +vsync
    ModeLine     
"1280x800_85" 123.4 1280 1368 1504 1728 800 801 804 840 -hsync +vsync
    ModeLine     
"1280x800_75" 107.2 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
    ModeLine     
"1280x800_60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    ModeLine     
"1280x800_50" 68.6 1280 1336 1472 1664 800 801 804 824 -hsync +vsync
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-0"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-1"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Device"
    
Identifier  "device1"
    
Driver      "radeonhd"
    
VendorName  "ATI Technologies Inc"
    
BoardName   "ATI Radeon X1300 and later"
    
Option        "DPMS"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-0"
    
Driver      "fglrx"
    
Option        "DesktopSetup" "horizontal"
    
Option        "OverlayOnCRTC2" "0"
    
BusID       "PCI:1:0:0"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-1"
    
Driver      "fglrx"
    
BusID       "PCI:1:0:0"
    
Screen      1
EndSection

Section 
"Screen"
    
Identifier "screen1"
    
Device     "device1"
    
Monitor    "monitor1"
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-0"
    
Device     "aticonfig-Device[0]-0"
    
Monitor    "aticonfig-Monitor[0]-0"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
        Modes    
"1440x900" "1280x1024"
    
EndSubSection
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-1"
    
Device     "aticonfig-Device[0]-1"
    
Monitor    "aticonfig-Monitor[0]-1"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
    EndSubSection
EndSection 
PHP Code:
# File generated by XFdrake (rev 247269)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
    
Identifier     "layout1"
    
Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         
"aticonfig-Screen[0]-1" Above "aticonfig-Screen[0]-0"
    
InputDevice    "Keyboard1" "CoreKeyboard"
    
InputDevice    "Mouse1" "CorePointer"
EndSection

Section 
"Files"
EndSection

Section 
"Module"
    
Load  "dbe" # Double-Buffering Extension
    
Load  "v4l" # Video for Linux
    
Load  "extmod"
    
Load  "type1"
    
Load  "freetype"
    
Load  "glx" # 3D layer
    
Load  "dri" # direct rendering
EndSection

Section 
"ServerFlags"

    
#DontZap # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
 # allows the server to start up even if the mouse does not work
    
Option        "allowmouseopenfail"
EndSection

Section 
"InputDevice"
    
Identifier  "Keyboard1"
    
Driver      "kbd"
    
Option        "XkbModel" "pc105"
    
Option        "XkbLayout" "us"
    
Option        "XkbOptions" "compose:rwin"
EndSection

Section 
"InputDevice"
    
Identifier  "Mouse1"
    
Driver      "mouse"
    
Option        "Protocol" "ExplorerPS/2"
    
Option        "Device" "/dev/mouse"
EndSection

Section 
"Monitor"

    
# Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 89 dpi)
    
Identifier   "monitor1"
    
VendorName   "Plug'n Play"
    
ModelName    "HB191"
    
HorizSync    30.0 80.0
    VertRefresh  49.0 
75.0
    ModeLine     
"1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
    ModeLine     
"768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine     
"768x576" 63.1 768 800 960 1024 576 578 590 616
    ModeLine     
"1440x900_120" 229.8 1440 1552 1712 1984 900 901 904 965 -hsync +vsync
    ModeLine     
"1440x900_100" 187.6 1440 1544 1704 1968 900 901 904 953 -hsync +vsync
    ModeLine     
"1440x900_85" 156.8 1440 1536 1696 1952 900 901 904 945 -hsync +vsync
    ModeLine     
"1440x900_75" 136.5 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
    ModeLine     
"1440x900_60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    ModeLine     
"1440x900_50" 87.4 1440 1512 1664 1888 900 901 904 926 -hsync +vsync
    ModeLine     
"1280x800_120" 181.2 1280 1376 1520 1760 800 801 804 858 -hsync +vsync
    ModeLine     
"1280x800_100" 147.9 1280 1376 1512 1744 800 801 804 848 -hsync +vsync
    ModeLine     
"1280x800_85" 123.4 1280 1368 1504 1728 800 801 804 840 -hsync +vsync
    ModeLine     
"1280x800_75" 107.2 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
    ModeLine     
"1280x800_60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    ModeLine     
"1280x800_50" 68.6 1280 1336 1472 1664 800 801 804 824 -hsync +vsync
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-0"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-1"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Device"
    
Identifier  "device1"
    
Driver      "radeonhd"
    
VendorName  "ATI Technologies Inc"
    
BoardName   "ATI Radeon X1300 and later"
    
Option        "DPMS"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-0"
    
Driver      "fglrx"
    
BusID       "PCI:1:0:0"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-1"
    
Driver      "fglrx"
    
BusID       "PCI:1:0:0"
    
Screen      1
EndSection

Section 
"Screen"
    
Identifier "screen1"
    
Device     "device1"
    
Monitor    "monitor1"
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-0"
    
Device     "aticonfig-Device[0]-0"
    
Monitor    "aticonfig-Monitor[0]-0"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-1"
    
Device     "aticonfig-Device[0]-1"
    
Monitor    "aticonfig-Monitor[0]-1"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
    EndSubSection
EndSection 
PHP Code:
# File generated by XFdrake (rev 247269)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
    
Identifier     "layout1"
    
Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         
"aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
    
InputDevice    "Keyboard1" "CoreKeyboard"
    
InputDevice    "Mouse1" "CorePointer"
EndSection

Section 
"Files"
EndSection

Section 
"Module"
    
Load  "dbe" # Double-Buffering Extension
    
Load  "v4l" # Video for Linux
    
Load  "extmod"
    
Load  "type1"
    
Load  "freetype"
    
Load  "glx" # 3D layer
    
Load  "dri" # direct rendering
EndSection

Section 
"ServerFlags"

    
#DontZap # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
 # allows the server to start up even if the mouse does not work
    
Option        "allowmouseopenfail"
EndSection

Section 
"InputDevice"
    
Identifier  "Keyboard1"
    
Driver      "kbd"
    
Option        "XkbModel" "pc105"
    
Option        "XkbLayout" "us"
    
Option        "XkbOptions" "compose:rwin"
EndSection

Section 
"InputDevice"
    
Identifier  "Mouse1"
    
Driver      "mouse"
    
Option        "Protocol" "ExplorerPS/2"
    
Option        "Device" "/dev/mouse"
EndSection

Section 
"Monitor"

    
# Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 89 dpi)
    
Identifier   "monitor1"
    
VendorName   "Plug'n Play"
    
ModelName    "HB191"
    
HorizSync    30.0 80.0
    VertRefresh  49.0 
75.0
    ModeLine     
"1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
    ModeLine     
"768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine     
"768x576" 63.1 768 800 960 1024 576 578 590 616
    ModeLine     
"1440x900_120" 229.8 1440 1552 1712 1984 900 901 904 965 -hsync +vsync
    ModeLine     
"1440x900_100" 187.6 1440 1544 1704 1968 900 901 904 953 -hsync +vsync
    ModeLine     
"1440x900_85" 156.8 1440 1536 1696 1952 900 901 904 945 -hsync +vsync
    ModeLine     
"1440x900_75" 136.5 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
    ModeLine     
"1440x900_60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    ModeLine     
"1440x900_50" 87.4 1440 1512 1664 1888 900 901 904 926 -hsync +vsync
    ModeLine     
"1280x800_120" 181.2 1280 1376 1520 1760 800 801 804 858 -hsync +vsync
    ModeLine     
"1280x800_100" 147.9 1280 1376 1512 1744 800 801 804 848 -hsync +vsync
    ModeLine     
"1280x800_85" 123.4 1280 1368 1504 1728 800 801 804 840 -hsync +vsync
    ModeLine     
"1280x800_75" 107.2 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
    ModeLine     
"1280x800_60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    ModeLine     
"1280x800_50" 68.6 1280 1336 1472 1664 800 801 804 824 -hsync +vsync
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-0"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Monitor"
    
Identifier   "aticonfig-Monitor[0]-1"
    
Option        "VendorName" "ATI Proprietary Driver"
    
Option        "ModelName" "Generic Autodetecting Monitor"
    
Option        "DPMS" "true"
EndSection

Section 
"Device"
    
Identifier  "device1"
    
Driver      "radeonhd"
    
VendorName  "ATI Technologies Inc"
    
BoardName   "ATI Radeon X1300 and later"
    
Option        "DPMS"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-0"
    
Driver      "fglrx"
    
BusID       "PCI:1:0:0"
EndSection

Section 
"Device"
    
Identifier  "aticonfig-Device[0]-1"
    
Driver      "fglrx"
    
BusID       "PCI:1:0:0"
    
Screen      1
EndSection

Section 
"Screen"
    
Identifier "screen1"
    
Device     "device1"
    
Monitor    "monitor1"
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-0"
    
Device     "aticonfig-Device[0]-0"
    
Monitor    "aticonfig-Monitor[0]-0"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section 
"Screen"
    
Identifier "aticonfig-Screen[0]-1"
    
Device     "aticonfig-Device[0]-1"
    
Monitor    "aticonfig-Monitor[0]-1"
    
DefaultDepth     24
    SubSection 
"Display"
        
Viewport   0 0
        Depth     24
    EndSubSection
EndSection 
Now I'm not entirely sure I'm reading this right, but if I am... I have correctly installed the device and the drivers but Mandriva hasn't recognized that I have installed these drivers. So how do I beat some sense into it?
 
Old 11-11-2008, 11:15 PM   #6
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Quote:
Originally Posted by neogeek23 View Post
Now I'm not entirely sure I'm reading this right, but if I am... I have correctly installed the device and the drivers but Mandriva hasn't recognized that I have installed these drivers. So how do I beat some sense into it?
I'm an Nvidia user, but I think the device driver to use in your case is "fglrx" not "radeonhd".
You have too many "device", "monitor" and "screen" sections in your config file,...just asking for trouble.
 
Old 11-11-2008, 11:35 PM   #7
lurid
LQ Newbie
 
Registered: May 2007
Location: Pennsylvania, USA
Distribution: Ubuntu Studio 9.10
Posts: 29

Rep: Reputation: 15
I used to use a Radeon 9550 and 3D acceleration was never available for it while I used it. I don't know if this ever changed, but considering its age, I doubt it. Phoronix.com has good video card benchmarks which could help you decide what card to replace that Radeon with.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
r8169.ko driver automatically activated, card detected but link is down arani Linux - Networking 1 02-14-2008 12:03 PM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM
nVidia problem rainbow colors when 3d driver is activated chadl Linux - Hardware 9 09-30-2005 11:09 AM
Floppy driver gets activated when using USB Flash drive iradi8 Linux - Hardware 0 07-28-2004 01:13 PM
Floppy driver gets activated when using USB Flash drive iradi8 Linux - Laptop and Netbook 0 07-16-2004 11:47 AM


All times are GMT -5. The time now is 12:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration