LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 02-12-2014, 05:42 PM   #1
SAJM
Member
 
Registered: Nov 2012
Location: Essex UK
Distribution: Slackware
Posts: 49

Rep: Reputation: Disabled
Upgrade gcc


I'm installing XAMPP, it failed because the gcc version was old. I downloaded the latest version (4.8.2) from gnu.org and read up on the installation. The instructions might as well have been written in hieroglyphics, I could not even get beyond unpacking the tar package! It dawned upon me there must be packages from Slackware that make this process a little easier but I cannot find them on the web.

Any pointers greatly received.

Thanks
 
Old 02-12-2014, 06:11 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Slackware 14.1 has already GCC 4.8.2, which version are you using?
 
Old 02-12-2014, 06:58 PM   #3
SAJM
Member
 
Registered: Nov 2012
Location: Essex UK
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Slackware 14.1 has already GCC 4.8.2, which version are you using?
I've got Slackware 12, gcc is v 4.1
 
Old 02-12-2014, 07:08 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
You shouldn't use Slackware 12, it is out of support and does not get any security upgrades. Upgrade the whole system to a supported version. When I think about it, why are youe even trying to install XAMPP, doesn't Slackware come with all of its components by default?
 
Old 02-12-2014, 07:19 PM   #5
SAJM
Member
 
Registered: Nov 2012
Location: Essex UK
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
You shouldn't use Slackware 12, it is out of support and does not get any security upgrades. Upgrade the whole system to a supported version. When I think about it, why are youe even trying to install XAMPP, doesn't Slackware come with all of its components by default?
I did not install those components at the time and now I need them. You are right though I may just upgrade the whole OS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why gcc is needed for an HBA card? How to upgrade gcc enayet_v Linux - Newbie 3 11-17-2007 05:57 AM
How to upgrade to gcc 4.1.2 from gcc 3.4.4 on Slackware 11.0 lali.p Slackware 4 09-10-2007 07:31 AM
Upgrade from gcc 3.X to gcc 4.0 in Slackware Bob_H Linux - Software 2 06-01-2006 09:51 PM
gcc Upgrade (RH 7.3) ejfuente Linux - Newbie 1 10-21-2003 10:37 AM
gcc upgrade tundra Linux - General 10 09-08-2002 04:11 AM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration