LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Upgrade gcc (http://www.linuxquestions.org/questions/slackware-installation-40/upgrade-gcc-4175494702/)

SAJM 02-12-2014 04:42 PM

Upgrade gcc
 
I'm installing XAMPP, it failed because the gcc version was old. I downloaded the latest version (4.8.2) from gnu.org and read up on the installation. The instructions might as well have been written in hieroglyphics, I could not even get beyond unpacking the tar package! It dawned upon me there must be packages from Slackware that make this process a little easier but I cannot find them on the web.

Any pointers greatly received.

Thanks

TobiSGD 02-12-2014 05:11 PM

Slackware 14.1 has already GCC 4.8.2, which version are you using?

SAJM 02-12-2014 05:58 PM

Quote:

Originally Posted by TobiSGD (Post 5116498)
Slackware 14.1 has already GCC 4.8.2, which version are you using?

I've got Slackware 12, gcc is v 4.1

TobiSGD 02-12-2014 06:08 PM

You shouldn't use Slackware 12, it is out of support and does not get any security upgrades. Upgrade the whole system to a supported version. When I think about it, why are youe even trying to install XAMPP, doesn't Slackware come with all of its components by default?

SAJM 02-12-2014 06:19 PM

Quote:

Originally Posted by TobiSGD (Post 5116530)
You shouldn't use Slackware 12, it is out of support and does not get any security upgrades. Upgrade the whole system to a supported version. When I think about it, why are youe even trying to install XAMPP, doesn't Slackware come with all of its components by default?

I did not install those components at the time and now I need them. You are right though I may just upgrade the whole OS.


All times are GMT -5. The time now is 12:00 PM.