LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-16-2007, 10:44 AM   #1
enayet_v
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Rep: Reputation: 0
Why gcc is needed for an HBA card? How to upgrade gcc


I am working on EMC SAN environment and want to integrate a Linux 2.26 host in the SAN. But I am not getting the HBA card (WWN number) in the SAN Switch that I have attached a FC cable with the HBA port. After issuing dmesg command I have found the following message:

qla2xxx_conf: version magic '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2' should be '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4'
qla2xxx_conf: version magic '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2' should be '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4'
qla2xxx: version magic '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2' should be '2.6.9-42.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4'

I don't understand what it means. Please help me resolve it. Can you please tell me how I can see the harware model from Linux. And also how can I upgrade to gcc-3.4? What file needed to do that?
enayet_csl@yahoo.com, enayet@csl-bd.com
 
Old 11-16-2007, 11:36 AM   #2
mrrangerman
Member
 
Registered: Oct 2007
Location: MI
Distribution: Debian Slackware
Posts: 528

Rep: Reputation: 50
First welcome to linuxquestions.org

Second of all don't post you e-mail address unless you love getting spam.

What Linux Distro are you using? Use the package manager for your distro to see if gcc-3.4 is available.

In Debian you would open up Synaptic Package Manager, use the search to see if gcc-3.4 is available. Check/mark it for install then install.

Or you can fine the version you want to download Here.
 
Old 11-17-2007, 04:00 AM   #3
enayet_v
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks and need more info

Hi,
Thanks for your information. The OS is RedHat Linux Enterprise 2.6. But the it is also showing "CentOS". I have downloaded the gcc-3.4.6.tar.gz from the link you provided. But please make me sure that the gcc needs to be upgraded or not.

Will be grateful if you response.



Quote:
Originally Posted by mrrangerman View Post
First welcome to linuxquestions.org

Second of all don't post you e-mail address unless you love getting spam.

What Linux Distro are you using? Use the package manager for your distro to see if gcc-3.4 is available.

In Debian you would open up Synaptic Package Manager, use the search to see if gcc-3.4 is available. Check/mark it for install then install.

Or you can fine the version you want to download Here.
 
Old 11-17-2007, 04:57 AM   #4
enayet_v
LQ Newbie
 
Registered: Nov 2007
Posts: 3

Original Poster
Rep: Reputation: 0
What is the difference between DKMS RPM and RPM?

Please provide me the difference between DKMS RPM and RPM. And when it is preffered to install.

Quote:
Originally Posted by enayet_v View Post
Hi,
Thanks for your information. The OS is RedHat Linux Enterprise 2.6. But the it is also showing "CentOS". I have downloaded the gcc-3.4.6.tar.gz from the link you provided. But please make me sure that the gcc needs to be upgraded or not.

Will be grateful if you response.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to upgrade to gcc 4.1.2 from gcc 3.4.4 on Slackware 11.0 lali.p Slackware 4 09-10-2007 06:31 AM
Upgrade from gcc 3.X to gcc 4.0 in Slackware Bob_H Linux - Software 2 06-01-2006 08:51 PM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare Suse/Novell 3 11-29-2004 02:13 PM
gcc or similar compiler needed. robmcw Linux - Newbie 6 07-07-2003 05:53 AM
Help needed for installing gcc-2.95.3 bush Linux - Newbie 1 05-13-2003 10:56 AM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration