LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-19-2010, 07:21 AM   #1
Linux.Girl
Member
 
Registered: Aug 2010
Posts: 42

Rep: Reputation: 2
nm-applet icon missing


Hello everyone,

I am completely new both here and in Linux. I carefully read the threads where you explain where to post what, and even searched for previous postings which might have already answered my question, unfortunately, I still got the problem.

Since my distro is CentOS 5.5, I decided to post here, hope it was the right decision (if not, please let me know where I should have posted).

So as the subject says, I installed CentOS and can't manage to make the nm-applet icon show on the notification area.

I read previous threads about this, which suggest that perhaps nm-applet is not running, or that perhaps I did not add a notification area to the panel, or that maybe nm-applet --sm-disable is not showing on sys-sessions. Unfortunately, all the above is ok, i.e, nm-applet is running, I do have a notification area and "nm-applet --sm-disable" appears as it should in the right place.

Do you have any other suggestions?

Many thanks in advance.

Linux.Girl

Last edited by Linux.Girl; 08-19-2010 at 07:22 AM.
 
Old 08-19-2010, 04:50 PM   #2
Linux.Girl
Member
 
Registered: Aug 2010
Posts: 42

Original Poster
Rep: Reputation: 2
Hello, if I give more details maybe someone can help me? I tried to do a killall gnome-panel and then check .xsession-errors to see if I could get a clue of what is wrong. Of course, I took this tip from someone else and even more "of course", I did not understand the result. Here is what is said, maybe it will give the experts a clue as to why my nm-applet icon is not showing?

cat /home/me/.xsession-errors gives the following:

** (nm-applet:4319): WARNING **: No connections defined

** (nm-applet:4319): WARNING **: Invalid return value type: GPtrArray_DBusGObjectPath_
Introspect error: The name edu.duke.linux.yum was not provided by any .service files
Traceback (most recent call last):
File "/usr/bin/puplet", line 467, in ?
main()
File "/usr/bin/puplet", line 464, in main
p.run()
File "/usr/bin/puplet", line 451, in run
self._refreshInfo()
File "/usr/bin/puplet", line 191, in _refreshInfo
if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'


I don't know if this is related or not, can you please please help me?

Thanks in advance.

Linux.Girl

Last edited by Linux.Girl; 08-19-2010 at 04:54 PM.
 
Old 08-19-2010, 05:42 PM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 220Reputation: 220Reputation: 220
When the nm-applet icon doesn't show, it means either nm-applet isn't running, or NetworkManager isn't running. Open a terminal window and enter
Code:
ps ax | grep nm-applet
to see if nm-applet is running, and
Code:
ps ax | grep NetworkManager
to see if NetworkManager is running. If Networkmanager isn't running, then, as root, run
Code:
/etc/init.d/NetworkManager
I had a problem today in Fedora 14 alpha with nm-applet not showing up or running even though NetworkManager appeared to be running. My fix was to downgrade the versions of NetworkManager, NetworkManager-glib, and
NetworkManager-gnome.
 
1 members found this post helpful.
Old 08-20-2010, 07:05 AM   #4
Linux.Girl
Member
 
Registered: Aug 2010
Posts: 42

Original Poster
Rep: Reputation: 2
WOW!!! it worked, can't believe it - so many thanks!!!

Now the weird thing is that both network manager and applet appeared as running, but it seems they weren't after all. After I did a start on /etc/init.d/NetworkManager the icon appeared!

[m@localhost ~]$ ps ax | grep nm-applet
3257 ? Ss 0:00 nm-applet --sm-disable
3584 pts/1 S+ 0:00 grep nm-applet

[me@localhost ~]$ ps ax | grep NetworkManager
3272 ? S 0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
3586 pts/1 R+ 0:00 grep NetworkManager

[me@localhost ~]$ su

[root@localhost me]# /etc/init.d/NetworkManager start
Setting network parameters... [ OK ]
Starting NetworkManager daemon: [ OK ]
[root@localhost me]#

Why would networkmanager and applet appear as running when actually they weren't?
 
Old 08-20-2010, 03:57 PM   #5
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 220Reputation: 220Reputation: 220
Quote:
After I did a start on /etc/init.d/NetworkManager the icon appeared!
That is how it works for me (when working properly).

Are you saying that after you did the start on /etc/init.d/NetworkManager it wasn't actually working even though the nm-applet icon appeared?
 
1 members found this post helpful.
Old 08-20-2010, 07:30 PM   #6
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Restart the system and check if nm-applet shows. If not, then you need to set NetworkManager to start on boot.

I have not checked, but it is possible that if NetworkManager service is not running nm-applet does not show icon.
 
Old 08-21-2010, 06:50 AM   #7
Linux.Girl
Member
 
Registered: Aug 2010
Posts: 42

Original Poster
Rep: Reputation: 2
Hi RockDoctor, thanks for your help - what you told me to do worked. I started networkmanager and the icon appeared. I was just puzzled because BEFORE I started networkmanager, it was showing itself as working and the icon was not there. The I hit restart (after your tip) and the icon appeared.

In any event, case solved, many thanks for the help!

@DrLove73 - how do I make sure networkmanager starts on boot?

Thanks in advance.

Linux.Girl
 
Old 08-21-2010, 10:51 AM   #8
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
System -> Administration -> Server Settings -> Services
or
System -> Administration -> Services

and then make sure you tick NetworkManager ans Save settings.

Manually, you would run (as root):
Code:
chkconfig --level 2345 NetworkManager on
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to shutdown - panel applet missing a_m0d Linux - Desktop 8 07-05-2013 08:28 AM
[SOLVED] nm-applet and battery missing from indicator applet in lucid someshpr Ubuntu 2 11-16-2010 05:02 PM
Still can't Restore Missing Network Manager Applet daniell Linux - Newbie 5 07-03-2009 05:34 AM
Samba Icon Missing kaede Linux - Networking 4 08-16-2005 10:40 AM
gaim tray icon / applet problem shadow.blue Linux - Software 1 06-27-2003 11:53 AM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration