LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-06-2004, 02:43 AM   #1
nedian123
Member
 
Registered: Jun 2004
Location: PAKISTAN
Posts: 46

Rep: Reputation: 15
Angry mounting error


hi,
i m unable to share the /home of server. when i mount -a on the slave an error is generated

mount: host1:/home failed, reason given by server: permission denied


the /etc/hosts files on both server and slave r same.
on the server the contents of file /etc/exports are

/home *.192.168.0.20/24(rw,sync,no_root_squash)



Akhtar
 
Old 12-08-2004, 11:30 PM   #2
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Re: mounting error

Quote:
Originally posted by nedian123
on the server the contents of file /etc/exports is

/home *.192.168.0.20/24(rw,sync,no_root_squash)
[/B]
It looks to me like the net/mask entry of the ip addresses in /etc/exports is incorrect. The "*." at the front of the net/mask does not make sense. Combining that with a net/mask combination is not permitted. The entry should be as follows:
Code:
/home 192.168.0.20/24(rw,sync,no_root_squash)
By the way, using no_root_squash is somewhat dangerous. A user logged in as root on a client (slave) would have complete access to /home after they mount it.

Bill

Last edited by wmakowski; 12-08-2004 at 11:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting error javier_ccs Linux - Newbie 1 06-17-2005 10:57 AM
mounting error mm3000 Slackware 17 07-31-2004 08:16 PM
mounting error Uldis Slackware - Installation 2 07-04-2004 01:58 PM
Error while Mounting Smooth Linux - Newbie 2 08-12-2003 11:01 PM
installation error: Error mounting sda1: Invalid Argument sadirmata Linux - Newbie 1 01-29-2002 02:28 AM


All times are GMT -5. The time now is 03:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration