Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 10-01-2003, 09:44 AM   #1
Registered: Mar 2003
Posts: 126

Rep: Reputation: 17
gnome / metacity became very slow...

Howdy Folks,

My rh9 box is up2date, but after a few changes to my system, gnome has become extremely slow. Logging in hangs on the splash screen - taking around 30 sec for each icon (panel, etc) to load. Further, the panel never appears (waited several minutes).

What I changed:[list=1][*] added a raid array for doc storage - not used for any system files (mounted as /vault)[*] updated openssl via up2date[*] moved my /home directory to a separate partition. - this is what I think caused the issue (though permissions were fine), so I moved it back - and the issue persisted[/list=1]

the raid array is in sync, not active, and I think I've ruled it out as an issue. "top" shows that the system is almost totally idle. /var/log/messages is not much help, nothing is complaining, no errors, etc.

The system runs fine otherwise (mailserver, webserver, etc) and has not lost responsiveness other that this login oddness.

thoughts? -Larry
Old 10-01-2003, 07:02 PM   #2
Registered: Sep 2003
Location: Somerville, MA
Distribution: Fedora/RHEL currently. Red Hat, Slackware, Debian, SuSe and Mandrake at other times
Posts: 104

Rep: Reputation: 15
A couple of things you might do to get started troubleshooting:

Go into runlevel3 and run startx -- does the problem persist?

If so, try using ltrace and strace, which track the library and system calls being used by an application.

strace -o startx-strace.out startx

would store the system call history of startx (including gnome-session) and could maybe give you a hint as to what is taking so long (look for a string of failed attempts to access or open some kind of file, maybe?)

Also, could there be a DNS issue? Gnome uses dns to lookup the machine's name. Perhaps these are DNS timeouts?

These are all just wild guesses. There's really not enough info for me to give more at this point. Try this stuff out and see what you find.

Old 10-09-2003, 10:49 AM   #3
LQ Newbie
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
same problem

I have the same problem. If you fixed yours please reply
Old 10-09-2003, 02:25 PM   #4
LQ Newbie
Registered: Oct 2003
Distribution: RH9
Posts: 18

Rep: Reputation: 0
Try downloading specific updated drivers off of your video card's official site. Or buy a new one all together...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME freezes when loading metacity CPUFreak91 Slackware 6 11-10-2005 05:24 PM
gnome-metacity SeptivaOra Linux - Newbie 0 02-15-2005 01:55 AM
move window up in gnome/metacity? codec Linux - Software 3 09-18-2004 04:05 PM
running enlightenment instead of metacity with gnome - how? xscousr Fedora 0 07-29-2004 09:45 AM
BLFS: Gnome control-center and metacity Dark_Helmet Linux From Scratch 1 05-29-2003 03:48 PM

All times are GMT -5. The time now is 12:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration