LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2004, 06:54 PM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,427

Rep: Reputation: 53
Fail to start KDE as USER


Hi folks,

RH 8.0

My PC started KDE at boot without problem before. Now for unknow reason KDE fails to start

Booting to TEXT mode (init5).

Login as USER
$ startx
GNOME started automatically not Xterm window nor KDE

$ startkde
OR
$ startx startkde

it prompted;
using Config file:"/etc/X11/XF86Config"
/usr/X11R6/bin/xterm bad command line option "kde"

I tried to read /usr/X11R6/bin/xterm, only codes there.

Login as ROOT
$ startx
KDE started

Kindly advise how to fix the problem

TIA

B.R.
satimis
 
Old 07-03-2004, 07:38 PM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
from your text mode terminal session, invoke:
switchdesk kde
 
Old 07-03-2004, 08:56 PM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,427

Original Poster
Rep: Reputation: 53
Quote:
Originally posted by idaho
from your text mode terminal session, invoke:
switchdesk kde
Hi idaho,

Tks for your advice which works for me.

Steps taken as follows;

Booting PC to text mode (init5) and login as USER

$ switchdesk kde
...
Desktop now set up to run KDE
For system default, remove /home/user/Xclient

$ startx
KDE started

Rebooting the PC, it went straight to text mode instead of starting GUI login screen.

Kindly advise how to fix it.

TIA

B.R.
satimis
 
Old 07-03-2004, 10:00 PM   #4
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,427

Original Poster
Rep: Reputation: 53
Hi idaho,

Further to my last posting, problem solved as follows;


edit /etc/inittab
changing
id:3:initdefault:
to
id:5:initdefault:
done

rebooting PC, GUI login screen started.

But I still can't find out the cause of the
problem encountered.

Anyway lot of thanks for your advice and
time spent.

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde fail to start eddy98 Suse/Novell 1 03-07-2005 02:15 AM
KDE 3.2 won't start as user now.... r3dhatter Linux - General 3 05-16-2004 11:26 PM
cannot start kde as a user in slackware andy753421 Linux - General 3 04-25-2004 08:45 PM
Can no longer start kde as a normal user J_Szucs Linux - Software 4 03-15-2004 08:04 AM
Fail to start KDE satimis *BSD 2 02-26-2004 08:46 PM


All times are GMT -5. The time now is 11:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration