LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Fail to start KDE as USER (http://www.linuxquestions.org/questions/red-hat-31/fail-to-start-kde-as-user-200825/)

satimis 07-03-2004 06:54 PM

Fail to start KDE as USER
 
Hi folks,

RH 8.0

My PC started KDE at boot without problem before. Now for unknow reason KDE fails to start

Booting to TEXT mode (init5).

Login as USER
$ startx
GNOME started automatically not Xterm window nor KDE

$ startkde
OR
$ startx startkde

it prompted;
using Config file:"/etc/X11/XF86Config"
/usr/X11R6/bin/xterm bad command line option "kde"

I tried to read /usr/X11R6/bin/xterm, only codes there.

Login as ROOT
$ startx
KDE started

Kindly advise how to fix the problem

TIA

B.R.
satimis

idaho 07-03-2004 07:38 PM

from your text mode terminal session, invoke:
switchdesk kde

satimis 07-03-2004 08:56 PM

Quote:

Originally posted by idaho
from your text mode terminal session, invoke:
switchdesk kde

Hi idaho,

Tks for your advice which works for me.

Steps taken as follows;

Booting PC to text mode (init5) and login as USER

$ switchdesk kde
...
Desktop now set up to run KDE
For system default, remove /home/user/Xclient

$ startx
KDE started

Rebooting the PC, it went straight to text mode instead of starting GUI login screen.

Kindly advise how to fix it.

TIA

B.R.
satimis

satimis 07-03-2004 10:00 PM

Hi idaho,

Further to my last posting, problem solved as follows;


edit /etc/inittab
changing
id:3:initdefault:
to
id:5:initdefault:
done

rebooting PC, GUI login screen started.

But I still can't find out the cause of the
problem encountered.

Anyway lot of thanks for your advice and
time spent.

B.R.
satimis


All times are GMT -5. The time now is 06:43 AM.