LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2006, 12:27 PM   #1
broknindarkagain
Member
 
Registered: May 2006
Location: Atlanta
Distribution: WinXP, Ubuntu
Posts: 64

Rep: Reputation: 15
No mouse and poor graphics on Puppy 2


I have been using DSL for quite awhile now, but latley I have been looking for something new. I tried Suse, Ubuntu, and Xubuntu...but I didnt have enough hard drive space for any of them (I have a 1gb drive) I heard a lot about Puppy linux, so I decided to give it a shot. Things were terrible.

I first tried to boot up off of the Live CD, and the boot process went fine...I got into the Window Manager, and had no mouse...and the graphics looked like they were 800x600pxls with 256color. Since my mouse would not work, I couldnt play around with it that much to figure it out.

I have a USB optical mouse and a ATI Rage video card on a Pentium2 266MHz w/ 128 ram.

My hardware seems to work fine with all the other distros I have tried out. Does anyone know what could be causing my mouse and video card not to work properly and how I can fix it?

I would love to try out puppy linux, but so far it dosnt look like I will be able to.
 
Old 07-06-2006, 12:40 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
boot up with your DSL again and check out your configuration file for X (in /etc/X11/ folder). youll want to focus on the mouse inputDevice section.. write down the protocol, device, buttons options. boot into puppy again, press CTRL + ALT + BACKSPACE to kill X. then, in the console, use vi to edit the /etc/X11/xorg.conf file, replacing the 3 options in the mouse section with those that worked in DSL. save the file with ESC, :x, [enter]. then 'startx' again.. does the mouse work? if not maybe you need to 'modprobe' some usb device drivers.. run 'lsmod > lsmodOutput.txt' save the file to your harddrive (ie not to ram), reboot into DSL, and paste the contents of that file. also do the same for 'dmesg | grep -i usb'.

hope it helps at all, good luck
 
Old 07-06-2006, 01:05 PM   #3
broknindarkagain
Member
 
Registered: May 2006
Location: Atlanta
Distribution: WinXP, Ubuntu
Posts: 64

Original Poster
Rep: Reputation: 15
That sounds like it will work, I didnt even think about ctrl-alt-bcksps to exit X. I will definatly try that as soon as I get home. Thanks a lot for the info, ill let you know if it works or not
 
Old 07-07-2006, 03:49 AM   #4
marksouth2000
Puppy Motivator
 
Registered: Oct 2004
Location: The Shadowy Planet
Distribution: Too many to mention
Posts: 111

Rep: Reputation: 15
Broknindarkagain, you don't say which version of Puppy you tried. The latest versions are 1.09CE and 2.01. If one doesn't work for you it may be worth trying the other. Your issues are definitely not because your hardware isn't powerful enough, I have Puppy 2 running on a 133 MHz Pentium 1 with 80 Mb of RAM and a 2 Gb disk with 128 Mb of swap. Display runs at 800x600x16.

Also, Can you try booting with a PS/2 mouse? One of the recent versions had some USB mouse detection issues at boot if I recall correctly.
 
Old 08-26-2006, 02:36 AM   #5
darinbolson
Member
 
Registered: Jan 2006
Distribution: multi booting whatever I feel like. Grub rocks!
Posts: 85

Rep: Reputation: 15
I've been seeing a lot of posts about puppy mouse problems with usb mouse. The technical guys here tell you to edit certain files, which can be difficult for the novice, or someone who just plain doesn't care to know HOW things work, and just wants them to work so they can get on with their day. As I understand it, puppy is meant to be a user friendly distro with the MSWindows user in mind. THERE IS AN EASY WAY to get your usb mouse to work. Just hit f12 after puppy boots up and use your arrow keys to navigate to the mouse wizard. you should see usb as an option. select that and then OK. your mouse should now work, but, you have to do this every time you boot.

Last edited by darinbolson; 08-26-2006 at 02:39 AM.
 
Old 08-26-2006, 02:38 AM   #6
darinbolson
Member
 
Registered: Jan 2006
Distribution: multi booting whatever I feel like. Grub rocks!
Posts: 85

Rep: Reputation: 15
Quote:
Originally Posted by marksouth2000
One of the recent versions had some USB mouse detection issues at boot if I recall correctly.
Both 2.01 and 2.02 have this problem.
 
Old 08-26-2006, 02:44 AM   #7
darinbolson
Member
 
Registered: Jan 2006
Distribution: multi booting whatever I feel like. Grub rocks!
Posts: 85

Rep: Reputation: 15
Quote:
Originally Posted by broknindarkagain
the graphics looked like they were 800x600pxls with 256color.
The default settings ARE crappy. When you first boot this thing, you have two options. choose the second one and proceed to tell it what kind of monitor you have.
 
Old 08-29-2006, 03:09 PM   #8
marksouth2000
Puppy Motivator
 
Registered: Oct 2004
Location: The Shadowy Planet
Distribution: Too many to mention
Posts: 111

Rep: Reputation: 15
Quote:
Originally Posted by darinbolson
The default settings ARE crappy. When you first boot this thing, you have two options. choose the second one and proceed to tell it what kind of monitor you have.
The original post looks like it was based on a very out-of-date Puppy version. 2.02 runs happily at 1280x1024 in 24-bit colour here. This is because recent Puppies have included the main range of X.org servers, while early versions came only with the xvesa/k-drive server.
 
Old 08-29-2006, 04:37 PM   #9
jackag
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Rep: Reputation: 0
I am running puppy 202 with a usb mouse

to make mouse active went thru the following actions:

used f12 key to bring up menu.
used kb updn keys to select setup kb buttons to navigate to
select mouse wizard
dn to mouse type
dn to usb type
tab to ok
dn to ok
after abt 10 sec delay mouse becomes active.

hope this helps. Jack
 
Old 08-29-2006, 04:41 PM   #10
jackag
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Rep: Reputation: 0
on the usb mouse detection problem.

If you have a save file for your changes setup,
you can go into a load file and make a setting that will automatically detect your mouse.

go to /etc/rc.d
edit rc.local file
add this to end of entries in file:modprobe usbhid
save file and make sure you exit puppy with reboot or stop.
so the save can take place.

Jack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor graphics performance Ross Clement Linux - Laptop and Netbook 1 09-13-2005 01:20 PM
Yet another i810 graphics problem, very very poor 3D support Merlinfmct87 Linux - Software 12 04-14-2005 06:19 AM
poor graphics performance after kernel upgrade (2.6.11.6) geomatt Slackware 6 04-06-2005 11:14 AM
Poor graphics performance himyuza Slackware 13 02-25-2005 01:30 AM
UT2003 - Poor sound and graphics Stevetgn Linux - Software 6 01-25-2004 03:38 PM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration