LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-25-2004, 08:08 AM   #1
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Rep: Reputation: 30
Question UT2003 - Poor sound and graphics


I've finally got UT2003 installed, but the sound is distorted and slightly speeded up! (almost like a sample rate problem) Also the graphics performance is very poor. I have the nVidia drives installed ok, TUX racer etc work fine. UT2003 is my favorite game and now my only reason left to boot into windows. Please help!

Thanks in advance

Steve
 
Old 01-25-2004, 08:53 AM   #2
a2ps
Member
 
Registered: Oct 2003
Location: Oeiras, Portugal
Distribution: Fedora Core 4
Posts: 30

Rep: Reputation: 15
did you install under wine or did you use the linux install on the 3rd cd? in that case everything should work ok, check if there are any latest drivers for your gc, and dont forget when installing new ones you MUST uninstall the old ones first.

i have a radeon 9700 with the latest driovers installed and ut2003 just runs even better than on windows, with more fps i mean.

sorry im not beeing much helpfull, but if you say it runs the tux racer well, than its not a drivers issue, maybe your trying to run ut2003 with all the settings on maximum?...
 
Old 01-25-2004, 01:22 PM   #3
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
Yes I used the 3rd CD and did the full Linux install (No Wine) and I have a Geforce FX5900 it flys in windows with ut2003. Bummer! I really want to get this working.

Thanks for your reply anyway my friend. Can anyone else help?
 
Old 01-25-2004, 01:51 PM   #4
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
Some possibilities:
1) Make sure you install all the patches
2) If you're using KDE or Gnome you may want to kill artsd or esound...it only clogs up the system IMO.
3) try making a symlink UT2003/system/openal.so leading to your system's openal (if it exists...back up the UT2003 openal first)
4) try the same with SDL
5) Could be you're missing libsmpeg
 
Old 01-25-2004, 02:17 PM   #5
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
I'll try your suggestions but it sound a bit scary for a newbie!

Thanks for your help
 
Old 01-25-2004, 03:48 PM   #6
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
It may be enough just upgrading to 2225...I've heard some people who have had audio issues had them fixed with this patch.

Only thing about the Linux UT, though, is you need to install all the patches in order (or somehow get the updater to work) rather than just the most recent one.



first 5 patches are here (plus the 2225 tarball, if it works for you):
http://www.beyondunreal.com/dl_home....ficial/ut2003/

and the 2225 .bin.sh:
unreal.epicgames.com/linux/ut2003/ut2003lnx_full2225.sh.bin
 
Old 01-25-2004, 04:38 PM   #7
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
Thanks Mik, I'll try that later. Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor graphics performance Ross Clement Linux - Laptop and Netbook 1 09-13-2005 02:20 PM
Yet another i810 graphics problem, very very poor 3D support Merlinfmct87 Linux - Software 12 04-14-2005 07:19 AM
poor graphics performance after kernel upgrade (2.6.11.6) geomatt Slackware 6 04-06-2005 12:14 PM
Poor graphics performance himyuza Slackware 13 02-25-2005 02:30 AM
UT2003 - graphics go berzerk Thermodynamic Linux - Games 3 01-25-2004 09:50 PM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration