LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices

Reply
 
Search this Thread
Old 08-09-2008, 02:32 AM   #1
aaron11193
LQ Newbie
 
Registered: Aug 2008
Posts: 4

Rep: Reputation: 0
Unhappy acpi=force Bad EIP value.


Hey all,
I have a Toshiba Satellite 2520CDT and have installed Puppy Linux on it.

To make the usb port on it work i have to put acpi=force in the GRUB boot line for it. This worked fine up until recently, when it started giving me the error:
Code: Bad EIP value.
EIP: [<00000000>] _stext+0x3feff000/0x20 SS:ESP 0068:c10b3bd4
Kernel panic - not syncing: Attempted to kill init!

Anyone know what this means?

Also, when acpi=force worked without complaints, i could not get my sound to work. modprobe snd-op13sa2 would just sit there doing nothing.

Please help, this laptop would be very very useful for school if it worked.

Aaron.
 
Old 08-09-2008, 04:03 AM   #2
aaron11193
LQ Newbie
 
Registered: Aug 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Unhappy

Fixed the EIP value problem by playing around with the bios settings...

Now I can get USB if i insert acpi=force into the GRUB line...
But at the same time i cant get any sound unless i take acpi=force out...

Cant figure it out...
 
Old 09-01-2008, 05:51 AM   #3
pcdoctor01
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Rep: Reputation: 0
Try puppy acpi=off when it boots up.
I installed puppy for a 10 year old and was unable to get sound with puppy 2.x, 3.x and 4.x. I only was able to get sound using puppy 1.x.
I even copied the info from the alsa boot section.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad EIP value... epic_problem Linux - Hardware 1 02-22-2005 12:10 PM
Bad EIP Value Doktor Prokt Linux - Hardware 1 10-19-2004 02:05 PM
Bad EIP Value? falconfighter Slackware 2 11-01-2003 09:49 AM
Bad EIP Value gillesd Linux - Hardware 3 10-10-2003 03:58 AM
bad EIP value romcgill Linux - Newbie 0 03-13-2003 03:27 AM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration