LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices



Reply
 
Search this Thread
Old 05-07-2004, 05:58 AM   #1
CuteBug
LQ Newbie
 
Registered: Apr 2003
Posts: 20

Rep: Reputation: 0
Playing sound in an avi file


I am developing video player in Linux using C/C++. well I am using libavi library to open and play avi files. Now the I am getting the video display working correctly but I cannot play the sound. I obtained the sound samples for each frame (at a time) in a buffer . Now what should I do to make it play. I am also using libSDL to create a display and sound object on the screen.

Plz help...
 
Old 05-17-2004, 12:53 PM   #2
Rajahuroman
Member
 
Registered: May 2004
Location: Romania; Arad
Distribution: Archlinux
Posts: 91

Rep: Reputation: 15
Consider trying out the NeHe tutorials for OpenGL. One of the tutorials focuses on creating a basic movie player using OpenGL and it also explains how to add sound.
 
Old 05-17-2004, 12:54 PM   #3
Rajahuroman
Member
 
Registered: May 2004
Location: Romania; Arad
Distribution: Archlinux
Posts: 91

Rep: Reputation: 15
The Nehe tutorials are located at
http://nehe.gamedev.net/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xine distorting sound and dropping frames when playing .avi-movies Trickj Linux - Software 2 11-21-2005 03:04 AM
Why is playing a .avi file such a pain? iggep Mandriva 9 09-22-2005 02:30 AM
No sound while playing .avi file Mr. Hill Linux - Newbie 2 09-05-2005 12:36 AM
Remove sound from avi file renanmathias Linux - General 1 07-22-2004 07:30 PM
no sound when playing avi + wmv's FLOODS Linux - Software 6 05-18-2004 02:22 PM


All times are GMT -5. The time now is 10:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration