Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 02-09-2004, 07:06 PM   #1
Registered: Jan 2004
Location: South Central PA
Distribution: Mandrake 9.2, Yellow Dog Linux 3.0, Knoppix, MacOS 9
Posts: 49

Rep: Reputation: 15
yaboot won't boot under Mdk 9.1 PPC :(

I just (sucessfully?) installed 9.1 PPC on my ibook. I set it up as a dual-boot system, along with Mac OS 9. Upon configuring the bootloader, yaboot, I was told that I would need to restart and press Command-Option-O-F (etc...), then reboot, if no boot loader was present.

Since this was the case, I performed the key combination to enter "Open Firmware" mode. I then entered what I *thought* Mdk told me to:

setenv boot-device /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:9,\\:tbxi


I tried the setenv command with and without a space after boot-device to no avail. I either miswrote the command, or got confused with a O or 0, or the like...

So, what do I need to enter under Open Firmware to get yaboot rolling???

I'm stuck until I can get yaboot to make an appearance!

Thanks in advance!!!

Old 02-10-2004, 10:00 AM   #2
Senior Member
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,118

Rep: Reputation: 374Reputation: 374Reputation: 374Reputation: 374
hmmm. have you tried using the bootx bootloader? i'm not sure what ibook you have, but my powerbook g3 (1998) can't use yaboot at all... i have to use bootx, also if you don't like having to keep a small macos, try looking into mIboot, that requires a small mac partition for a fake macos for the boot loader
Old 02-10-2004, 10:29 AM   #3
Registered: Jan 2004
Location: South Central PA
Distribution: Mandrake 9.2, Yellow Dog Linux 3.0, Knoppix, MacOS 9
Posts: 49

Original Poster
Rep: Reputation: 15
methinks i need yaboot

I have a blueberry ibook (G3).

When I was using YDL 3, so times ago, it used yaboot, so I guess I need to figure out how to convince the Mac that it needs to visit yaboot for startup!

Thanks for the tip on mIboot!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 - PPC - yaboot & Kernel issues superphreak4 Fedora 1 08-10-2005 06:24 AM
Mobility ATI 9700 driver for MDK PPC? cbenson Mandriva 1 02-04-2005 11:09 PM
LFS PPC and Yaboot lloyd_smart Linux From Scratch 0 12-29-2004 01:19 PM
10.1 PPC boot problems thefsfempire Mandriva 0 12-06-2004 04:13 PM
Gentoo - Macintosh G3 Blue & White - Yaboot doesnt Boot craigdolson Linux - Distributions 4 10-23-2003 07:33 PM

All times are GMT -5. The time now is 07:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration