LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 09-25-2012, 06:41 PM   #1
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Rep: Reputation: Disabled
Powerpack 2011 and several issues


OK , so finally installed PWP 2011 and every thing went smooth, but there are several problems.

1) The sound is damaged, there is sound but damaged, I tried the driver to be snd_ad1816a ALSA, OSS ad1816 , snd_hda_intel(ALSA), and neither worked, there is a possibility to choose from list but it is long. My sound card is Intel Corporation Device 1e20 .HELP!


2) There is no wifi driver nor firmware under MCC, and modprobe as root gives:
Quote:
FATAL:Module iwlwifi does not found.
3) I want to change the emacs theme, there is no package named color-theme in MCC, and I don't know the name of the theme I want, I remember that I faced the same problem on previous version of mandriva and that all I needed to do is to modify the ~/.emacs file... any HELP please !

4) There is no 3D option under MCC ???

5) I installed sakis3g, I have lsusb and lsmod only as superuser, there is no sysfs mounted under /mnt/sys.
after giving it the root password it shows this error:
Quote:
sakis3g: cannot execute command ~/Desktop/sakis3g --interactive SGUI "kdialog" USB MODEM = "1bbb:f000" OTHER = "USB MODEM" MODEM = "OTHER" MENU = "CONNECT" DISPLAY = "0"
hope for some help..

Thanks in advance,


[EDIT]lspci nfo here: http://www.linuxquestions.org/questi...0/#post4788061[/EDIT]

Last edited by unSpawn; 09-26-2012 at 11:30 AM. Reason: missing information
 
Old 09-26-2012, 06:33 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
color-theme - if this doesn't show anything, Mandriva does not have a package for it. I went to this link-->http://rpm.pbone.net/index.php3 and did a search for a color-theme rpm package. There are several for Fedora and Red-hat. You could download one, and use urpmi to install it. I do not know if that will work, or not. It is worth a try.

Iwlwifi support is probably in the kernel. I don't have a Mandriva system to verify that. It is in Magia2 kernel. In MCC I entered iwlwifi, and it shows the three 'ucode' packages. They would not be there if the support was not in the kernel. Try the same in MCC.

In MCC, under Hardware, is there not a 3D option there?
 
Old 09-26-2012, 08:07 AM   #3
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
In MCC, under Hardware, is there not a 3D option there?
There is no, only an option for graphic card.

And regarding sakis3g, I found that I don't have wvdial , wvdialconf and usb mode switch, I installed all of them, now if I run it as a root it connects but there is no internet, the APN username and password I give it do not show in the wvdial.conf file under /etc .. ?

Quote:
In MCC I entered iwlwifi, and it shows the three 'ucode' packages. They would not be there if the support was not in the kernel. Try the same in MCC.
I have all of them installed .

Last edited by mandrivaFan; 09-26-2012 at 08:13 AM.
 
Old 09-26-2012, 09:42 AM   #4
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Hi,
I just wanted to add that the most important thing for me now is the sakis3g since I don't want to switch between Linux and Windows all the time.

The net work applet asks for password to unlock Keyring Default?
also when I connect using sakis ifconfig -a shows ppp0 with IP address..!!!

MCC shows wireless as an option of configured networks, but with no name (eth1,wlan,...), only the name of the device, if click on it to configure it, it gives this mesage:

Quote:
unable to find network interface for selected device using iwlagn driver
hope for some help,

Thanks

Last edited by mandrivaFan; 09-26-2012 at 10:49 AM.
 
Old 09-26-2012, 12:53 PM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Sorry, I can not help with sakis3g, I have never used the script.

Quote:
I have all of them installed .
This may be part of the problem. You should have only the one your card needs installed. It may be loading the wrong ucode.
 
Old 09-26-2012, 01:42 PM   #6
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
This may be part of the problem. You should have only the one your card needs installed. It may be loading the wrong ucode.
If I uninstall some of them then it will install them all automatically if I click the WiFi on MCC .

what is the password for keyring ??
it also asks me for USB modem HSPA password ?

Thanks,
 
Old 09-26-2012, 02:21 PM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Your keyring - this may help -->http://en.wikipedia.org/wiki/GNOME_Keyring

As far as I know, your user password should unlock the keyring. I don't use Gnome, anymore. This is one reason why.

Quote:
it also asks me for USB modem HSPA password ?
Did you set a password for this device at some point? Other than that, I have no idea.
 
Old 09-26-2012, 03:42 PM   #8
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
As far as I know, your user password should unlock the keyring
It does not.

Quote:
Did you set a password for this device at some point?
I insert the APN usernamd and password of my provider .
 
Old 09-26-2012, 04:17 PM   #9
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
You can try and reset the keyring password. Here is a 'how to' for the keyring password.

-->http://askubuntu.com/questions/65281...yring-password

Give this a try.
 
Old 09-27-2012, 09:43 AM   #10
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Hi,
I finally managed to connect through sakis3g, I have no clue as to why it connected this time,
It still asks me about the default keyring, I have seahorse installed on my machine ,
I didn't understand what to do with it, I read it's manual pages and could not figure out how it will help me discover the keyring password.

I tried all of the drivers for the sound card, neither worked, the default one works some time, for few minutes then the noise starts again.

I installed the color-theme package, now it appears as installed in the MCC, but emacs says problem loading color-theme file ... !

Thanks,
 
Old 09-28-2012, 08:56 AM   #11
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Hi,
Any help with the sound !?

Thanks,
 
Old 09-29-2012, 03:41 PM   #12
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Can you post the output of 'sudo lspci' please. What are the names of the audio drivers you have tried?

Is there just one sound card in the system?

Have you tried disabling pulse audio? What ever you do, do not try to uninstall pulse audio.
 
Old 09-30-2012, 12:57 AM   #13
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
sudo lspci :
Quote:
00:00.0 Host bridge: Intel Corporation Device 0154 (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
00:14.0 USB Controller: Intel Corporation Device 1e31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 1e3a (rev 04)
00:1a.0 USB Controller: Intel Corporation Device 1e2d (rev 04)
00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 1e10 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Device 1e12 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Device 1e14 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Device 1e16 (rev c4)
00:1d.0 USB Controller: Intel Corporation Device 1e26 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Device 1e57 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 1e03 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 1e22 (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)
03:00.0 Network controller: Intel Corporation Device 0888 (rev c4)
0c:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
I tried a huge list, over 50 drivers, I went to MCC, under hardware click on the sound and then choosing try set audio driver manually, it give a huge list, now it's set on snd_hda_intl.

Quote:
Is there just one sound card in the system?
I guess.

Quote:
Have you tried disabling pulse audio?
No, how is that done ?
Thanks
 
Old 09-30-2012, 08:56 AM   #14
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
This is your audio device, and there appears to be only one. However, the card is not properly being shown by lspci. See this thread, it is a bit long, the solution is in the last post on page two.

-->http://forums.debian.net/viewtopic.p...039f4&start=15

See what the poster did to get the card properly identified, on page one.

The solution:

Quote:
Installing the 3.2 kernel did the trick. Frankly, I have no idea why I couldn't do this in Synaptic, but this did the trick:

Code: Select all
apt-get -t squeeze-backports install linux-image-3.2.0-0.bpo.2-amd64 firmware-linux-free
reboot
/usr/sbin/alsactl init
This is Debain, you will not be able to copy the commands, your system is Mandriva. You will have to see if Mandriva has a newer kernel, at least 3.2 for sound to work.

You could always download the latest kernel source, and compile your own.

Another possibility is to switch to a distro with at least a 3.2 kernel.

Last, wait for mandriva to release its next version.

If I can remember, to disable Pulse audio, in MCC, sound configuration, I think there was some advanced settings, and an option there to disable pulse. I never got sound to work on Mandriva with pulse audio enabled with my sound card. It was just a thought I had, and costs nothing to try it, to see if that helps.
 
Old 09-30-2012, 10:30 AM   #15
mandrivaFan
Member
 
Registered: Sep 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Hi,
My kernel is
Quote:
2.6.39.4-4.2-desktop
So from what I understand I should have at least 3.2 , how can I get a newer version of the kernel, I knew about the
possibility to compile the kernel, but I don't know how is that done ?

And disabling the pulse audio does not work !
And I don't have apt-get .

Thanks,

Last edited by mandrivaFan; 09-30-2012 at 11:41 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 2011 PowerPack on lenovo ThinkPad E530 mandrivaFan Linux - Laptop and Netbook 10 09-17-2012 07:02 AM
PowerPack 2011 - Hide Icons Adriann Mandriva 1 06-03-2012 07:21 PM
PowerPack 2011 Taskbar and simplewelcome Adriann Mandriva 1 12-02-2011 04:39 PM
Show computer memory on Mandriva Powerpack 2011 Adriann Mandriva 3 11-28-2011 05:41 PM
LXer: Mandriva Linux Powerpack 2011 Announced LXer Syndicated Linux News 0 11-17-2011 11:20 AM


All times are GMT -5. The time now is 09:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration