LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-27-2004, 03:46 AM   #1
jfi
Member
 
Registered: Sep 2003
Location: France
Distribution: Mandriva2007, Debian, OpenSuse, Slack10, FC6, PC-BSD, Solaris10
Posts: 65

Rep: Reputation: 15
No USB module loaded /dev/sda1 not created


I (try to) use Mandrake 9.2 with Kernel 2.6.2-3 on a Laptop.

I cannot use my USB memory key, /dev/sda1 is not created and no USB module is loaded.

Any idea ?

(As I have many problems I have written a web page with (too ?) much information on
my Linux installation see link )

Thanks for help.
 
Old 02-27-2004, 04:30 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
hmm...my memory stick (usb) uses /dev/sda4, but nevertheless...let's see.

you see your loaded modules (in terminal) like this:

lsmod

and probably you won't see any usb-stuff there. if you wish to see available usb-related modules, (in terminal) do this:

modprobe -l | grep usb

and you should get a list. then load the appropriate modules, I think what you need is usb-storage and perhaps usb-uhci....the list you get is just a list of locations to modules, like

/lib/modules/2.6.1/kernel/drivers/usb/storage/usb-storage.ko

for example. now this module is loaded by using "usb-storage" as the modulename (no quotes)...so no path nor .ko in it well, now load these modules (if you haven't build them into kernel, but have them as modules):

modprobe usb-storage
modprobe uhci-hcd
modprobe ohci-hcd

I guess the two first should be enough...if the "usb-storage" isn't enough itself after you've modprobed those, check out what sda's you got in your /dev/ (or did you got any) and then just mount what you need.
 
Old 02-27-2004, 06:27 AM   #3
jfi
Member
 
Registered: Sep 2003
Location: France
Distribution: Mandriva2007, Debian, OpenSuse, Slack10, FC6, PC-BSD, Solaris10
Posts: 65

Original Poster
Rep: Reputation: 15
Many thanks for your reply, it was sufficient to modprobe
usb-storage and uhci-hcd

May I ask two additional questions ?
- when I log out and log in I have to type again
su .... modprobe... is it possible to have the modules automatically
loaded ?

- is it necessary tu umount the memory stick before log out
(root required to umount) ?

Thanks again
 
Old 02-27-2004, 06:38 AM   #4
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
You can definitely load the modules at boot. Hopefully only small adjustments are needed. How does your /etc/modules.conf look like? Does it have a line:

probeall usb-interface usb-uhci

At least mine do, and my usb-stick works like a charm.

greetings,
kamstrup
 
Old 02-27-2004, 02:11 PM   #5
jfi
Member
 
Registered: Sep 2003
Location: France
Distribution: Mandriva2007, Debian, OpenSuse, Slack10, FC6, PC-BSD, Solaris10
Posts: 65

Original Poster
Rep: Reputation: 15
Thanks for your reply

I have tried your solution but I probably misunderstood as it didn't work.

I have added the two lines
modprobe usb-storage
modprobe uhci-hcd

at the end of /etc/rc.d/rc.local

Now it is okays.

@+
 
Old 02-27-2004, 02:35 PM   #6
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
nice if it works.. and to your question about the umounting of the stick: unless the stick is umounted, there is a real possibility (danger!) to a _data loss_, that means, if you don't umount it, the files you've saved to it may become unworkable or get missing...so I suggest you _do_ umount it when logging out. BUT - if you don't remove it (if you _do_ leave it in the usb-port), and the machine stays powered on, I guess there is no need to umount it. only if you reboot/turn off your PC/plug the stick out, then it's needed to umount.

and about the root privileges...have a look at /etc/fstab file, it should contain a line for your stick, looking somehow like this:

/dev/sda1 /mnt/memstick auto user,noauto,unhide 0 0

(first is device, then the mountpoint, then the used filesystem (auto -> autodetected), then options and dump/pass). you should have this line, where it is told what device it is, where it is mounted when it's mounted, what fs it uses (auto is good), and options - if you specify "user" in options, a user should be able to both mount AND umount the device! noauto means that it's not automatically mounted at boot....so try that one out. remember to put the mountpoint and device paths to what they are in your machine...if you put them wrong, it's nothing dangerous I think but the stick may not mount correctly unless the fstab -file is being corrected (and possibly a reboot is needed?)

so a line in the fstab, like the one above, and then try mounting/umounting as user, should work? not sure..ther might be some other option too which you must enable to let your users u/mount the devices...but try.
 
Old 02-27-2004, 03:01 PM   #7
jfi
Member
 
Registered: Sep 2003
Location: France
Distribution: Mandriva2007, Debian, OpenSuse, Slack10, FC6, PC-BSD, Solaris10
Posts: 65

Original Poster
Rep: Reputation: 15
This is the line that was added to the file /etc/fstab I do not recognize your syntax ! Anyway it works.

none /mnt/hd supermount dev=/dev/sda1,fs=ext2:vfat,--,iocharset=iso8859-15,codepage=850,kudzu 0 0

Thanks
 
Old 02-29-2004, 02:11 PM   #8
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
hmm...ok, that seems a bit different than what I've used to see in fstab guess your distro has some own way of doing...but good if it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB: Memory Stick: no /dev/sda1 sysbox Linux - Hardware 6 08-09-2005 11:29 PM
dvb devices not created, and wrong module loaded? greenmuzz Linux - Hardware 4 07-09-2005 07:43 AM
USB drive... /dev/sda1 does not exist! Lord Zoltar Linux - Hardware 48 05-15-2005 11:55 AM
USB - /dev/sda1 is not a block device rstebbins Linux - Hardware 4 08-14-2003 05:16 AM
USB Compact flash card reader hotplug creates /dev/sda but no /dev/sda1 -Mandrake 9.1 bibinono Linux - Hardware 2 08-11-2003 09:37 AM


All times are GMT -5. The time now is 01:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration