LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2004, 04:07 PM   #1
pdmackenzie
Member
 
Registered: Dec 2002
Location: toronto
Distribution: mandrake 10
Posts: 135

Rep: Reputation: 15
how to stop mandrake/kde from automounting nonexistent removable devices at startup?


I believe that mandrake/kde's habit of allowing users to un/mount devices windows style, ie. without having to explicitly un/mount them is causing my system to freeze (the desktop is showing the usb port devices as mounted, even when there is nothing in the usb ports). Is there a way I can force mandrake to force me to mount and unmount these devices explicitly?

thank in advance,
doug

ps. at least I hope that this is what the problem is. I also notice during the boot sequence I see the message:
checking for new hardware [FAILED]
 
Old 11-07-2004, 04:39 PM   #2
65_289
Member
 
Registered: May 2002
Distribution: Ubuntu 5.04, Kanotix
Posts: 163

Rep: Reputation: 30
In /etc/fstab, add "noauto" without quotes in the options for that device. Like this:

/dev/sda1 /mnt/usb auto noauto,user 0 0

That is for my USB flash drive.
 
Old 11-07-2004, 04:51 PM   #3
pdmackenzie
Member
 
Registered: Dec 2002
Location: toronto
Distribution: mandrake 10
Posts: 135

Original Poster
Rep: Reputation: 15
when opening fstab in vim as root, I receive this message before the file is displayed:

"fstab" 11L, 809C
E576: viminfo: Missing '>' in line: :^@


I don't know if this affects anything, but it certainly makes me nervous.

Anyhoo, I have altered the relevant line in fstab to
none /mnt/removable2 noauto dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

it originally read:
none /mnt/removable2 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

Will this have the desired effect?

thanks
doug
 
Old 11-08-2004, 09:53 AM   #4
Nobber
Member
 
Registered: Jun 2002
Location: Nova Scotia
Distribution: Debian (home), Kubuntu 7.04 (work)
Posts: 265

Rep: Reputation: 30
Quote:
Anyhoo, I have altered the relevant line in fstab to
none /mnt/removable2 noauto dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

it originally read:
none /mnt/removable2 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

Will this have the desired effect?
Probably not.

If this device is a USB memory stick, and you want to mount and unmount it yourself explicitly, you first want to turn off supermount for the device. You should be able to do that somewhere in the Mandrake Control Center. Otherwise create an entry for the device in your fstab that looks something like this:

/dev/sda1 /mnt/removable2 vfat noauto,noatime,user 0 0

Then the filesystem on the device will be mounted only when you click the relevant desktop icon or device in Konqueror etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stop automounting tired Fedora 5 06-05-2005 11:33 AM
Does dpkg work with removable devices? jolphil Debian 13 03-23-2005 03:14 PM
Debian and removable devices. Sslaxx Debian 2 02-09-2005 01:24 PM
How to use shell script to get removable devices? slownet Programming 2 03-23-2004 10:16 AM
Automounting a removable drive rhraz Linux - Newbie 1 03-11-2004 12:02 PM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration