LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 01-08-2011, 07:48 PM   #1
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Rep: Reputation: 33
Handbrake Install


Hello, I want to install handbrake on Mandriva 2010.1. Here is the output when I query for it:

Code:
[david@localhost ~]$ urpmq handbrake
No package named handbrake
Does anyone know of a repo I can add to be able to install it?

Thanks,

David
 
Old 01-08-2011, 08:20 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,247

Rep: Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557Reputation: 1557
I haven't used Mandriva for a while, but you can download it from the maintainers and install it locally.

http://handbrake.fr/downloads.php
 
Old 01-08-2011, 08:32 PM   #3
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Original Poster
Rep: Reputation: 33
I am not very good with resolving dependencies and what not. It appears that in earlier versions of Mandriva, it was in the repos. Is there a way I can add 2009 repos for instance and install the old one on Mandriva 2010? Is there anything else I can do?

Or, if anyone wants to help me with dependency hell, that would be cool to. Here is what happens when I try to install the rpm:

Code:
[root@localhost Desktop]# rpm -ivh HandBrake-0.9.5-Fedora_GUI_i686.rpm 
error: Failed dependencies:
        libstdc++.so.6(GLIBCXX_3.4.14) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libwebkitgtk-1.0.so.0 is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.2.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.3.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686

Last edited by CincinnatiKid; 01-08-2011 at 08:40 PM.
 
Old 01-09-2011, 07:06 AM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, try the urpmi and the absolute address of the package,

eg. urpmi /home/glenn/Programs/HandBrake-0.9.5-Fedora_GUI_i686.rpm

If your running mandriva, you won't want the fedora stuff.

If you have the correct versions of std libc++ libz (compression?) and webkit try to install it with rpm -ivh --nodeps --force package-name.rpm

You may have better results installing from source instead of using a different distro package.

http://linux.softpedia.com/get/Multi...ake-3051.shtml

http://sourceforge.net/settings/mirr...-0.9.5.tar.bz2

Need help, just ask here.
cheers Glenn

Last edited by GlennsPref; 01-09-2011 at 07:10 AM.
 
Old 01-09-2011, 07:51 AM   #5
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
There is a Mandriva package available.

32 bit
http://rpm.pbone.net/index.php3/stat....i586.rpm.html

64 bit
http://rpm.pbone.net/index.php3/stat...86_64.rpm.html
 
1 members found this post helpful.
Old 01-09-2011, 10:27 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Post # 5 : The i586 package works OK, using the command 'ghb'.
The installed link /usr/bin/HandBrakeGUI is not working :
/usr/bin/HandBrakeGUI -> ../../home/oli/rpm-build/rpm/2010.1/ \
BUILDROOT/handbrake-0.9.4-1mud2010.1.i386/usr/bin/ghb



About version 0.9.5 :
I used RPMBUILD to provide version 0.9.5 with a spec file from
the Mandriva lookalike handbrake-0.9.4-4pclos2010.src.rpm
http://ftp.uwsg.indiana.edu/linux/pc...os2010.src.rpm
modified to version 0.9.5 : rpmbuild -bb handbreake095.spec

The result, handbrake-0.9.5-4m2010.1.i586.rpm is here
https://docs.google.com/uc?id=0B7S25...download&hl=en
Menu >> Sound & Video > Handbrake.
..
Attached Files
File Type: txt handbrake095.spec.txt (3.6 KB, 4 views)
 
Old 01-10-2011, 09:40 AM   #7
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by reed9 View Post
This worked! Thanks.
 
Old 07-26-2011, 09:48 PM   #8
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
Quote:
Originally Posted by lewisforlife View Post
if anyone wants to help me with dependency hell, that would be cool to. Here is what happens when I try to install the rpm:

Code:
[root@localhost Desktop]# rpm -ivh HandBrake-0.9.5-Fedora_GUI_i686.rpm 
error: Failed dependencies:
        libnotify.so.4 is needed by HandBrake-gui-0.9.5-1.fc15.i686
        libstdc++.so.6(GLIBCXX_3.4.14) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libwebkitgtk-1.0.so.0 is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.2.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.3.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686
If I having Centos6.

I checked the required library in /usr/lib what I got was:
libnotify.so.1
libwebkitgtk-1.0.so.2
libz.so.1

So the version of my library is higher than the required dependency.

Anyone know how to solve above dependency hell?

Last edited by fhleung; 07-26-2011 at 10:28 PM.
 
Old 07-27-2011, 06:55 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Post # 8, @fhleung.

If you are trying to install a Fedora 14(15) handbrake package into the Fedora 12
based CentOS 6: That's not a real dependency issue. It's just an impossible action.

As you can see from other handbrake posts, the application is easy to build :
The CentOS 6 package, handbrake-0.9.5-2el6.i686.rpm can be downloaded here ..

https://docs.google.com/uc?id=0B7S25...nload&hl=en_US

..
 
Old 08-02-2011, 12:40 AM   #10
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
The file from your link works like a charm! Thank you so much!

Sorry, I still not understand the dependency concept. If I having latest/higher version of package (Fedora 15), is it possible to install into (Fedora 12) ?

for example, if I already having python2.6
Code:
rpm -ivh package-Python2.4.noarch.rpm 
error: Failed dependencies:
	/usr/bin/python2.4 is needed by package.noarch

Last edited by fhleung; 08-02-2011 at 06:20 AM.
 
Old 08-02-2011, 10:13 AM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
rpm -Uvh application-Python2.4.noarch.rpm :
It's a package built by using python version 2.4 .
May or may not depend on python-2.4.

Using rpm to install packages should be an exception.
And using packages from another OS : A few will work.
But why are you trying to install alien packages ? ?


Generally : Use only # 'yum install' for package installs.
The most used 10,000 packages are avilable from CentOS or EPEL :
https://fedoraproject.org/wiki/EPEL

Other repositories, which you can add (temporarily) :
http://wiki.centos.org/AdditionalResources/Repositories
→ Some 3rd party repositories must be disabled at update, to avoid conflicts.
Yum-Priorities : http://wiki.centos.org/PackageManagement/Yum/Priorities

..
 
Old 11-28-2012, 11:52 PM   #12
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
Dear knudfl,

Frist of all, thank you for help last time, sorry for my stupid, I got similar question again.

Quote:
That's not a real dependency issue. It's just an impossible action.
Inside /usr/lib directory, there was many, and one of the files like
/usr/lib/libstdc++.so.6
but application (IBM DB2) require version libstdc++.so.5


Question: can several library fileS be TOGETHER ? like libstdc++.so.6, libstdc++.so.5, libstdc++.so.4 etc...

Last edited by fhleung; 11-28-2012 at 11:55 PM.
 
Old 11-29-2012, 05:02 AM   #13
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Quote:
Can several library fileS be TOGETHER ?
like libstdc++.so.6, libstdc++.so.5, libstdc++.so.4 etc.
Of course they can. Different file names = No conflicts.
There are many libraries, that you can have in different versions.

libstdc++.so.5 package names :
Mandriva, Debian : libstdc++5
Fedora, CentOS : compat-libstdc++-33

.
 
Old 11-29-2012, 05:37 AM   #14
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
Please Please help me UNTIL I can get through it: install IBM DB2 version 9.5 which require
libstdc++.so.5

OS: Centos 6
current library file: /usr/lib/libstdc++.so.6



So I need to find the older version of this library? Thank you

Last edited by fhleung; 11-29-2012 at 05:38 AM.
 
Old 11-29-2012, 05:53 AM   #15
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Post # 14
Quote:
OS: Centos 6
Please see post # 13 :
The package name 'compat-libstdc++-33' provides libstdc++.so.5 :
/usr/lib/libstdc++.so.5
/usr/lib/libstdc++.so.5.0.7

Solution : # yum install compat-libstdc++-33

.
 
  


Reply

Tags
handbrake


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
handbrake or others mhg Ubuntu 1 11-26-2010 12:02 PM
installing handbrake clifford227 Slackware 5 08-25-2010 08:04 PM
Slackbuild handbrake error-[gtk.install] Error 2 Swift&Smart Slackware 8 08-17-2010 04:42 PM
LXer: Handbrake 0.9.4 LXer Syndicated Linux News 0 11-26-2009 07:00 PM
handbrake compilation microsoft/linux Debian 3 01-02-2006 11:25 PM


All times are GMT -5. The time now is 02:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration