LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Handbrake Install (http://www.linuxquestions.org/questions/mandriva-30/handbrake-install-855080/)

CincinnatiKid 01-08-2011 07:48 PM

Handbrake Install
 
Hello, I want to install handbrake on Mandriva 2010.1. Here is the output when I query for it:

Code:

[david@localhost ~]$ urpmq handbrake
No package named handbrake

Does anyone know of a repo I can add to be able to install it?

Thanks,

David

frankbell 01-08-2011 08:20 PM

I haven't used Mandriva for a while, but you can download it from the maintainers and install it locally.

http://handbrake.fr/downloads.php

CincinnatiKid 01-08-2011 08:32 PM

I am not very good with resolving dependencies and what not. It appears that in earlier versions of Mandriva, it was in the repos. Is there a way I can add 2009 repos for instance and install the old one on Mandriva 2010? Is there anything else I can do?

Or, if anyone wants to help me with dependency hell, that would be cool to. Here is what happens when I try to install the rpm:

Code:

[root@localhost Desktop]# rpm -ivh HandBrake-0.9.5-Fedora_GUI_i686.rpm
error: Failed dependencies:
        libstdc++.so.6(GLIBCXX_3.4.14) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libwebkitgtk-1.0.so.0 is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.2.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.3.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686


GlennsPref 01-09-2011 07:06 AM

Hi, try the urpmi and the absolute address of the package,

eg. urpmi /home/glenn/Programs/HandBrake-0.9.5-Fedora_GUI_i686.rpm

If your running mandriva, you won't want the fedora stuff.

If you have the correct versions of std libc++ libz (compression?) and webkit try to install it with rpm -ivh --nodeps --force package-name.rpm

You may have better results installing from source instead of using a different distro package.

http://linux.softpedia.com/get/Multi...ake-3051.shtml

http://sourceforge.net/settings/mirr...-0.9.5.tar.bz2

Need help, just ask here. ;)
cheers Glenn

reed9 01-09-2011 07:51 AM

There is a Mandriva package available.

32 bit
http://rpm.pbone.net/index.php3/stat....i586.rpm.html

64 bit
http://rpm.pbone.net/index.php3/stat...86_64.rpm.html

knudfl 01-09-2011 10:27 AM

1 Attachment(s)
Post # 5 : The i586 package works OK, using the command 'ghb'.
The installed link /usr/bin/HandBrakeGUI is not working :
/usr/bin/HandBrakeGUI -> ../../home/oli/rpm-build/rpm/2010.1/ \
BUILDROOT/handbrake-0.9.4-1mud2010.1.i386/usr/bin/ghb



About version 0.9.5 :
I used RPMBUILD to provide version 0.9.5 with a spec file from
the Mandriva lookalike handbrake-0.9.4-4pclos2010.src.rpm
http://ftp.uwsg.indiana.edu/linux/pc...os2010.src.rpm
modified to version 0.9.5 : rpmbuild -bb handbreake095.spec

The result, handbrake-0.9.5-4m2010.1.i586.rpm is here
https://docs.google.com/uc?id=0B7S25...download&hl=en
Menu >> Sound & Video > Handbrake.
..

CincinnatiKid 01-10-2011 09:40 AM

Quote:

Originally Posted by reed9 (Post 4218188)

This worked! Thanks.

fhleung 07-26-2011 09:48 PM

Quote:

Originally Posted by lewisforlife (Post 4217835)
if anyone wants to help me with dependency hell, that would be cool to. Here is what happens when I try to install the rpm:

Code:

[root@localhost Desktop]# rpm -ivh HandBrake-0.9.5-Fedora_GUI_i686.rpm
error: Failed dependencies:
        libnotify.so.4 is needed by HandBrake-gui-0.9.5-1.fc15.i686
        libstdc++.so.6(GLIBCXX_3.4.14) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libwebkitgtk-1.0.so.0 is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.2.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686
        libz.so.1(ZLIB_1.2.3.3) is needed by HandBrake-gui-0.9.5-1.fc14.i686


If I having Centos6.

I checked the required library in /usr/lib what I got was:
libnotify.so.1
libwebkitgtk-1.0.so.2
libz.so.1

So the version of my library is higher than the required dependency.

Anyone know how to solve above dependency hell?

knudfl 07-27-2011 06:55 AM

Post # 8, @fhleung.

If you are trying to install a Fedora 14(15) handbrake package into the Fedora 12
based CentOS 6: That's not a real dependency issue. It's just an impossible action.

As you can see from other handbrake posts, the application is easy to build :
The CentOS 6 package, handbrake-0.9.5-2el6.i686.rpm can be downloaded here ..

https://docs.google.com/uc?id=0B7S25...nload&hl=en_US

..

fhleung 08-02-2011 12:40 AM

The file from your link works like a charm! Thank you so much!:cool:

Sorry, I still not understand the dependency concept. If I having latest/higher version of package (Fedora 15), is it possible to install into (Fedora 12) ?

for example, if I already having python2.6
Code:

rpm -ivh package-Python2.4.noarch.rpm
error: Failed dependencies:
        /usr/bin/python2.4 is needed by package.noarch


knudfl 08-02-2011 10:13 AM

rpm -Uvh application-Python2.4.noarch.rpm :
It's a package built by using python version 2.4 .
May or may not depend on python-2.4.

Using rpm to install packages should be an exception.
And using packages from another OS : A few will work.
But why are you trying to install alien packages ? ?


Generally : Use only # 'yum install' for package installs.
The most used 10,000 packages are avilable from CentOS or EPEL :
https://fedoraproject.org/wiki/EPEL

Other repositories, which you can add (temporarily) :
http://wiki.centos.org/AdditionalResources/Repositories
→ Some 3rd party repositories must be disabled at update, to avoid conflicts.
Yum-Priorities : http://wiki.centos.org/PackageManagement/Yum/Priorities

..

fhleung 11-28-2012 11:52 PM

Dear knudfl,

Frist of all, thank you for help last time, sorry for my stupid, I got similar question again.

Quote:

That's not a real dependency issue. It's just an impossible action.
Inside /usr/lib directory, there was many, and one of the files like
/usr/lib/libstdc++.so.6
but application (IBM DB2) require version libstdc++.so.5


Question: can several library fileS be TOGETHER ? like libstdc++.so.6, libstdc++.so.5, libstdc++.so.4 etc...

knudfl 11-29-2012 05:02 AM

Quote:

Can several library fileS be TOGETHER ?
like libstdc++.so.6, libstdc++.so.5, libstdc++.so.4 etc.
Of course they can. Different file names = No conflicts.
There are many libraries, that you can have in different versions.

libstdc++.so.5 package names :
Mandriva, Debian : libstdc++5
Fedora, CentOS : compat-libstdc++-33

.

fhleung 11-29-2012 05:37 AM

Please Please help me UNTIL I can get through it: install IBM DB2 version 9.5 which require
libstdc++.so.5

OS: Centos 6
current library file: /usr/lib/libstdc++.so.6



So I need to find the older version of this library? Thank you

knudfl 11-29-2012 05:53 AM

Post # 14
Quote:

OS: Centos 6
Please see post # 13 :
The package name 'compat-libstdc++-33' provides libstdc++.so.5 :
/usr/lib/libstdc++.so.5
/usr/lib/libstdc++.so.5.0.7

Solution : # yum install compat-libstdc++-33

.


All times are GMT -5. The time now is 10:55 PM.