LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 04-17-2008, 09:56 AM   #61
paulpeer
Member
 
Registered: Apr 2008
Location: Antwerpen
Distribution: Mandriva 2008.0 KDE 3.5
Posts: 50

Original Poster
Rep: Reputation: 15

Quote:
Originally Posted by ernie View Post
My Documents is a Windows folder (directory).
You're right that "My documents" is a Windows-folder. But it is on the Mandriva Flash stick and it's empty in the beginning. It does not inherit anything from the hard disk My Documents folder, it 'inherits' the documents from the /home/$USER folders. Yes, I've used it on other computers as well. It still has the same bookmarks!
 
Old 04-17-2008, 04:05 PM   #62
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
OK, then the Mandriva Flash configuration is unique. Even Mandriva One does not include a My Documents folder (directory). Since I do not use the Flash release here I am unfamiliar with its characteristics. You may be best served to ask this question on the Mandriva Users Forum (this link gets you to the main portal page).

HTH,
 
Old 04-18-2008, 04:08 PM   #63
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Moved: This thread is more suitable in <MANDRIVA> and has been moved for a merge with http://www.linuxquestions.org/questi...h-2008-635553/
 
Old 04-18-2008, 05:53 PM   #64
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
And has now been merged
 
Old 08-11-2008, 07:04 AM   #65
mobeenkhan
LQ Newbie
 
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
Okay the solution is quite simple, this is what u have to do,
Open up a Terminal window,
type in this,
cd .mozilla/
cd firefox/
ls -a
cd (name).default (You'll see a folder with default extension)
ls -a

LOOK FOR "LOCK" file, if there, type in
rm lock
TRY RUNNING NOW, IF NOT THEN LOOK FOR "PARENTLOCK",
rm parentlock

Now Firefox should work !!!

Take Carezzz byaaaaa
 
Old 08-11-2008, 02:25 PM   #66
paulpeer
Member
 
Registered: Apr 2008
Location: Antwerpen
Distribution: Mandriva 2008.0 KDE 3.5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mobeenkhan View Post
Okay the solution is quite simple,
Thanks for the answer, but as you can see in the thread above, this did not solve the problem. In the meantime I installed Linux again from scratch, and since then the problem didnṫ show up again.
 
Old 08-21-2008, 09:17 AM   #67
ksri07091983
Member
 
Registered: Nov 2007
Location: Chennai,TamilNadu,India
Distribution: RedHat,SuSE
Posts: 65

Rep: Reputation: 15
Hi,

I had the same problem. I did the following to remove the stale lock files and then opened firefox. it worked.

Code:
find $HOME/.mozilla -name lock -exec rm -f {} \;
find $HOME/.mozilla -name .parentlock -exec rm -f {} \;
run the above commands as the user who is having firefox problem.

In addition.. i moved my firefox binary (/usr/lib/firefox/firefox-bin) to /usr/lib/firefox/firefox-bin.org and kept my script (shown below) as /usr/lib/firefox/firefox-bin. so that the same problem will be solved background itself

Code:
#!/bin/bash
# /usr/lib/firefox/firefox-bin script
if ! [ `id -u` = 0 ]
then
        chmod -R 777 $HOME/.mozilla/
        find $HOME/.mozilla -name lock  > /dev/null 2>&1
        if [ $? = 0 ]
        then
                rm -f `find $HOME/.mozilla -name lock` 2> /dev/null
                rm -f `find $HOME/.mozilla -name sessionstore.js` 2> /dev/null
                rm -f `find $HOME/.mozilla -name .parentlock` 2> /dev/null
        fi
fi

/usr/lib/firefox/firefox-bin.org $*

You can try this out. But dont mess up if you are not clear what is happening..

Thanks

Sridhar
 
Old 08-21-2008, 07:26 PM   #68
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Cool Thank you for your solution...

Quote:
Originally Posted by ksri07091983 View Post
Hi,

I had the same problem. I did the following to remove the stale lock files and then opened firefox. it worked.

Code:
find $HOME/.mozilla -name lock -exec rm -f {} \;
find $HOME/.mozilla -name .parentlock -exec rm -f {} \;
run the above commands as the user who is having firefox problem.

In addition.. i moved my firefox binary (/usr/lib/firefox/firefox-bin) to /usr/lib/firefox/firefox-bin.org and kept my script (shown below) as /usr/lib/firefox/firefox-bin. so that the same problem will be solved background itself

Code:
#!/bin/bash
# /usr/lib/firefox/firefox-bin script
if ! [ `id -u` = 0 ]
then
        chmod -R 777 $HOME/.mozilla/
        find $HOME/.mozilla -name lock  > /dev/null 2>&1
        if [ $? = 0 ]
        then
                rm -f `find $HOME/.mozilla -name lock` 2> /dev/null
                rm -f `find $HOME/.mozilla -name sessionstore.js` 2> /dev/null
                rm -f `find $HOME/.mozilla -name .parentlock` 2> /dev/null
        fi
fi

/usr/lib/firefox/firefox-bin.org $*

You can try this out. But dont mess up if you are not clear what is happening..

Thanks

Sridhar
Thank you for your solution,

regards, Glenn
 
Old 08-22-2008, 02:24 AM   #69
ksri07091983
Member
 
Registered: Nov 2007
Location: Chennai,TamilNadu,India
Distribution: RedHat,SuSE
Posts: 65

Rep: Reputation: 15
Hi Glenn,

you are most welcome. But did that solution worked ???


Thanks

Sridhar
 
Old 08-22-2008, 04:00 AM   #70
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Not as it is, I have /usr/lib64/firefox

But it looks like it, I never get lockups in ff.

regards, Glenn
 
Old 08-31-2008, 03:06 PM   #71
paulpeer
Member
 
Registered: Apr 2008
Location: Antwerpen
Distribution: Mandriva 2008.0 KDE 3.5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ksri07091983 View Post
Hi,

I had the same problem. I did the following to remove the stale lock files and then opened firefox. it worked.
Thanks for the answer, but as you can see in the thread above, this did not solve the problem. In the meantime I installed Linux again from scratch, and since then the problem didnṫ show up again.
 
Old 10-09-2010, 07:07 PM   #72
CyberScann
LQ Newbie
 
Registered: Oct 2010
Location: Maine, USA
Distribution: Ubuntu
Posts: 1

Rep: Reputation: 0
the command "ps -A | grep firefox" is case sensitive if you look at the ps --help there are a lot of letters and the upper case perform different functions then the lower case ones do hope this helps
 
Old 03-05-2012, 01:04 PM   #73
tonyh1
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Cure to misleading "firefox already running" message

>>>This seems to be caused by a corruption in the user's Firefox profile.
>>>First stop Firefox (and you may as well delete lock files).

ps aux | grep firefox

>>kill any processes you find..

kill -9 "nnnn" (process number = nnnn)

>>>remove lock files
cd ~"username"/.mozilla/firefox/uuhu32gf.default/ (or whatever your profile directory is)

ls -alh
rm lock
rm .parentlock
rm sessionstore.js


>>>Now rename the ini file which selects your corrupt profile at firefox startup (so firefox will no longer find "profiles.ini").
cd ~username/.mozilla/firefox/
mv profiles.ini not_profiles_ini

[fyi: profiles.ini contained:
cat not_profiles_ini

[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=uuhu32gf.default]

In the absence of profiles.ini, when you restart Firefox (and it will start now) firefox will create a new profile and profiles.ini file. The name of the new profile will be visible in >
ls ~username/.mozilla/firefox/

Suggest then copying bookmarks from your old profile folder to the new one (unless someone has time to spare doing further definitive investigation to pin down the exact file causing the old profile to fail).

To restore bookmarks from old profile:
>>find your old bookmarks (the most recent LARGE "bookmarks-(date of last known good).json" file in this directory (ignore any more recent tiny / empty ones created by the corrupted or failed firefox profile).

ls ~username/.mozilla/firefox/"old_profile_directory"/bookmarkbackups/


Copy last good bookmark backups .json file to new profile:
cp ~username/.mozilla/firefox/"old_profile_directory"/bookmarkbackups/bookmarks-2012-02-29.json ~username/.mozilla/firefox/"new_profile_directory"/bookmarkbackups

Open Firefox (your bookmarks won't be there yet, unlike the old method of just copying a bookmarks file, this is a 2-stage process).

Click on bookmarks > show all bookmarks > import and backup > restore >>> choose the file / date from the menu which corresponds to the last-known good file (.json) that you just previously / copied restored.

Your old bookmarks will all now be available, although the "bookmarks toolbar folder (ie links/personal bookmarks, whatever you like to call it) may need restoring by dragging on your own favourites.

Last edited by tonyh1; 03-05-2012 at 01:57 PM. Reason: Added detail
 
Old 03-06-2012, 03:10 AM   #74
floppywhopper
Member
 
Registered: Aug 2004
Location: Albany, Western Australia
Distribution: Mageia 4.1, SME Server 8
Posts: 627
Blog Entries: 2

Rep: Reputation: 55
Go "Main menu"
Go "Tools'
Go "System Tools"
Go "System Monitor"
find Firefox
click "End Process"
 
Old 03-12-2012, 09:56 PM   #75
mgrivas
LQ Newbie
 
Registered: Oct 2010
Posts: 3

Rep: Reputation: 0
Correction to firefox self-curing startup script

I saw that fine script from ksri07091983 in post #69.
However, I think there is a bug there.
If you try to run firefox for a second time, then it tries to delete the existing lock files, which will happily happen.
Then, you delete anything saved within the session, which means that if you have many windows and tabs open, next time you start you will not have them !
If you remove the
Code:
rm ... sessionstore.js
then you get the whole session again, that is all the windows and tabs you had last time (or is saved, anyway).
I would recommend add a line about if firefox runs already, then let it run as-is.
I would change your
Quote:
find
and
Quote:
if
commands into :
Code:
  ps -e | grep firefox &>/dev/null; let lastexit=$? 
  find $HOME/.mozilla -name lock  &>/dev/null ; let lastexit+=$? 
  if [ $lastexit = 0 ]
That way you run the rm set only if there is lock file AND the firefox does not run (i.e. first call).
 
  


Reply

Tags
firefox, readonly


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
thunderbird is already running but not responding wearetheborg Linux - Software 9 09-06-2011 01:52 PM
Slackware. The keyboard stops responding after "Running /etc/rc.d/rc.modules-2.6.21." kolRn Linux - Hardware 10 01-22-2008 01:02 AM
Firefox not responding. 0rinoco Linux - Newbie 2 09-24-2007 03:00 AM
Firefox is already running. . . slackwarefan Linux - Software 3 12-27-2005 07:56 PM
trying to get NIS up: ypserv running but not responding? BrianK Linux - Networking 1 06-07-2004 07:45 PM


All times are GMT -5. The time now is 11:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration