LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 10-06-2005, 09:37 PM   #1
CyberDoc
Member
 
Registered: Oct 2003
Location: usa
Distribution: linux mint 17, slackware, ubuntu server
Posts: 41

Rep: Reputation: 15
Angry Could not find mime type application/octet-stream ERROR


Anyone got a guess as to what is causing this error "Could not find mime type
application/octet-stream" everytime i boot or bring up konqueror. I sort of want to do a reinstall but not that bad i think it's a mime type error not sure. Tried to associate wine with .exe files then i started getting the above error.


Thanks
CyberDoc
 
Old 10-08-2005, 03:11 PM   #2
mguiddy
LQ Newbie
 
Registered: Oct 2005
Distribution: OpenSuse 10.2
Posts: 7

Rep: Reputation: 1
This just happened to me (after adding an association for par2 files) and after trying several things I think I managed to fix it.

Try deleting everything in the following folder.
~/.kde/share/mimelnk/

Seems to have worked for me.

Let us know if it works.

Last edited by mguiddy; 10-08-2005 at 03:13 PM.
 
Old 10-08-2005, 03:29 PM   #3
CyberDoc
Member
 
Registered: Oct 2003
Location: usa
Distribution: linux mint 17, slackware, ubuntu server
Posts: 41

Original Poster
Rep: Reputation: 15
Talking worked great

I did not have to delete all contents i just deleted the file named octet-stream

Thanks,

CyberDoc
 
Old 10-08-2005, 03:35 PM   #4
mguiddy
LQ Newbie
 
Registered: Oct 2005
Distribution: OpenSuse 10.2
Posts: 7

Rep: Reputation: 1
Glad it worked.

I kind of thought you wouldn't have to delete all the contents, but it's what I did.
 
1 members found this post helpful.
Old 10-10-2005, 10:31 AM   #5
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
KDE "mime type" errors

For the sake of those who follow --

The "Epidemic"
There must be an epidemic of this:
  • I've had the same problem for a couple of weeks.
  • I too was considering a fresh install.
  • I had been messing w/ file associations. (Like mguiddy)
The Bad File
On my system its name was octet-stream.desktop, I assume that is the case elsewhere.

A Different Fix
Instead of deleting the apparently offending file, I renamed it; just to make sure I had the right one. (I added a '.0' suffix.)

Where It Was
I found it in ~/.kde/share/mimelnk/application/

How I Found It
Code:
grep -ri 'octet-stream' ~/.kde/share/*
You could adapt this command to find any other "mime type" error. Just substitute your error for "octet-stream" between the single quotes.

So the generalized form might be written:
Code:
grep -ri 'put_the_text_of_your_error_here' ~/.kde/share/*
Follow-up Needed
Given that 2 of the 3 posters reporting the symptom noticed & reported that they had recently made new file associations, it would be nice to know 2 things:[list=1][*]Is this a common/normal problem?[*]Is it avoidable?[/list=1]
 
1 members found this post helpful.
Old 10-10-2005, 08:35 PM   #6
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
The KDE file associations can be edited in the KDE Control Centre under KDE Components->File Associations. There's no need to change the config files directly and you definately don't need to do anything drastic like reinstall.

Quote:
# Is this a common/normal problem?
Probably only for those who mess with file association settings

Quote:
# Is it avoidable?
Yes, don't mess with your file association settings
 
Old 10-11-2005, 04:11 PM   #7
Keen48
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Rep: Reputation: 0
I have trouble with .txt files, whenever i click them the console tries to open it. I associated it with Emacs but it still opens with console. I run Xandros 3.0.2 Business, is there any fix?

I tried the File Associations editor already but it doesnt work.

Last edited by Keen48; 10-11-2005 at 04:13 PM.
 
Old 10-12-2005, 12:36 PM   #8
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Yes, use the "Application Preference Order" dialog in the "File Associations editor". That is, KDE Components :: File Associations in the Control Center, or in Konqueror Settings :: Configure Konqueror :: File Associations. In either case, you will want text :: plain

The "Application Preference Order" dialog allows you to highlight an application(emacs, for instance) & then move it up (or down) the preference list. Did you not see it?
 
Old 10-16-2005, 09:51 PM   #9
mguiddy
LQ Newbie
 
Registered: Oct 2005
Distribution: OpenSuse 10.2
Posts: 7

Rep: Reputation: 1
Quote:
Originally posted by tkedwards
The KDE file associations can be edited in the KDE Control Centre under KDE Components->File Associations. There's no need to change the config files directly and you definately don't need to do anything drastic like reinstall.



Probably only for those who mess with file association settings
Just for the record, I added the association via Konquerer > Settings > Configure Konquerer > File Associations.

Quote:
Originally posted by tkedwards

Yes, don't mess with your file association settings
That kinda sounds like the Groucho Marx routine.
 
Old 10-17-2005, 08:01 AM   #10
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Thanks for reminding me where that came from. It sounded like Groucho to me too. And the routine is so old, I was mildly offended by it at the time because there was no smiley to indicate that he knew he referencing an old joke. I would have said something then, but I thought I was just upset enough that I was afraid that my reply would be too flamey. Since my experience of "tk" is that he usually has something useful to say, I decided to let it slide.

And for the record, I too got into trouble using the GUI tool, not mucking around in the conf files w/ a text editor.
 
Old 10-17-2005, 09:18 PM   #11
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
I thought I did put a in? But yeah it wasn't meant to be a flame, just saying that changing file associations always seems to cause problems
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not find mime type application/octet-stream jon rouse Mandriva 11 02-14-2007 02:18 AM
could not find mime type application/octet-stream WhiteTornado Fedora 7 04-12-2006 01:52 PM
Could not find mime type - application/octet-stream EuroJovi Linux - Software 4 01-26-2006 02:30 PM
mime type/ocet stream error ?? mnchur Linux - Software 3 02-25-2004 10:42 AM
"Cannot find application/octet-stream" Chroder Linux - General 1 10-15-2003 08:38 PM


All times are GMT -5. The time now is 12:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration