LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-12-2004, 04:12 AM   #1
jon rouse
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 6

Rep: Reputation: 0
Could not find mime type application/octet-stream


I finally managed to get my Linux box connected to the Internet, and ran all the upgrades. Consequently I now get errors when starting Konqueror with the message "Could not find mime type application/octet-stream".

Also Konqueror no longer launches kwrite when I click on a .conf file, and it will not act a s a web browser when I type in URLs on the navigation line.
 
Old 01-12-2004, 04:24 AM   #2
Ice9
Member
 
Registered: Jun 2002
Location: Belgium
Distribution: Sidux
Posts: 313

Rep: Reputation: 30
I had more or less the same thing happening to me, try this
and let me know if it worked for you too.
 
Old 01-12-2004, 06:45 AM   #3
jon rouse
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for that, I'll give it a go.
 
Old 01-13-2004, 07:15 AM   #4
jon rouse
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 6

Original Poster
Rep: Reputation: 0
Nope, still get all the errors. Also when I click on a file ending with .html it doesn't launch the browser.
 
Old 01-13-2004, 10:08 AM   #5
Ice9
Member
 
Registered: Jun 2002
Location: Belgium
Distribution: Sidux
Posts: 313

Rep: Reputation: 30
Hmmm, weird.
Check the file associations for html and see if anything is associated with the .html extension.
Also, do you have octet/stream listed under applications in the file associations menu?
 
Old 08-19-2004, 05:59 AM   #6
kit_johnson
LQ Newbie
 
Registered: Jul 2004
Distribution: Fedora Core 3
Posts: 5

Rep: Reputation: 0
Hi,

I tried the above suggestion (via the desktop control centre). Adding the application 'octet/stream' didn't help, but I then added the application 'octet', which seemed to clear it up. I'm a newbie, so have no idea why it works, or even what the problem was in the first place.
 
Old 02-13-2006, 11:02 PM   #7
marclijour
LQ Newbie
 
Registered: May 2004
Distribution: Mandrake
Posts: 6

Rep: Reputation: 0
octet-stream

I found that a kded crash on my machine would generate this same problem and at the same time it would make impossible for me to add the application/octet-stream mime-type manually.

I tried everything above and then I relaunched kded (typing kded as me, the normal user, in the console). And it solved the problem
 
Old 04-09-2006, 11:47 PM   #8
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
Ice9 linked to a suggestion which mentioned deleting the file /home/userID/.kde/share/mimelnk/application/octet-stream.desktop. However, in my setup, the file wasn't there. Also, both konqueror and control center were down so I couldn't mess with the file associations. And typing kded into the console simply told me that it was already running ^_^.

However, I found the file at /usr/share/mimelnk/application/octet-stream.desktop. Rather than delete the file, I changed its name to octet-stream.desktop.bak. All seems well now.

My distro is Fedora Core 4 so that may explain why I found the file in a different location.

In faith, Dave
dave@christos.cjb.net, dpeirce@christian.net
Viva Texas

Sometimes I feel like a woodpecker in a petrified forest.
 
Old 11-13-2006, 05:54 PM   #9
vinster
LQ Newbie
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Fedora & Salckware
Posts: 25

Rep: Reputation: 15
I had this problem when I tried to open a text file after installing a cabinet extractor program. It showed up when I opened the file browser also. I followed the simple intructions in this link and all seems to be working. Hope it helps.

http://lists.kde.org/?l=kde&m=107797994605331&w=2
 
Old 11-15-2006, 06:49 AM   #10
nadavkav
LQ Newbie
 
Registered: Nov 2005
Location: Israel, Kfar Sirkin
Distribution: Fedora,Debian,Ubuntu
Posts: 12

Rep: Reputation: 0
it solved my problem thanks :-)

Thanks for the info ! it solved my problem

it started when i associated kwriter to open an empty file extension (file with no extension). it was unknown mime type. i use the "open with dialog" to change it, which later changed my /root/.kde/share/mimelnk/application/octet-stream.desktop
file to...
[Desktop Entry]
Comment=
Hidden=false
Icon=
MimeType=application/x-kdeuser1
Patterns=

now, for fixing it i used you first advice which changed the file and all works great :-)

here is the corrected file:
[Desktop Entry]
Comment=
Hidden=false
Icon=
MimeType=application/octet-stream
Patterns=
Type=MimeType

thanks again,
nadav :-)
 
Old 12-09-2006, 04:15 PM   #11
sliding
LQ Newbie
 
Registered: Sep 2006
Location: Eefde - the Netherlands
Distribution: Suse 10.1
Posts: 13

Rep: Reputation: 0
Octet-stream find problem solution

I had the same problem with finding the octet-stream mime type.
It happened with several file types in Konquerer when moving the
mouse over it or when trying to open these type of files.

In fact the only change that had to be made is to change the
Hidden value in /root/.kde/share/mimelnk/application/octet-stream.desktop
(location in Suse 10.1)

The original setting was Hidden=true.

I think it would be nice if this had been done at installation,
thus saving a lot of time searching to find the solution.
For newbies this can be very frustrating


octet-stream.destop content:
[Desktop Entry]
Hidden=false
MimeType=application/octet-stream
Type=MimeType
 
Old 02-14-2007, 02:18 AM   #12
uldics
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
I had same problem on Debian Etch netinst i386 with fresh updates. The problem occured after I installed FCEU and associated (manually) filetype nes (Nintendo Entertainment System cartridge image) to it. In my mimetypes there were no octet or octet stream mentioned. When I renamed the abowementioned file to bak, clicking on nes is not starting fceu, but asking open with question. Not good. And my octet-stream.desktop file has already that Hidden=false.
How do I start my nes files with fceu then?

Edit: Ehh, I did it again, same way and now it did not create that file. And it works.

Last edited by uldics; 02-14-2007 at 08:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
could not find mime type application/octet-stream WhiteTornado Fedora 7 04-12-2006 01:52 PM
Could not find mime type - application/octet-stream EuroJovi Linux - Software 4 01-26-2006 02:30 PM
Could not find mime type application/octet-stream ERROR CyberDoc Mandriva 10 10-17-2005 09:18 PM
Help with <application/octet-stream> Dooley MEPIS 1 10-08-2005 03:08 PM
"Cannot find application/octet-stream" Chroder Linux - General 1 10-15-2003 08:38 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration