LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
Password
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.

Notices

Reply
 
Search this Thread
Old 06-03-2004, 01:25 PM   #1
scoob_e
LQ Newbie
 
Registered: Aug 2003
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
Post DISCUSSION: 3D acceleration on an ATI IGP 340M


This thread is to discuss the article titled: 3D acceleration on an ATI IGP 340M
 
Old 06-17-2004, 05:16 PM   #2
JP_Design.04
LQ Newbie
 
Registered: Jun 2004
Distribution: Fedora Core 2
Posts: 1

Rep: Reputation: 0
This is pretty tricky stuff for me as I am new to Fedora, ok. That said I have gotten as far as

[root@localhost xc]# exports/lib/modules/dri/*.so /usr/X11R6/lib/modules/dri

and I get:-

Segmentation fault
[root@localhost xc]#

there are loads of posts on google about this which mean nothing to me not all of this relates to the new kernel and i dont want to try to fix it with a patch that will not work. Specifically I dont want to not be able to start my system.

I got no errors during the last stage I checked this with the command u suggested with grep '\*\*\*' world.log.
Could you please help with this as I need to get up to speed as quick as I can so I can get modelling in 3d.

Thanks chap.

James.
 
Old 06-27-2004, 03:00 AM   #3
AndymionJunta
LQ Newbie
 
Registered: Jun 2004
Posts: 9

Rep: Reputation: 0
This technique worked for me on the first attempt.

I followed the tutorial, yet had an error on compiling, if you have, just do like me, compile as a user then switch to root, and if you still have an error, reboot and try again... if you still have an error, i dunno...

Seriously, now i can fully enjoy OpenGL games on my laptop at DECENT speeds.

Thank you so much.

JP_Design.04
There was a typo in his tutorial

before exports/.... add cp
like:
cp exports/libs/.....


Last edited by AndymionJunta; 06-27-2004 at 03:02 AM.
 
Old 07-10-2004, 08:53 PM   #4
jedixi
LQ Newbie
 
Registered: Jul 2004
Distribution: Fedora Core 2
Posts: 1

Rep: Reputation: 0
Trouble...

I'm *attempting* an install using the howto on a Compaq Presario 2545US, on Fedora Core 2. I've been having a wee bit of trouble. After following the howto completely, I get an alert saying that the Xserver could not start. Upon viewing the details, it complains that it was not able to start a screen, adding that no screen could be detected. If anyone can offer any help, that would be greatly appreciated.
 
Old 07-28-2004, 04:17 AM   #5
cybercullen
LQ Newbie
 
Registered: Jun 2004
Location: US
Distribution: Fedora Core 5
Posts: 12

Rep: Reputation: 0
I too get a segmentation fault

I also get a segmentation fault even though the compile works without any errors:

exports/lib/modules/dri/*.so /usr/X11R6/lib/modules/dri
Segmentation fault (core dumped)

Any ideas?

Nevermind, I see the problem. Thanks above for the help! (Sorry!)

Last edited by cybercullen; 07-28-2004 at 04:19 AM.
 
Old 08-08-2004, 03:08 PM   #6
Mr. D.
Member
 
Registered: Jul 2003
Location: Switzerland
Distribution: Slackware 10, SuSE 9.3
Posts: 35

Rep: Reputation: 15
Thanks Scoob_e!!

Ur guide worked with my Slack10 box. However, I only got it working for the 2.6.7 kernel. I didn't succeed using the 2.4.26 kernel because I couldn't find any appropriate patches for the agpgart.

Thanks again, D.


I finally got it working!! An update to Kernel 2.6.27 brought agpgart to life! After that i recompiled Mesa and dri/drm and it worked! :-)

Last edited by Mr. D.; 08-19-2004 at 07:47 AM.
 
Old 09-24-2004, 03:57 PM   #7
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
I got it working after upgrading to xorg. Excellent!!!
But only with Mandrake, I can't get it to work with Libranet (using xfree86 4.3)

Last edited by cedar; 10-09-2004 at 03:52 AM.
 
Old 01-19-2005, 08:50 AM   #8
KMcD
Member
 
Registered: Jun 2003
Location: Dublin, Ireland
Distribution: Slack -- current
Posts: 354

Rep: Reputation: 30
I tried to perform the cvs logins/downloads but nothing happens. Once I enter
Code:
cvs -z3 -d:pserver:anonymous@dri.freedesktop.org:/cvs/dri login
and hit enter when asked for password nothing happens, it just hangs and after some time gives a warning stating that it timed out. Am I doing something wrong? I appreciate any help.

The error I recieve is (as of today):
Code:
cvs [login aborted]: connect to dri.freedesktop.org(131.252.208.82):2401 failed: Connection timed out

Last edited by KMcD; 01-19-2005 at 08:51 AM.
 
Old 03-30-2005, 04:28 AM   #9
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
Are you connected to the internet?
 
Old 04-01-2005, 12:32 AM   #10
riscphree
Member
 
Registered: Jun 2004
Location: Georgia
Distribution: Slackware 11.0, Arch
Posts: 32

Rep: Reputation: 15
this is what i got just after step 5. this is just the end of the process:

Code:
/home/riscphree/3d/Mesa/include/GL/glx.h:295: warning: previous declaration of 'glXGetProcAddress' was here
dri_util.c:55: error: conflicting types for 'PFNGLXGETMSCRATEOMLPROC'
/home/riscphree/3d/Mesa/include/GL/glxext.h:617: error: previous declaration of 'PFNGLXGETMSCRATEOMLPROC' was here
dri_util.c: In function `glx_find_dri_screen':
dri_util.c:155: warning: pointer targets in passing arg 1 of `glXGetProcAddress' differ in signedness
dri_util.c: In function `driCreateNewContext':
dri_util.c:1046: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1046: warning: ISO C forbids assignment between function pointer and `void *'
dri_util.c:1047: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1047: warning: ISO C forbids assignment between function pointer and `void *'
dri_util.c:1049: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1049: warning: ISO C forbids assignment between function pointer and `void *'
dri_util.c:1050: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1050: warning: ISO C forbids assignment between function pointer and `void *'
dri_util.c:1054: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1054: warning: ISO C forbids assignment between function pointer and `void *'
dri_util.c:1055: warning: ISO C forbids conversion of function pointer to object pointer type
dri_util.c:1055: warning: ISO C forbids assignment between function pointer and `void *'
make[6]: *** [dri_util.o] Error 1
make[6]: Leaving directory `/home/riscphree/3d/xc/xc/lib/GL/mesa/drivers/dri/common'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/riscphree/3d/xc/xc/lib/GL/mesa/drivers/dri'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/riscphree/3d/xc/xc/lib/GL'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/riscphree/3d/xc/xc/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/riscphree/3d/xc/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/home/riscphree/3d/xc/xc'
make: *** [World] Error 2
 
Old 04-01-2005, 06:56 AM   #11
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
have you installed xorg?
 
Old 04-01-2005, 08:35 AM   #12
riscphree
Member
 
Registered: Jun 2004
Location: Georgia
Distribution: Slackware 11.0, Arch
Posts: 32

Rep: Reputation: 15
hehe, of course.
 
Old 04-01-2005, 02:58 PM   #13
riscphree
Member
 
Registered: Jun 2004
Location: Georgia
Distribution: Slackware 11.0, Arch
Posts: 32

Rep: Reputation: 15
now my gnome does not start.

any advice on fixing this?
 
Old 05-26-2005, 04:41 PM   #14
apteryx
LQ Newbie
 
Registered: Apr 2005
Location: East Texas
Distribution: Blag
Posts: 1

Rep: Reputation: 0
Works excellent, even for FC3. Only really had to change the xorg.conf to make it work here, as FC3 seems to install DRI, Mesa, etc.

GREAT WORK, and Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No 3D accel ATI RADEON IGP 340M SUSe 9.3 mconroy Linux - Laptop and Netbook 1 09-18-2005 01:27 PM
ATI Radeon IGP 340M 3d acceleration cedar Libranet 27 05-29-2005 07:23 PM
problem with MPlayer using ATI IGP 340m peevee Linux - Laptop and Netbook 1 12-07-2004 07:41 PM
3D support on an ATI IGP 340m!!! scoob_e LinuxQuestions.org Member Success Stories 5 06-22-2004 02:05 AM
ATI IGP 320M acceleration orlenok Linux - Laptop and Netbook 1 09-30-2003 10:10 AM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration