LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-06-2009, 11:03 AM   #1
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Rep: Reputation: 15
wicd shows network name as "none" + unable to get IP (protected networks)


Hi guys,

well, as the subject name goes, its really as much as I can say on that.

Initially, the network name did show up on wicd, but i was still unable to get the IP on protected networks, despite me putting in the correct password and testing it on all 3 WEP choices.

So I decided to reinstall ndiswrapper on my Mininote 2133, Hardy Heron, 2.6.24-19.

Same result, unable to connect to IP on protected networks, and now the network name shows "none" at the lower left hand corner, regardless of the network i connect to.

I'm out of ideas. Any one?

Regards.
 
Old 09-08-2009, 01:50 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,364

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Can you try with no encryption first?
What's your 1.Wireless card? 2.Distro? 3.Kernel version?
are we on pci, usb, or pcmcia?
Have you 1.the wireless modules in /etc/modprobe.d/blasclist? 2.Wlan0? 3.The exact error?
 
Old 09-08-2009, 06:02 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
You can ignore the "none" thing. A peculiarity of wicd is that it displays the name of the last network to which it connected as the name of the network to which it's connecting. Whenever I switch from one AP to another one, I'm told I'm connecting to the old AP until the connection is actually made.

And, are you sure that the AP to which you want to connect is using the old, broken, WEP security method? The current cracker tools usually take less than a minute to "beak" a WEP protected network.
 
Old 09-09-2009, 09:54 AM   #4
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Original Poster
Rep: Reputation: 15
@businesskid: I can connect to non-encrypted/public networks, no problem. I'm using Hardy Heron (Ubuntu), 2.6.24-19, Gnome 2.22.3, Broadcom Corporation BCM4312 802.11b/g. I think my card is PCI, but I'm not sure. Is there any way to check?

lspci gives me this: 02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01).

I'm pretty sure that I blacklisted the modules (except ndiswrapper) on /etc/modprobe.d/blacklist.

ifconfig:
wlan0 Link encap:Ethernet HWaddr 00:21:00:2d:1d:d2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Memory:fdffc000-fe000000

And the exact error was : Unable to Obtain IP address.

@PTrenholme: well, it wasn't really my choice, actually. I was at my friend's place = his network.

Anyway, thanks guys, much appreciated.
 
Old 09-09-2009, 05:18 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
I think that the b43 FOSS Broadcom driver is sufficiently mature now that it works better than using ndiwrapper to emulate a Windows box on which the vendor's sys file expects to be run. Note that the b43 driver does use the Broadcom microcode (which is why you need to run the b43fwcutter program to extract the code from a object file supplied by Broadcom).

Do a ps -e | grep -i b43 on your friend's system to see if there's any other Broadcom driver being loaded. (There are several different ones in the repositories, and you may have missed one in the blacklist.)

But I'd recommend you toss the ndiswrapper work-around, and go with the b43 driver Ubuntu will have automatically installed.
 
Old 09-09-2009, 11:39 PM   #6
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Hmmm.

I think I get what you are driving at, but I'm not too sure that I have much of a choice. Actually I'm using the HP Mininote 2133, and I followed the instructions from the Ubuntu Wiki.

https://wiki.ubuntu.com/LaptopTestin...%20and%20Fixes
(Part 8: Wireless Driver)

Unless I have been reading it wrong from the very start, then thats a whole new ball game.

I did "ps -e | grep -i b43" in terminal, no output.

Thanks.
 
Old 09-10-2009, 03:13 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,364

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Quote:
Originally Posted by r11_kaede View Post
@businesskid: I can connect to non-encrypted/public networks, no problem. I'm using Hardy Heron (Ubuntu), 2.6.24-19, Gnome 2.22.3, Broadcom Corporation BCM4312 802.11b/g. I think my card is PCI, but I'm not sure. Is there any way to check?
I have a 4312. Gnome Network manager is probably what you should use, or set up the init scripts like I have done in Slackware. Mine is on usb, and only shows on pci because of ssb.ko containing the b43_pci_bridge driver.
You need ssb & b43 or ndiswrapper and a windowws driver.

If you set up wpa_supplicant or try gnome network manager you will probably crack it.
 
Old 09-11-2009, 03:36 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,364

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Forgot to mention


I did "ps -e | grep -i b43" in terminal,

Should probably be

lsmod |grep b43

http://linuxwireless.org/en/users/Drivers/b43
 
Old 09-11-2009, 07:11 AM   #9
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Original Poster
Rep: Reputation: 15
I went back to Network Manager, and no joy too.

wpa_cli still gave me "Could not connect to wpa_supplicant - re-trying"

lsmod | grep b43 gave me no output.

lshw -C network gave me this:

description: Wireless interface
product: BCM4312 802.11b/g
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 00:21:00:2d:1d:d2
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.55+Broadcom,09/20/2007, 4.170. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

... How on earth do I set up wpa_supplicant anyway? I actually installed it via Synaptic.

Thanks a lot, and apologies for the slow understanding.
 
Old 09-11-2009, 09:40 AM   #10
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by r11_kaede View Post
I went back to Network Manager, and no joy too.

wpa_cli still gave me "Could not connect to wpa_supplicant - re-trying"

lsmod | grep b43 gave me no output.
Sorry, I misspoke, above, re ps -e, business_kid was correct.
Quote:
lshw -C network gave me this:

description: Wireless interface
product: BCM4312 802.11b/g
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 00:21:00:2d:1d:d2
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.55+Broadcom,09/20/2007, 4.170. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
Well, I think that the parti I highlighted in red, above, is telling you that you've got ndswarpper installed and running, using the Broadcom driver from the bcmwl5 file. So that part - as you said - should be working.
Quote:
... How on earth do I set up wpa_supplicant anyway? I actually installed it via Synaptic.
Using wicd, just click on the "Properties" button in the AP selection pop-up and, under the "Security" tab, enter the security information. wicd will handle the rest.

<edit>
FYI, the wicd connection settings (including the WPA information in plain text) are stored in /etc/wicd/wireless-settings.conf. Of course, only "root" can read or write that file.
</edit>

Last edited by PTrenholme; 09-11-2009 at 10:07 AM.
 
Old 09-11-2009, 11:49 PM   #11
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Original Poster
Rep: Reputation: 15
@PTrenholme: this is where it pretty much gets back to square one, haha.

None:Validating Authentication
None: Obtaining IP address
Connection Failed: Unable to Get IP Address

Quote:
Using wicd, just click on the "Properties" button in the AP selection pop-up and, under the "Security" tab, enter the security information. wicd will handle the rest.
I did exactly that, selecting WPA + correct passphrase.

No go.
 
Old 09-12-2009, 03:32 AM   #12
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,364

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Ideally things should run wpa_supplicant for you. You tell you system that the connection is type wpa, and all goes forward from there automagically.

Other useful commands are:
iwconfig wlan0 - allows you to see how much of your settings the device has picked up. If it says "Not Associated", you're offline. If it gives a mac address you are associated to, run dhcpcd or dhclient. You can also set wireless parameters.

iwlist wlan0 scan shows you available networks. I don't know ubuntu well. BTW, on kernel 2.6.24, forget b43 as that wasn't usable before 2.6.27. My bad.
 
Old 09-12-2009, 10:10 AM   #13
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Can you upgrade your Ubuntu distribution Jaunty? It uses a newer kernel (2.6.28) which provides better wireless support. I've been using wicd and WPA on Jaunty for some time now without any problems.
 
Old 09-13-2009, 04:01 AM   #14
r11_kaede
LQ Newbie
 
Registered: Jul 2008
Posts: 26

Original Poster
Rep: Reputation: 15
@businesskid and PTrenholme: Yeah, I think upgrading to Jaunty is my final option. I was putting it off, because I actually wanted the long-term support and upgrades. Guess it was too much to hope for, haha.

Thanks guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"..device eth0 does not seem to be present.." unable to network Redhat GP00 Linux - Networking 28 06-04-2009 10:54 AM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM
Windows box shows "Network cable unplugged" when hooked up to my Linux router drkstr Linux - Networking 5 10-03-2006 04:44 PM
"rm -rf /tmp", now Evolution shows "(no folder displayed" Ed-MtnBiker Linux - Software 7 04-10-2006 04:05 PM
Trying to get SAMBA working "Unable to find any workgroups in your local network." shodekiagari Linux - Networking 1 07-08-2005 01:32 PM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration