LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-03-2006, 01:02 PM   #1
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Windows box shows "Network cable unplugged" when hooked up to my Linux router


Bleh, this is why I don't use windows any more

I am hooking my mom up to my Linux router to share my internet connection but windows XP is saying that the network cable is unplugged.

This is the setup:

Windows --> eth1 --> iptables --> eth0 --> modem

My Linux box works just fine on the same setup. It's been awhile since I've used Windows so I am a little unfamiliar with it. Is there anything extra I need to do to get it to recognize the existence of my Linux box? I've tried telling windows to use DHCP, static, and played around with the duplex settings to no avail.

Any advice?

Thanks!
...drkstr

**edit**
FYI: windows box is go when I plug it directly into the modem, so it's not the cable.

Last edited by drkstr; 10-03-2006 at 01:10 PM.
 
Old 10-03-2006, 01:15 PM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 63
If you are connecting one pc to another directly, without a hub/switch, than the cable must be a cross-over cable. The straight cable will not work.

For reference, the cross-over cable has the following diagram:
1 ---> 3
2 ---> 6
3 ---> 1
4 ---> 4
5 ---> 5
6 ---> 2
7 ---> 7
8 ---> 8

Last edited by marozsas; 10-03-2006 at 01:17 PM.
 
Old 10-03-2006, 02:07 PM   #3
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Original Poster
Rep: Reputation: 45
Thanks for the reply!

I admit, I know very little about networking so you are probably right. But I am curious why my Linux desktop can connect strait to my Linux router with the same eth cable.

Also, to make things even more confusing (for me at least) I brought my laptop into the mix for some testing, and this is what happened when moving the same ethernet cable around and testing connection by ssh'ing

Desktop eth0 --> server eth1 : Connects OK
Laptop eth0 --> desktop eth0 : Connects OK
Laptop eth0 --> Server eth1 : Does not Connect

So it appears my server will only accept connections from my Linux Desktop through eth1. Any idea what is causing this? (note: iptables is turned off on all machines during testing)

Thanks for the help!
...drkstr

setup:

Router:
eth0 - temporarily disabled while testing
eth1 - static
Code:
root@srv:~# ifconfig
eth1      Link encap:Ethernet  HWaddr 00:0C:41:EF:B0:07
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3038091 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1094646 errors:5 dropped:0 overruns:0 carrier:5
          collisions:0 txqueuelen:1000
          RX bytes:3714588850 (3542.5 Mb)  TX bytes:999745566 (953.4 Mb)
          Interrupt:10 Base address:0x1400
Code:
root@srv:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo

Desktop:
eth0 - static
Code:
root@dsk:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0D:56:02:64:7E
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1095334 errors:3 dropped:0 overruns:0 frame:3
          TX packets:3038761 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1004348400 (957.8 Mb)  TX bytes:3726864511 (3554.2 Mb)
          Base address:0xdf40 Memory:feae0000-feb00000
Code:
root@dsk:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    1      0        0 eth0
laptop
eth0 - static
Code:
root@lpt:/etc/rc.d# ifconfig
eth0      Link encap:Ethernet  HWaddr 08:00:46:1D:11:16
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1087 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:184020 (179.7 KiB)  TX bytes:112168 (109.5 KiB)
          Interrupt:10 Base address:0x1800
Code:
root@lpt:/etc/rc.d# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    1      0        0 eth0

Last edited by drkstr; 10-03-2006 at 02:10 PM.
 
Old 10-03-2006, 03:40 PM   #4
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 63
Quote:
Originally Posted by drkstr
But I am curious why my Linux desktop can connect strait to my Linux router with the same eth cable.
Some ethernet cards has the capability to auto-detect cross/straight cables and work with both.

In your scenario, looks like the linux desktop has that kind of card, and both windows desktop and the laptop, hasnīt.
The windows message about the cable is unplugged is typical.

Besides that, your configuration looks like fine to me.

Try to connect using a hub/switch and straight cables you already have, or buy a cross-over cable.

good luck !
 
Old 10-03-2006, 03:58 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,812

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
When not using a hub/switch the adapters must be configured for the same settings i.e. 100MB full duplex. The default is typically is auto negotiate. Check the properties in windows and use the mii-tool in linux. mii-tool will also verify that you have a good link.
 
Old 10-03-2006, 04:44 PM   #6
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Original Poster
Rep: Reputation: 45
Ok, makes sense to me now. Thanks for the help everybody, I have to take off for a bit, but I'll try messing around with the pairings (terminology?) when I get home. I have a switch coming in the mail in a few days, but I need to try and get something working in the mean time. I'll let you know how it turns out.

Thanks again!
...drkstr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Cable Unplugged on Windows Caused by Linux Redhat 9.0 nader_hos Linux - Networking 8 07-26-2006 02:24 AM
"rm -rf /tmp", now Evolution shows "(no folder displayed" Ed-MtnBiker Linux - Software 7 04-10-2006 04:05 PM
plugged in lan cable, still "not connected'' message shows New@Mandrake Linux - Networking 5 10-14-2004 11:56 AM
Can I turn my box into a "Hub" with 2 network Cards?? Atmosphere Linux - Networking 2 10-21-2003 10:03 PM


All times are GMT -5. The time now is 04:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration