LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 06-28-2004, 10:32 PM   #1
Noisebox
Newbie
 
Registered: Jun 2004
Posts: 5

Rep: Reputation: 0
Realtek 8180 loaded! Now no traffic?


I'm using a Realtek 8180 based Linksys WPC11 on a livecd distro of Slackware with kernel2.4.22(i believe). I am using ndiswrapper 0.8 with the latest WinXP drivers from the realtek website net8180.inf. I've got to the point where the drivers are installed the module is loaded and i can even dhcpcd the wlan0 card and it receives the information. I can goto my routers page and view the DHCP lease, so i know it has connected and is working properly. But i still have no network traffic. I am assuming i've setup the gateway wrong or something. As i don't have/can't use a ifcfg-wlan0 file i've been typing the commands in manually. Has anyone solved this problem?

dmesg | grep ndis
// snip
ndiswrapper version 0.8 loaded
ndiswrapper adding rtl8180.sys
wlan0: ndiswrapper ethernet device 00:06:25:2f:fe:72 using driver rtl8180.sys
// snip

iwconfig
// snip
wlan0 IEEE 80211.b ESSID:"Openend"
Mode:Managed Frequency:2.437GHz Access point: 00:06:25:91:CB
Bit Rate:11Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:2432 B Fragment thr:2432 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-56 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
// snip

ifconfig
// snip
wlan0 Link encap:Ethernet HWaddr 00:06:25:2F:FE:72
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:206 errors:0 dropped:0 overruns:0 frame:0
TC packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:62800 (61.3Kb) TX bytes:2164 (2.1Kb)
Interrupt:11 Memory:10800000-108000ff
// snip


Kernel IP routing table
// snip
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.1.1 0.0.0.0 Ug 0 0 0 wlan0
// snip

Can someone point me in the right direction?

(sorry for length)

Last edited by Noisebox; 06-29-2004 at 12:10 AM.
 
Old 06-29-2004, 11:44 PM   #2
Noisebox
Newbie
 
Registered: Jun 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Solved!

Alright so i was partially right when i said i think it's a routeing problem. Turns out that Slax 4.1.2 (Slackware based LiveCD) has a bug with the firewall script. It was blocking network traffic for soemreason. a simple /etc/rc.d/rc.firewall stop followed by my dhcpcd wlan0 and then /etc/rc.d/rc.firewall start to bring it back up worked wonders!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
realtek 8180 again! sundevil Mandriva 5 06-03-2006 11:00 AM
Oh no! Not another realtek 8180 thread! ;) neatflux Linux - Wireless Networking 10 03-21-2005 04:40 PM
Realtek 8180 + kernel 2.6.2??? jmh1079 Linux - Laptop and Netbook 1 02-16-2004 08:20 PM
Suse 9 and Realtek 8180 moebis Linux - Wireless Networking 2 01-28-2004 01:17 AM
realtek 8180 Locking up Syntax_Error Linux - Networking 4 12-29-2003 12:34 AM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration