LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-21-2004, 12:22 PM   #1
ephraim613
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Proxim Gold dual band pcmcia card + RH 9.0 2.6.7 Kernel


Hi,
I am trying to get a Proxim Gold dual band wireless card to work on my Sony Laptop.
It is a VAIO PGZC-GR250.
I have installed RedHat 9.0 and upgraded kernel 2.4.20-8 to 2.6.7
I am having several issues that I am trying to sort out.

1) the cardmgr seems to be broken as I can't see the card when I do a
% /sbin/cardctl ident
I have been attempting the recompile of pcmcia-cs-3.2.8 but fails during ./Configure
2) I am also trying to get the madwifi driver to compile but also without success

Any help sorting this out would be greatly appreciated

Regards

Ephraim Schoenfeld
 
Old 07-22-2004, 05:37 PM   #2
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
if you do a dmsg | grep "manfid" do you get an output?
 
Old 07-27-2004, 11:07 PM   #3
libertyboy
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Rep: Reputation: 0
I'm having EXACTLY the same problem. I was running 2.4.20-8 from the RH ISOs and my Xircom CB 10/100 PC Card was working just fine. I immediately upgraded to 2.6.7 to gain Prism54 support (and other reasons) for my other WiFi cards. When I upgraded I can't even get the system to recognize a Orinoco Gold a/b CB or the Xircom CB 10/100. The system doesn't even beep when it's inserted nor do any of the lights light up. It's as if PCMCIA isn't working at all. I then tried a normal PCMCIA (non-card bus) Orinoco Silver 802.11b, the classic card and still to no avail.

During boot, PCMCIA indicates that it starts OK. Also, in the .config file before compile I enabled cardbus and all PCMCIA, etc.

I did a:
dmesg | grep "manfid"
and it did not return anything.

Any clues?!

THANKS

Last edited by libertyboy; 07-27-2004 at 11:22 PM.
 
Old 07-27-2004, 11:29 PM   #4
libertyboy
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Rep: Reputation: 0
One more thing...

lsmod shows the following:

Module Size Used by Not tainted
lsmod: QM_MODULES: Function not implemented

Anyone know what to do now?
 
Old 07-28-2004, 06:53 PM   #5
ephraim613
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thumbs up

Well,
After few days of frustrations, I decided to install Fedora Core 2 on this sony laptop of mine.
I also downloaded the madwifi driver from their cvs directory.

You will see below that a lot of what is required is working fine now.
I still however have a ramaining issue with the configuration of the interface thru the network config GUI supplied by Fedora Core 2
it seems that there is a comflict with name of devices between ath0 and eth1 as the tools expect.
If someone can reach the same level than below with FC2 and knows how to configure the interface I would appreciate your input
I have been able now to talk over air to this ath0 interface but can not yet go on internet with it when I turn off the eth0 interface
This one as to be much simpler but somehow escape me.
Btw this all exercise prove that the road to easy linux is still a bit bumpy and when we all get up there we may want to call the result
OSX ................ :-)

Ephraim

==== Login gives this ==============
Fedora Core release 2 (Tettnang)
Kernel 2.6.5-1.358 on an i686
login:


=======================

lsmod gives me:

Module Size Used by
snd_mixer_oss 13824 2
snd_intel8x0 26280 4
snd_ac97_codec 50436 1 snd_intel8x0
snd_pcm 68872 1 snd_intel8x0
snd_timer 17156 1 snd_pcm
snd_page_alloc 7940 2 snd_intel8x0,snd_pcm
gameport 3328 1 snd_intel8x0
snd_mpu401_uart 4864 1 snd_intel8x0
snd_rawmidi 17184 1 snd_mpu401_uart
snd_seq_device 6152 1 snd_rawmidi
snd 38372 12 snd_mixer_oss,snd_intel8x0,snd_ac97_code
401_uart,snd_rawmidi,snd_seq_device
soundcore 6112 3 snd
parport_pc 19392 1
lp 8236 0
parport 29640 2 parport_pc,lp
autofs4 10624 0
rfcomm 27164 0
l2cap 16004 5 rfcomm
bluetooth 33636 4 rfcomm,l2cap
ath_pci 33176 0
wlan 49704 2 ath_pci
ath_hal 124624 2 ath_pci
ds 12292 12
yenta_socket 15104 1
pcmcia_core 46792 2 ds,yenta_socket
sunrpc 101064 1
e100 25348 0
mii 3584 1 e100
ipt_REJECT 4736 1
ipt_state 1536 7
ip_conntrack 24968 1 ipt_state
iptable_filter 2048 1
ip_tables 13440 3 ipt_REJECT,ipt_state,iptable_filter
sg 27552 0
microcode 4768 0
radeon 92464 2
ipv6 184288 10
dm_mod 33184 0
sd_mod 16384 0
usb_storage 55392 0
scsi_mod 91344 3 sg,sd_mod,usb_storage
uhci_hcd 23708 0
button 4504 0
battery 6924 0
asus_acpi 8472 0
ac 3340 0
ext3 102376 8
jbd 40216 1 ext3
[root@localhost root]#

==============================

cardctl gives


status
=====

[root@localhost root]# cardctl status
Socket 0:
no card
Socket 1:
3.3V CardBus card
function 0: [ready]
[root@localhost root]#

Ident:
====
root@localhost root]# cardctl ident
ocket 0:
no product info available
ocket 1:
product info: "Atheros Communications, Inc.", "AR5001-0000-0000", "Wireless LAN Reference Card", "
0"
manfid: 0x0271, 0x0012
function: 6 (network)
root@localhost root]#

==========================

ifconfig


[root@localhost root]# ifconfig -a
ath0 Link encap:Ethernet HWaddr 00:20:A6:513:E0
inet addr:192.168.1.107 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::220:a6ff:fe51:d3e0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4766226 errors:742612 dropped:0 overruns:0 frame:742612
TX packets:1543 errors:5 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:470651174 (448.8 Mb) TX bytes:176335 (172.2 Kb)
Interrupt:9 Memory:13de8000-13df8000

eth0 Link encap:Ethernet HWaddr 08:00:46:43:A1:F4
inet addr:192.168.1.103 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::a00:46ff:fe43:a1f4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:60027 errors:0 dropped:0 overruns:0 frame:0
TX packets:2692 errors:0 dropped:0 overruns:0 carrier:0
collisions:209 txqueuelen:1000
RX bytes:27489627 (26.2 Mb) TX bytes:270436 (264.0 Kb)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2272 errors:0 dropped:0 overruns:0 frame:0
TX packets:2272 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2258160 (2.1 Mb) TX bytes:2258160 (2.1 Mb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

[root@localhost root]#

======================================
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone got the proxim orinoco gold 8420-WD wireless pcmcia card working??? jipe Linux - Laptop and Netbook 15 03-02-2005 02:43 PM
Proxim b/g gold wireless card dbrickman Linux - Wireless Networking 3 02-01-2005 02:16 PM
adding Proxim (Agere) orinoco gold card to sarge r.stiltskin Linux - Wireless Networking 2 10-22-2004 03:17 PM
orinoco proxim gold card hotgirl101 Linux - Hardware 3 08-06-2004 05:43 PM
Orinoco gold proxim card not recognized? Nikon01 Linux - Wireless Networking 2 08-07-2003 05:14 PM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration