LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 07-17-2003, 07:25 PM   #1
jipe
LQ Newbie
 
Registered: Jul 2003
Posts: 15

Rep: Reputation: 0
anyone got the proxim orinoco gold 8420-WD wireless pcmcia card working???


there's a sizeable post in "networking" so i'm not going to repeat all the grizzly details here (but please feel free to check out the details...)

http://www.linuxquestions.org/questi...threadid=72457

basically i'm hoping you harware guys can help and i just want to know has anyone got the proxim orinoco gold 8420-WD working?

according to http://www.hpl.hp.com/personal/Jean_...ml#WavelanIEEE

Quote:
"The Wavelan IEEE saga nevers ends. Proxim bought the card and access point business of Agere (Agere keept the chipset and radio part), so now the same Orinoco cards are sold by Proxim under the name Orinoco Classic or Orinoco World (841X - with the big square antenna and using the same Agere chipset). In a bold marketing move, Proxim renamed all it's other lines of wireless cards as Orinoco, however those cards are not based on the Agere chipset but on Atheros chipset (846X, 847X and 848X). So, if the Proxim Orinoco card doesn't have a big square antena and do support 802.11a or 802.11g, you can be sure it's not a true Orinoco. I currently don't know yet if the Orinoco 11b (842X - 802.11b only with a short antenna) use the Agere chipset or not."
so has anyone got it working? or any further ideas would be appreciated. thanks very much
 
Old 07-27-2003, 12:41 AM   #2
cp8
LQ Newbie
 
Registered: Jul 2003
Posts: 6

Rep: Reputation: 0
Hello guys. I've found this doing a google search on proxim 8420

My netstumbler.com post: http://forums.netstumbler.com/showth...&threadid=7814

First question, are you guys sure this is a HERMES 2 chipset? I suspect this is a new Agere chipset. I'm running Slackware 9.0. I've tried the latest orinoco_cs driver, with no luck.

Snip:
cardmgr[54]: unsupported card in socket 0
cardmgr[54]: product info: "Agere Systems", "Wireless PC Card Model 0111", "", ""
cardmgr[54]: manfid: 0x0156, 0x0003 function: 6 (network)

It works great under Windows 98se with netstumbler 0.3.30

The netstumbler forum users are reporting that this is a completely new card hardware wise. It would be cool if someone could let us in on just what exactly is different so we dont go wasting time trying to get drivers working for it.
 
Old 08-01-2003, 04:47 PM   #3
Gloomer
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
Atheros

the new cards run ulnder the atheros chipset. I havent had any luck getting it to work but there are some atheros drivers on sourceforge.
 
Old 08-08-2003, 01:24 PM   #4
heymarcel
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Proxim has a beta driver for this, and it works fine -- at least I know that it works fine under Slackware, Red Hat and Gentoo. They don't seem to have it posted on their site anywhere, but if you call their tech support they'll email it to you. According to their tech support, it uses the Hermes II chipset.
 
Old 08-08-2003, 09:33 PM   #5
jipe
LQ Newbie
 
Registered: Jul 2003
Posts: 15

Original Poster
Rep: Reputation: 0
here's a link to proxim's beta driver for anyone that's interested:

http://www.greenblaze.com/proxim.html

thanks to stir_frey for posting it!

i got it working under redhat9.0 in minutes.

just download it, follow the instructions. very easy, very quick. no obvious bugs or clashes on my system yet either.

sweet

 
Old 08-19-2003, 01:47 PM   #6
LinuxRacr
Member
 
Registered: Jun 2002
Distribution: CentOS 5.3
Posts: 50

Rep: Reputation: 15
So what's the latest folks?
 
Old 08-20-2003, 03:35 PM   #7
jipe
LQ Newbie
 
Registered: Jul 2003
Posts: 15

Original Poster
Rep: Reputation: 0
it works.

see my previous post and download the driver

 
Old 10-07-2003, 01:26 AM   #8
HatingProxim
LQ Newbie
 
Registered: Oct 2003
Location: BC, Canada
Distribution: RH 8
Posts: 2

Rep: Reputation: 0
Well...

If it works so gosh darned well, how come I can't get it working on my RH8 system...even though I followed the directions to a "T". every last piece of documentation I have read, and still de-nada..."Beep(up)...boop(down)". Someone dear god please help. I may have to return this thing and I really don't want to because no one stocks the orinoco classics anymore here in town.
 
Old 10-31-2003, 12:18 PM   #9
PaleRider
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Lightbulb

The beta driver installed properly, and seems to work as well as possible
with the local Linksys AP. I found out that none of the lights on the card
light up until the driver loads; Proxim tech support said that one should
light up as soon as I plug it in(the power light.)

I used the /etc/agere/iwconfig-ethx option to configure the card. I did
that in order to have the biggest number of available configuration
options. Plus, since this whole Linux wireless driver scene seems to be so
problematic right now, I figured that doing it this way would cause the
least problems.

It took me a while to figure out why the encryption wouldn't work. It
turned out that to use a hex key, there has to be a 0x in front of it. As
in:

Key1=0x<key>

So, it works, but much slower out to the world over DSL, about half the
speed, compared to connecting to the AP over wire. I am not sure why.
Iwconfig shows an 11Mb bit rate. The LAN speed is of course much slower
than over wire because it's not a 100Mb link anymore.

The OS is Suse 8.2. uname = Linux linux 2.4.20-4GB #1 Wed Aug 6 18:26:21
UTC 2003 i686 unknown unknown GNU/Linux

It's on an IBM T21 Thinkpad.

Much thanks to the greenblaze.com operator for the
driver. (I haven't heard from Proxim support about the issue yet.)

Eli
 
Old 03-07-2004, 06:44 AM   #10
gbb123
Member
 
Registered: Mar 2004
Location: Ellsworth, Wisconsin
Distribution: Suse 9.0 Pro
Posts: 32

Rep: Reputation: 15
THAT DRIVER DOESNT INSTALL IN SUSE 9.0!!!!!

Quote:
Originally posted by jipe
here's a link to proxim's beta driver for anyone that's interested:

http://www.greenblaze.com/proxim.html

thanks to stir_frey for posting it!

i got it working under redhat9.0 in minutes.

just download it, follow the instructions. very easy, very quick. no obvious bugs or clashes on my system yet either.

sweet

I just thought I would let you know that this driver did not install for me it keeps giving me this :

linux gbb123/agere# ./Install

Error: Run 'make config' first!

linux gbb123/agere# make config
make: *** No rule to make target `config'. Stop.


There is no config file in the tar ball so I dont understand what it wants from me?
 
Old 05-05-2004, 11:06 PM   #11
ljbf
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh, PA, USA
Distribution: Red Hat, SuSe
Posts: 1

Rep: Reputation: 0
Unhappy Proxim Gold 8420 on Suse 9.0??

I have a Red Hat Linux 8.0 install on a Toshiba Satellite 3000. I've been trying to set the Gold card for days. But I can't seem to get the proper skernel sources, or I don't know what the heck is happening. I am getting the same results someone posted.... beep... boop....

I am tired of trying, and Red Hat 8.0 is too old now... so I decided to update anyway.... I don't want to go with Fedora... I tried Suse 9.0 and I liked it... so I think I am going to go for that...

Yes!... i know 9.1 is out there, and that it comes with the 2.6 kernel... but I think the Agere drivers are released for 2.4 only....


I was wondering: Can any of you guys report a working Suse 9.0 (or 9.1!!) install with this card...

I bought this card from ebay... it works fine on Windows, but I want it on my linux partition too!... I've being living with a Linux laptop for almost two years now, and I would hate to come back to Windows 2000 just for a bloody PCMCIA card....

Cheers.
 
Old 05-05-2004, 11:26 PM   #12
gbb123
Member
 
Registered: Mar 2004
Location: Ellsworth, Wisconsin
Distribution: Suse 9.0 Pro
Posts: 32

Rep: Reputation: 15
I have literally had this problem for months now without a solution. I dont forsee a solution for that particular card either. I would suggest to buy one of the older Orinoco cards that works with the standard orinoco driver. The agere version simply will not work , and even if it does it only works in monitor mode and will not work with kismit or netstumbler so it is virtually useless for me anyways. Im just buying one of the older versions of the gold card as a solution to the problem and trying to sell my agere card.

Garrett
 
Old 06-18-2004, 06:37 AM   #13
gizaclue
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Looking for Technical Assistance:

I'm tying to install and configure a Proxim 11a/b/g ORINOCO ComboCard Gold (PCMCIA) 8480WD on a IBM T23 Laptop running SuSe 8.2 kernel release 2.4.20-4GB.

The card has an Atheros chipset:

cardctl ident
Socket 0:
product info: "Atheros Communications, Inc.", "AR5001-0000-0000", "Wireless LAN Reference Card", "00"
manfid: 0x0271, 0x0012
function: 6 (network)
Socket 1:
no product info available

linux:~ # cardctl config
Socket 0:
Vcc 3.3V Vpp1 3.3V Vpp2 3.3V
interface type is "cardbus"
irq 11 [exclusive] [level]
function 0:
Socket 1:
not configured

And I am using the Madwifi driver from Sourceforge.net

Having obtained, via CVS, the latest modules. I have managed to make the 3 driver files. The problem I am having is I can't load the ath_pci.o, as follows:

modprobe ath_pci
Warning: loading /lib/modules/2.4.20-4GB/net/ath_hal.o will taint the kernel: non-GPL license - Proprietary
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module ath_hal loaded, with warnings
Module wlan loaded, with warnings
/lib/modules/2.4.20-4GB/net/ath_pci.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-4GB/net/ath_pci.o: insmod /lib/modules/2.4.20-4GB/net/ath_pci.o failed
/lib/modules/2.4.20-4GB/net/ath_pci.o: insmod ath_pci failed

Having trawled the internet for help, I came across a suggestion to amend my /etc/pcmcia/config.opts file, I have added the following:

device "ath_pci"
class "network" module "wlan", "ath_hal", "ath_pci"

card "Atheros Communications, Inc."
manfid 0x0271, 0x0012
bind "ath_pci"


This still results in the same problem.

Any assistance would be greatly appreciated.
 
Old 08-06-2004, 01:46 PM   #14
RAVIN'
LQ Newbie
 
Registered: Aug 2004
Location: Wherever I'm at.
Distribution: Debian Sarg
Posts: 10

Rep: Reputation: 0
the agere driver needs to be unpacked over the pcmcia-cs source. this causes it to compile properly... this is the driver from the agere website... not the bloody proxim site, that doesnt work at all. I'm running debian.... beep boop. I hate this shit. If someone out there knows a good site on how to write device driver code...

The Proxim orinoco 8420-WD is the third card I've tried to get up and running with 'nix. Anyone else see a pattern here? There is a definite problem with the M$ofties b*tch-slapping us on the hardware front. What can we do about it? The word "NOTHING" comes to mind...

And I quote: "You had to do what with the whozit?" --Every windows user ever.
 
Old 12-19-2004, 08:13 PM   #15
QuantumFunk
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
The greenblaze.com mirror is down. I have this same card and I'm desperate for these beta drivers... the guy I just called in support claimed that they don't exist

Can anyone else post a mirror, or email them to me so I can put them up? aspitzATempnetDOTcom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get encryption working ( MDK9.2, Orinoco Gold PCMCIA card ) electricmini Linux - Wireless Networking 5 09-13-2004 11:21 PM
orinoco proxim gold card hotgirl101 Linux - Hardware 3 08-06-2004 06:43 PM
Proxim 8420-WD orinoco gold, unsupported??? SlackinMonkeee Linux - Wireless Networking 3 08-06-2004 04:50 PM
Proxim ORiNOCO 8420-WD Gold and 2.6.x - compilation errors. Koxta Linux - Wireless Networking 0 04-04-2004 12:23 PM
rh9 proxim 8420(orinoco gold) and kismet pranitha Linux - Newbie 0 02-11-2004 04:31 PM


All times are GMT -5. The time now is 03:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration