Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 03-25-2006, 03:32 PM   #1
LQ Newbie
Registered: Aug 2004
Distribution: FC5
Posts: 23

Rep: Reputation: 15
PRO/wireless 2200BG rev. 5 on FC5, cannot bring up network connection

I have just installed FC5 and I am having problems getting my wireless card to work. I have installed ipw2200 and managed to get the module loaded and I am able to use iwlist eth1 scan to find a list of nearby access points.

However, when i try to use "ifup eth1", I get the message "failed; no link present. Check cable?". I have looked at the output of dmesg, and the last couple of lines say:

ADDRCONF(NETDEV_UP): eth1: link is not ready

I dont have any clues as to what I can do to fix the problem, any suggestions would be greatly appreciated.

EDIT: I am using ipw2200 v git-1.0.8 and firmware version 2.4

Last edited by Kryis; 03-25-2006 at 09:03 PM.
Old 03-27-2006, 12:27 PM   #2
Senior Member
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch
Posts: 1,587

Rep: Reputation: 97
Can you see any clue
iwconfig eth1
ifconfig eth1
Old 03-27-2006, 03:46 PM   #3
LQ Newbie
Registered: Mar 2006
Distribution: FC5
Posts: 1

Rep: Reputation: 0
have you tried loading the firmware for the driver?
Old 03-28-2006, 02:26 AM   #4
LQ Newbie
Registered: Oct 2004
Posts: 22

Rep: Reputation: 15
I have the same problem.

I followed the instructions on this page:

One of the RPM's is called ipw2200-firmware, so I assume the firmware was loaded.

ifconfig and iwconfig displayed the new interface after i added it as a new wireless connection.
Old 04-02-2006, 09:31 AM   #5
LQ Newbie
Registered: Mar 2006
Location: Dominica
Posts: 4

Rep: Reputation: 0
I have the same problem. I upgraded my kernel for Fedora Core 3 from 2.6.9-1.677 to I am using IPW2100 and the errors I'm experiencing is the same. "iwlist eth1 scan" shows the access points. dmesg shows the same eth1:link is not ready. I'm pretty new to this but could be due to the kernel? Maybe I should downgrade to 2.6.14 but oh I'm so close. There must be a better way.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2200BG henriette Linux - Laptop and Netbook 5 05-20-2007 02:50 PM
intel(r) pro/wireless 2200bg Help tylerjroach Linux - Wireless Networking 1 02-05-2006 07:15 AM
Intel Pro Wireless 2200BG bednarjm Fedora 2 12-10-2005 09:58 PM
Intel Corp. PRO/Wireless 2200BG (rev 05) -- ipw2200 module trouble visaris Linux - Hardware 7 12-09-2004 05:18 PM
FC2 not recognizing the Intel PRO/Wireless 2200BG wireless card mdslf Linux - Laptop and Netbook 2 08-24-2004 02:25 AM

All times are GMT -5. The time now is 12:25 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration