LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 02-22-2005, 08:29 PM   #1
kook
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Rep: Reputation: 0
On local network - can't get to internet


Hi- I'm a bit of a newbie so please bare with me...
I'm trying to set up a linux laptop with cisco aironet 350 wireless card on suse 9.1. When i plugged in the card, YaST picked it up and configured it. I can get to my router's configuration page (192.168.0.1). I can also ping other PC's connected to the router, but I can't get outside the network. I know the router works (im using a PC connected to it right now). I've tried all sorts of things - changing the default gateway and DNS to my router's IP, as well as the IP's obtained by my router from my isp. No matter what, I get "could not connect to host xxxx" in a browser and "connect: network is unreachable" when i try to ping. When i do iwconfig, i get entries for both eth1 and wifi0 with exactly the same info. when i do ifconfig, i get an entry for eth0, which is my internal NIC, which worked fine (havent tried it since i started meddling with network settings), and and entry for eth1 which is the wireless card (should it be wlan0 ???). It seems that the card is getting an ip from the router's dhcp: "inet addr:192.168.0.109 Bcast:192.168.0.255 Mask:255.255.255.0"

stumped.

Any help would be greatly appreciated!
 
Old 02-22-2005, 09:19 PM   #2
DoubleOTeC
Member
 
Registered: Aug 2003
Location: Dominica
Distribution: RedHat, FC1, FC3, FC4
Posts: 266

Rep: Reputation: 30
Check your routing table.

Run route to check what your default route and gateway are.

lemme know what happens...
 
Old 02-23-2005, 08:08 AM   #3
kook
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Code:
route:
Destination  Gateway  Genmask       Flags Metric Ref Use Iface
192.168.0.0  *        255.255.255.0 U     0      0   0   eth1
link-local   *        255.255.0.0   U     0      0   0   eth1
loopback     *        255.0.0.0     U     0      0   0   lo

route -n:
Destination  Gateway  Genmask       Flags Metric Ref Use Iface
192.168.0.0  0.0.0.0  255.255.255.0 U     0      0   0   eth1
169.254.0.0  0.0.0.0  255.255.0.0   U     0      0   0   eth1
127.0.0.0    0.0.0.0  255.0.0.0     U     0      0   0   lo

Last edited by kook; 02-23-2005 at 08:09 AM.
 
Old 02-23-2005, 10:56 AM   #4
eduardomsilva
Member
 
Registered: Feb 2005
Location: Portugal
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
It seems that you donĀ“t have it correctly... you have to add a default gateway... with the IP number of your router (168.192.0.1)...

To do that you can do "route add default gw 192.168.0.1"...

It should work...

But another thing... when you have both interfaces eth0, and eth1 up... you can have problems to access with your wireless interface, I think they have some kind of priorities to access the network... and so try to put down the other interface and just put up your wireless interface... get an IP number ("dhcpcd") and then it should work...

See you around!

/edu
 
Old 02-23-2005, 07:03 PM   #5
kook
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
That worked!!!
Thanks very much.
I just have 2 questions:
1. why didn't i have to configure the gateway for the regular nic connection.
2. why does the card come up as eth1 and not wlan0?
 
Old 02-24-2005, 07:07 AM   #6
eduardomsilva
Member
 
Registered: Feb 2005
Location: Portugal
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
Hello kook!

For the first question... I think it depends on the type of configuration that you have for your eth0... I suppose you have some file with your eth0 configuration where you say that the default gateway is you router's IP address... and this is the reason why it worked...

Relatively to the second question... I think it depends a bit on the way that you have installed you wireless card in your system... I suppose that it has been automatically detected/installed by your Suse... and it just attributed the eth1 to your card...
I have two versions of this designations... In my laptop... I have drivers (ipw2100) and I have the eth0 designation for my card... But in my Desktop pc I have wlan0, running with ndiswrapper... I think this question is a bit dependent on the way you install your card... But maybe you should look a bit on the internet to find a better answer...

See you!!

/edu
 
Old 02-26-2005, 04:54 PM   #7
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Rep: Reputation: 15
I am having the same problem as kook except I'm using a wired connection

here is my route and route -n info

[root@localhost ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
[root@localhost ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
[root@localhost ~]#

and my ifconfig info

[root@localhost ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:A0:C96:50:57
inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:c9ff:fed6:5057/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2659 errors:0 dropped:0 overruns:0 frame:0
TX packets:2647 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1123560 (1.0 MiB) TX bytes:424059 (414.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3236 errors:0 dropped:0 overruns:0 frame:0
TX packets:3236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2864249 (2.7 MiB) TX bytes:2864249 (2.7 MiB)

[root@localhost ~]#

and when I type in route add default gw 192.168.1.1 I get the message SIOCADDRT: File exists so can anyone tell me something to try next please?
 
Old 02-26-2005, 06:28 PM   #8
eduardomsilva
Member
 
Registered: Feb 2005
Location: Portugal
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
Hello!

You already have one default interface:

[root@localhost ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
|->default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
|
|- This is already your default gateway... so if you are trying to set it again, you will get that error!!

So I don't know if this is really your problem... but if your network is not working, maybe is due to another problem, since your default gateway is already set! Or maybe you are making an error and setting the wrong address for the default gateway... is 191.168.1.1 the address of your router that is connected to the internet?!

Anyway... you can remove it, and change it... just take a look on the manual of route.

See you!

/edu
 
Old 02-26-2005, 07:09 PM   #9
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Rep: Reputation: 15
my network is working because I can ping the computer and ping from it both the router and other computers on my network. I just cant get on the Internet is all.

and yes 191.168.1.1 the address of my router that is connected to the Internet. also I know the gateway works because it is also the gateway for this computer even if it is windows
 
Old 02-27-2005, 07:23 PM   #10
DoubleOTeC
Member
 
Registered: Aug 2003
Location: Dominica
Distribution: RedHat, FC1, FC3, FC4
Posts: 266

Rep: Reputation: 30
Try pinging to an internet address.

For example get the IP of google.com (216.239.37.99) and try to ping if from ur machine. If that works, check your /etc/resolv.conf or wherever your DNS server addresses can be edited to ensure that you have the correct ones.
 
Old 02-28-2005, 04:26 PM   #11
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Rep: Reputation: 15
First the good news. I am able to ping the address you gave me. Now the bad news I am unable to find the /etc/resolv.conf file and don't have a clue where else it could be or what it might be called.
 
Old 03-01-2005, 09:40 AM   #12
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Just create a /etc/resolv.conf file with a line:
Quote:
nameserver 0.0.0.0
Change the 0.0.0.0 to your router's IP address.
 
Old 03-01-2005, 10:45 AM   #13
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Rep: Reputation: 15
IT WORKS!!!! I can now surf the INTERNET. Now back to the project that spawned this project.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Email Server Able to see Local Network but not Internet?? thiessenstuart Linux - Networking 3 08-24-2005 03:29 PM
block internet from 1 pc on local network bgriesi Linux - Networking 4 01-23-2005 01:44 PM
Can go Local network, can't go internet!! nectron101 Linux - Hardware 2 11-27-2004 10:03 AM
Email works on local network but internet doesn't nixclueless Linux - Networking 1 07-06-2004 09:12 PM
local network okay - no internet Who Linux - Networking 7 03-26-2003 02:06 PM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration