LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-17-2006, 01:29 PM   #1
HarPaX
LQ Newbie
 
Registered: Oct 2003
Posts: 29

Rep: Reputation: 15
Intel wireless 3945BG (ipw3945) will not associate


I have been trying to get wireless up and running on my laptop, but no matter what I do the wireless card will not assoicate with the access point. Here is the output of a few commands:

Code:
[root@localhost ~]# iwlist eth1 scan
Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth1      Scan completed :
          Cell 01 - Address: 00:18:39:3D:3F:42
                    ESSID:"ES4000G"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:1
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
                    Quality=100/100  Signal level=-18 dBm  Noise level=-18 dBm
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    Extra: Last beacon: 56ms ago

[root@localhost ~]# iwconfig eth1 ap 00:18:39:3D:3F:42
[root@localhost ~]# iwconfig eth1 channel 1
[root@localhost ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth1      unassociated  ESSID:"ES4000G"  Nickname:"localhost"
          Mode:Managed  Frequency=2.412 GHz  Access Point: 00:18:39:3D:3F:42
          Bit Rate:0 kb/s   Tx-Power:16 dBm
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:3550-4D2D-6479-5362-422B-7941-50   Security mode:open
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2   Missed beacon:0
Everything looks OK, wireles driver is loaded, the SSID, AP, key etc are all correct, so why won't it associate? Due to the lack of association any attempt to do a ifup eth1 results in "link not present" errors. Is there just some little command i'm missing here?
 
Old 09-18-2006, 07:18 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Quote:
Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...
Well this certainly may be part of the problem. You need to find a more current wireless tools package.

I would also check your logs and see if there are any clues there as to what is going wrong.
 
Old 09-18-2006, 11:58 PM   #3
HarPaX
LQ Newbie
 
Registered: Oct 2003
Posts: 29

Original Poster
Rep: Reputation: 15
I can narrow this one down a bit more after playing with it for a while. It is not that it won't assoicate, it just won't assoicate if the AP is using WPA or WPA2, it works just fine with a unsecured connection or WEP. So my question is now, does anyone have any suggestions on why (or how to find out why) wpa_supplicant dosn't seem to be doing its job? (it is installed)

Also, I downloaded and compiled the latest (beta) version of wireless tools to remove warning message and attempted to setup wpa with those, it made no difference.

Last edited by HarPaX; 09-19-2006 at 12:14 AM.
 
Old 09-19-2006, 06:59 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Quote:
So my question is now, does anyone have any suggestions on why (or how to find out why) wpa_supplicant dosn't seem to be doing its job? (it is installed)
Why don't you start by posting how you start wpa_supplicant and the config file you're using. Also read through your logs and dmesg, wpa_supplicant is usually pretty good about leaving messages.
 
Old 09-21-2006, 08:19 PM   #5
HarPaX
LQ Newbie
 
Registered: Oct 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42
Why don't you start by posting how you start wpa_supplicant and the config file you're using. Also read through your logs and dmesg, wpa_supplicant is usually pretty good about leaving messages.
This was really the answer I was looking for. I did not realize what wpa_supplicant had to be started as a seperate process, I thought it was somthing automatically invoked by the tools. I configured it & started up and now everything is working fine
 
Old 09-21-2006, 08:42 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
It certainly would be nice if wpa_supplicant, or something like it, could be more tightly integrated and wasn't a separate process. Maybe as some of the kernel developement continues, that will be the case. Wireless in Linux has come a long way in the last couple of years, but it still has a long way to go.

Congrats on getting it working!
 
Old 10-04-2006, 08:15 PM   #7
edge123
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
I know this is an older post but i am haveing the same problems, I am just not sure how to configure wpa_supplicant for my network or even if its installed right. I am using fc5
 
Old 10-05-2006, 04:43 AM   #8
patrik.i
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Rep: Reputation: 0
First, run wpa_supplicant. Should be something like this:

wpa_supplicant -c/etc/wpa_supplicant.conf -ieth1 -Dwext -B

After that, the simplest way to get it working for the first time is to use wpa_gui, I think. Simply run "wpa_gui" and click "Scan". Double-click on the access point you want to use, enter the passphrase. If everything went right, your card should now associate with the AP.

When/if you verify this to be working, you can avoid having to do this everytime by using "wpa_passphrase". Syntax is "wpa_passphrase <essid for the AP> <passphrase>". Take its output and put it into /etc/wpa_supplicant.conf. Next time you start wpa_supplicant it should associate automatically.
 
Old 10-05-2006, 10:04 PM   #9
edge123
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
ok 2 things:
1. Its connecting to my router but not getting an ip address
2. is there anyway i can turn off ssid brodcast and have it work? the only way i got it to work is by turning on ssid brodcast
 
Old 10-06-2006, 04:17 AM   #10
patrik.i
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Rep: Reputation: 0
1. Run dhclient eth1
2. Don't know unfortunately.
 
Old 10-06-2006, 06:44 AM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
If it works with SSID broadcast on, leave it on. Some drivers really only work with SSID broadcast enabled on the router, besides having the broadcast turned off really does nothing. The idea that it somehow improves security is pretty bogus as the tools you should worry about have no problem finding an access point not broadcasting its SSID.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless won't associate with AP with ndiswrapper jrdioko Linux - Software 5 08-30-2006 12:32 AM
Wireless(ipw3945) refuses to connect Postal Penguin Linux - Wireless Networking 1 07-22-2006 05:25 PM
Associate Wireless card with wlan0 Nixon Linux - Wireless Networking 12 12-16-2005 02:45 PM


All times are GMT -5. The time now is 10:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration