LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2005, 05:28 PM   #1
knight-rider
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
how to change the interface name of the wireless device


how to change the interface name of the wireless device

Quite simply I want my wireless device to come up as eth3. When I do an iwconfig it is coming up with the following details :

dev6330 IEEE 802.11-DS ESSID:"" Nickname:"Prism I"
Mode:Managed Frequency:2.462GHz Access Point: 00:00:00:00:00:00
Bit Rate:11Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/92 Signal level=134/153 Noise level=134/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


When I reboot my box the dev number changes to what appears to be a completely random number. I have an eth0 and an eth1 which were my pre-existing device.

This is part of my dmesg file:

Detected Orinoco/Prism2 PLX device at 0000:00:0d.0 irq:9, io addr:0x2480
divert: allocating divert_blk for eth1
eth1: Station identity 001f:0003:0000:0008
eth1: Looks like an Intersil firmware version 0.8.3
eth1: Ad-hoc demo mode supported
eth1: IEEE standard IBSS ad-hoc mode supported
eth1: WEP supported, 104-bit key
eth1: MAC address 00:04:75:88:92:E4
eth1: Station name "Prism I"
eth1: ready


as the wireless device is attempting to use eth1 and I already have eth1 allocated to another nic, it is giving the name dev6330, and not working. AS a

little test I changed my ifcfg-eth1 file to have my wireless card details instead, and this seemed to work, and the wireless device is also displayed as eth1

when doing iwconfig, however this is not a working solution as I need eth3 to be the wireless, not eth1.


here are some more details of my system:

more /etc/modules.conf
alias eth0 e100
alias eth1 3c59x
alias usb-controller usb-uhci
alias eth3 orinoco_plx

more /etc/sysconfig/network-scripts/ifcfg-eth1
# 3Com Corporation|3c905C-TX/TX-M [Tornado]
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.0.200
NETMASK=255.255.255.0
HWADDR=00:50A:89:F1:82
TYPE=Ethernet

more /etc/sysconfig/network-scripts/ifcfg-eth3
# 3Com Corporation|3CRWE777 PCI(PLX) Wireless Adaptor [Airconnect]
DEVICE=eth3
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Wireless
Mode=Managed
ESSID=home
 
Old 01-18-2005, 02:47 AM   #2
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Your almost there. You just need to add the following to modules.conf I believe,

options orinoco_plx if_name=eth3

Add that before the final alias command.
Regards
Chris
 
Old 01-19-2005, 06:37 PM   #3
knight-rider
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks Chris

unfortunately didnt seem to work, I tried putting it before and after the last alias in modules.conf, and even in modprobe.conf

I wonder if I was to move the wireless card to a different PCI slot then it may be scanned after the other NIC and be given a different eth#

Is that worth a try, I have tried a different IRQ by changing it in the BIOS but it made no difference
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't Find Interface Ppp0: No Such Device orc Linux - Networking 10 09-12-2009 09:56 AM
change dns settings on mdk (for wireless pci device) jaybee Linux - Hardware 2 10-11-2004 04:16 PM
NIC and Interface Device mapping info? dileepkk Linux - Networking 3 07-20-2004 06:33 AM
Mandrake no such interface, device etc eth0 nforce DijitalX Linux - Networking 3 11-16-2003 11:25 PM
Fixing interface to device. ugenn Linux - Networking 1 09-07-2003 11:23 AM


All times are GMT -5. The time now is 05:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration