LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 06-17-2003, 08:25 PM   #1
orc
LQ Newbie
 
Registered: Jun 2003
Distribution: redhat 9
Posts: 3

Rep: Reputation: 0
Exclamation Couldn't Find Interface Ppp0: No Such Device


Hi, I am having quite a problem getting ppp started up on my machine after i login to my isp. here is what the log says.....

opener: recieved opendevice
opener: revieved execPPPdaemon
In parent: pppd pid 1133
opener: recieved openresolv
Couldn't find interface ppp0: no such device
Kernel supports ppp alright.
Couldn't find interface ppp0: no such device
Couldn't find interface ppp0: no such device
opener recieved killpppdaemon
In killpppd(): sending SIGTERM to 1133
It was pppd that died
pppd exited with a return value 5
sending 1122 a SIGUSR1
opener: recieved Removesecret
opener: recieved Removesecret
opener: recieved openresolv


Any help you can give me would be great! : )
 
Old 06-18-2003, 03:16 AM   #2
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
Your having problems getting ppp up AFTER logging in to ISP???

How on earth have you logged into your ISP without PPP??

PPP stands for Point to Point Protocol, and is used to dialup to whatever ISP your on.

Need some more info... Have you configured PPP at all??? Show me what you did.

Cheers
 
Old 06-18-2003, 11:29 AM   #3
orc
LQ Newbie
 
Registered: Jun 2003
Distribution: redhat 9
Posts: 3

Original Poster
Rep: Reputation: 0
I have created ppp0 with netcfg and i have set up kppp. I can dialup to my isp, type in my username and password (im using terminal) , and type in 1 to enter ppp mode. As that happens, pppd starts up and says it cant find interface ppp0 and then it just dies. If you want anything more specific just let me know.
 
Old 06-21-2003, 09:48 AM   #4
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
Are u model adsl or cable???

Have you configured your modem / router if you have one???

May be that ppp dies because there is no device to dial out with.

What commands are you typing to initiate the ppp dial??
 
Old 06-21-2003, 10:43 AM   #5
orc
LQ Newbie
 
Registered: Jun 2003
Distribution: redhat 9
Posts: 3

Original Poster
Rep: Reputation: 0
Im not using adsl or cable, I use dial up. My modem is configured correctly, i can dial out to my isp. I use kppp to dial out. let me know of anything else you need.
 
Old 08-20-2009, 12:31 AM   #6
rustycar
LQ Newbie
 
Registered: Aug 2009
Posts: 2

Rep: Reputation: 0
Possible solution

Ok, I spent many hours fooling with ppp, at least some of that time was due to getting the error mentioned above (couldn't fine interface ppp0). Since no search I did turned up the answer, I wanted there to be SOMEWHERE on the 'net where what worked for me is recorded for posterity - and LQ.org seemed like as good a spot as any. Even though this is a very old question I'm answering, the question is still a good one for a few people, so I'll answer it here (rather than start a new thread).

Anyway:

Symptom: KPPP connects to modem fine, dials out fine, switches to ppp and immediately fails with the complaint about no such device ppp0 (in fact my log file looked VERY much like the one above).

Turns out kppp worked fine when I ran it as root. So, I just do 'sudo kppp&' or something like that and go from there.

Yes, that's not a very good solution, but it worked, and I didn't feel like taking the time to get group permissions (or whatever) working right..

In conclusion - ONE possible reason for the error message is that you don't have permission to read and write to the (ppp) device. Note that I am not talking about the modem!

There are many other reasons too, I'm sure. But try it (kppp or whatever) as root, and if it works as root then you can be pretty sure its 'just' a permissions problem.

Rusty

Last edited by rustycar; 08-20-2009 at 12:37 AM. Reason: Clarify, fix subject.
 
Old 09-05-2009, 08:51 PM   #7
Dave41A
LQ Newbie
 
Registered: Sep 2009
Location: CT, USA
Distribution: Debian 5.0.2
Posts: 4

Rep: Reputation: 0
I'm having a similar problem/can't find ppp0

This is my first post and the system will not allow me to post my more detailed question until I post a simple one first (some anti-spam feature). The real question will follow shortly.

Dave
 
Old 09-05-2009, 08:54 PM   #8
Dave41A
LQ Newbie
 
Registered: Sep 2009
Location: CT, USA
Distribution: Debian 5.0.2
Posts: 4

Rep: Reputation: 0
Rustycar:

Thank you for your careful response and thoughfulness. I am glad you returned to an unanswered thread, despite it being years old.

I am having a similar if not identical problem. I would appreciate any assistance that anyone may be able to offer that will help me correct this problem. The issue seems to involve "interface ppp0."

As full a description of the problem as I can provide is provided below. If this is insufficient, please let me know what things I can do to help with the diagnosis.

I am running Debian 5.0.2 ("lenny") and have PCI dial-up modem.

When I log into the computer from the login screen as root, I get the following:

debian:~# su dave
dave@debian:/root$ kppp
No protocol specified
kppp: cannot connect to X server :0.0
dave@debian:/root$ su
Password:
debian:~# kppp
kbuildsycoca running...
Opener: received SetSecret
Opener: received OpenLock

Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 3701
Kernel supports ppp alright.
Opener: received OpenResolv
Opener: received RemoveSecret
Opener: received RemoveSecret

I can connect to the internet normally at this point.



However, when I log in as user ("dave"), I get the following:
dave@debian:~$ whoami
dave
dave@debian:~$ kppp
Opener: received SetSecret
Opener: received SetSecret
Opener: received OpenLock


(I heard the modem dialing out at this point...sounds like a normal connection!)


Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 3281
Opener: received OpenResolv
Couldn't find interface ppp0: No such device
Kernel supports ppp alright.
Opener: received RemoveSecret
Opener: received RemoveSecret

From a different console, I try the following:

dave@debian:~$ whoami
dave
dave@debian:~$ ping -c 3 www.google.com
ping: unknown host www.google.com

Likewise, my web browser doesn't recognize any connection, despite the fact that the kppp window has now minimized itself to the taskbar and shows that (it thinks that) I am in fact connected.

However, if I change to root user in the console (although I am otherwise logged in as a user), I get the following:

dave@debian:~$ su
Password:
debian:/home/dave# whoami
root
debian:/home/dave# kppp
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kbuildsycoca running...
Opener: received SetSecret
Opener: received OpenLock

Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 3437
Kernel supports ppp alright.
Opener: received OpenResolv
Opener: received RemoveSecret
Opener: received RemoveSecret

Now, from a different console (and as a user, not root), I can do the following:

dave@debian:~$ ping -c 3 google.com
PING google.com (74.125.127.100) 56(84) bytes of data.
64 bytes from pz-in-f100.google.com (74.125.127.100): icmp_seq=1 ttl=49 time=655 ms
64 bytes from pz-in-f100.google.com (74.125.127.100): icmp_seq=2 ttl=49 time=439 ms
64 bytes from pz-in-f100.google.com (74.125.127.100): icmp_seq=3 ttl=49 time=447 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2091ms
rtt min/avg/max/mdev = 439.911/514.568/655.800/99.920 ms
dave@debian:~$

So I can "su" to root from a console, run kppp, get a couple of errors, but still otherwise be able to connect. I think I should be able to run kppp as a user.

How can I fix this?

Thanks in advance.

Dave

Last edited by Dave41A; 09-05-2009 at 09:05 PM.
 
Old 09-05-2009, 10:56 PM   #9
evilted
Member
 
Registered: Aug 2009
Location: Ouagadougou, Burkina Faso
Distribution: centos
Posts: 92

Rep: Reputation: 18
in the file ifcfg-ppp0 (cent/rehl) there should be a setting
Code:
USERCTL=no
it basically says you need to be root to make changes on the int. set this to yes to allow all users to make changes on the interface..
 
Old 09-08-2009, 09:14 PM   #10
Dave41A
LQ Newbie
 
Registered: Sep 2009
Location: CT, USA
Distribution: Debian 5.0.2
Posts: 4

Rep: Reputation: 0
evilted:

Thanks for the response. However, I did a search of my entire filesystem and can find no such file. Should I create it? If so, where should it go?

The contents of my /etc/ppp directory are as follows:

debian:/etc/ppp# ls
chap-secrets ip-up ipv6-down.d options resolv.conf
ip-down ip-up.d ipv6-up pap-secrets
ip-down.d ipv6-down ipv6-up.d peers

I viewed all of these files, as well as the contents of the sub-directories using the "more" command. I wasn't able to find anything that looked like "USERCTL"

What should I do?

Thanks in advance to anyone who may help.

Dave

Last edited by Dave41A; 09-12-2009 at 08:44 AM.
 
Old 09-12-2009, 08:56 AM   #11
Dave41A
LQ Newbie
 
Registered: Sep 2009
Location: CT, USA
Distribution: Debian 5.0.2
Posts: 4

Rep: Reputation: 0
can't find ppp0 even when root...

If it makes any difference, I apparently still get the "couldn't find interface ppp0: no such device" error even when logged in as root. However, I can still connect to the internet normally. Since the error appears both when I attempt to run kppp as a user and as root, it seems to be independent of my ability to connect to the internet.

Yet, when I run kppp as root, I can connect, and when I run it as user, I cannot. The messages that are displayed when I run it as root are shown below. The messages that are displayed when I run it as user are shown in my earlier post (9-05-09).

Thanks in advance to anyone who can shed some light on this.

Thanks,

Dave


dave@debian:~$ su
Password:
debian:/home/dave# kppp &
[1] 2917
debian:/home/dave# Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kbuildsycoca running...
Opener: received SetSecret
Opener: received OpenLock

Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 2934
Kernel supports ppp alright.
Couldn't find interface ppp0: No such device
Couldn't find interface ppp0: No such device
Opener: received OpenResolv
Opener: received RemoveSecret
Opener: received RemoveSecret
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing ppp0 interface on 2.6.7 kernel kamransoomro84 Linux - Hardware 7 01-03-2005 01:12 PM
ppp0 interface setup zsjoska Linux - Networking 1 11-04-2004 01:01 PM
interface PPP0 walker#1 Linux - Hardware 4 08-28-2004 07:39 AM
No interface ppp0 exists Likosin Linux - Networking 3 08-09-2004 02:49 AM
for a year now... interface ppp0: failed Lee_Beck Linux - Networking 7 03-31-2003 03:34 AM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration