LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-17-2004, 07:10 PM   #1
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Rep: Reputation: 0
essid not being set with iwconfig


I am using SUSE 9.1 with a SMC2802W V.2 wireless card.

I have proceeded through all the steps with the installation of ndiswrapper to configuration of my card.

iwlist wlan0 scanning works showing me my AP.

I can set my encryption fine.

No matter what I do, I cannot get
iwconfig wlan0 essid "XYZ"
to change my ssid. It remains "".

This is the last hurdle as everything else seems to work.

iwconfig can change other settings like mode but just not essid.

Does anyone have any solutions????

Any help would be GREATLY appreciated as I am slowing going crazy with this.

Thanks,
Jonathan
 
Old 10-17-2004, 07:14 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
My only comment would be if your using Suse 9.1, what the heck are you doing messing with iwconfig? Just load up the network module of yast, put ndiswrapper in as the module name for the cards driver, and go into the wireless settings and set everything. Reboot and it either works, or your card never will. Do not click on "pcmcia" or "usb" or anything in the yast network settings that make the module name section gray out.
 
Old 10-17-2004, 07:17 PM   #3
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
That is the problem. I've done just that, but again the SSID is not set. Thus I've tried to resort to iwconfig to set it.
 
Old 10-17-2004, 09:28 PM   #4
y0shi
Member
 
Registered: Oct 2004
Location: Boston, MA
Distribution: SUSE 9.1, Slackware 10.0
Posts: 95

Rep: Reputation: 15
/etc/sysconfig/network/ifcfg-wlan0

log in as root and open that file. you can edit everything there...save it...then in terminal ( still as root )

ifdown wlan0

ifup wlan0

see if that helps...if you CAN set the essid and still can't connect then post back here

i've been seeing lots of problems where people cannot get the device to recognize the changes in the config files lately...dunno whats up with that...maybe i'll have to do some googling.
 
Old 10-17-2004, 10:27 PM   #5
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
Unhappy

I've done that several times. It, unfortunately, doesn't work.

I've also tried reordering the steps in configuring the card in the file. Several posts I've seen suggested this. It didn't work.

I thought maybe it was my version of ndiswrapper. The one installed by YaST was 0.6. So I downloaded the latest 0.11 and installed that. The result is that now nothing wireless works. I think this implies that ndiswrapper is my problem.

This is the message I get now on bootup which didn't happen before:
ndiswrapper: loadnidswrapper failed (256)

Any other ideas?

...
 
Old 10-18-2004, 06:08 AM   #6
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
With an older version of ndiswrapper it took me some time as well to get the essid in it. I even had it set 3 times in my startup stuff cause otherwise it wouldn't recognize it. The newer version seems to work a lot better.

I saw that error a couple of times on this forum before and I didn't get it so I think you can still get it to work to check if the new version works.
 
Old 10-18-2004, 06:11 AM   #7
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Did you have root access when you installed ndiswrapper-0.11?
 
Old 10-18-2004, 09:09 AM   #8
y0shi
Member
 
Registered: Oct 2004
Location: Boston, MA
Distribution: SUSE 9.1, Slackware 10.0
Posts: 95

Rep: Reputation: 15
yea the newest version of ndiswrapper does not work for me either...just used the one that suse 9.1 pro comes with.
 
Old 10-18-2004, 04:42 PM   #9
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
Well, this is most odd and annoying, yet I am ecstatic for my card now works!!

After installing ndiswrapper-0.11 and having everything fail, I uninstalled it and reinstalled the default ndiswrapper with SUSE 9.1 which is ndiswrapper-0.6. I was going to just progress installing all of them incrementally, but before I did I accidently brought up my web browser which magically was conversing. For some reason, everything worked this time.

What a frustrating nonsensical process!!!

Thanks for everyone's input.

Jonathan
 
Old 10-18-2004, 04:59 PM   #10
y0shi
Member
 
Registered: Oct 2004
Location: Boston, MA
Distribution: SUSE 9.1, Slackware 10.0
Posts: 95

Rep: Reputation: 15
i'de like to know how you uninstalled it...
 
Old 10-18-2004, 05:44 PM   #11
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
That's a good question. I really didn't. I installed ndiswrapper-0.11 with make install and then when that didn't work just installed the older version 0.6 with YaST over it.

There are still a couple of glitches.

After reboot, DHCP does not pick up an IP address.
I need to to do
rmmod ndiswrapper
modprobe ndiswrapper
then suddenly everything works.

Plus, unless I load ndiswrapper at boot up in my /etc/sysconfig/kernel file, I can't get it to work.

Here is from my /var/log/boot.msg file:

<4>ndiswrapper: unsupported module, tainting kernel.
<6>ndiswrapper version 0.8 loaded
<6>ndiswrapper adding 2802w.sys
<6>PCI: Found IRQ 3 for device 0000:02:0a.0
<6>ndiswrapper: Buggy ndis driver trying to use unintilized spinlock. Trying to recover...ok.
<6>wlan0: ndiswrapper ethernet device 00:04:e2:c6:df:00 using driver 2802w.sys


Of note is the version 0.8 line. I didn't install that one.

Do you know the best place to put the
rmmod ndiswrapper
modprobe ndiswrapper
so that this is done before anyone logs in?

I don't want others playing root on my system.


Plus, do you have any idea what the reason for the above is?
 
Old 10-18-2004, 06:10 PM   #12
y0shi
Member
 
Registered: Oct 2004
Location: Boston, MA
Distribution: SUSE 9.1, Slackware 10.0
Posts: 95

Rep: Reputation: 15
fuck it, i'm just gonna reformat and play around with slack...buy a nic that works in linux and try to get xsupplicant up and running....screw suse and dell drivers with ndiswrapper
 
Old 10-18-2004, 06:34 PM   #13
jonathan_t
LQ Newbie
 
Registered: Oct 2004
Distribution: SUSE 9.1
Posts: 6

Original Poster
Rep: Reputation: 0
y0shi,
This was one of my most frustrating linux experiences. I have alot of experience with RedHat and little with other distros and this was my first week with SUSE. I'd be curious if you find it easier with Slack. Next time I am going to buy a bloody card that works with linux too. This wrapper around windows drivers kind of pisses me off. I'd rather spend an extra few bucks for the company that is linux friendly.
Jonathan
 
Old 10-18-2004, 07:43 PM   #14
y0shi
Member
 
Registered: Oct 2004
Location: Boston, MA
Distribution: SUSE 9.1, Slackware 10.0
Posts: 95

Rep: Reputation: 15
i'll let you know how it goes...i've been motivated to use slack anyhow...lots of people are having these problems with inabilities to set the ssid, and no one can seem to come up with an actual solution. so i dunno....i wish linuxant ( which works extremely well, for me anyhow ) worked with xsupplicant...but nope it doesn't and the xsupp team dun care....it's not their problem it's linuxants....as they will not give the xsupp guys a licence for testing....gonna post in the slack forums about supported card and issues i should look out for....what sucks is that i had EVERYTHING WORKING PERFECT...wanted to do a clean install...and now after compiling xsupp i have all these stupid issues :-\...thats what i get for installing suse personal and adding all the packages from pro and updating and blah blah blah..

Last edited by y0shi; 10-18-2004 at 07:46 PM.
 
Old 10-18-2004, 08:01 PM   #15
noamsml
LQ Newbie
 
Registered: Oct 2004
Distribution: Ubuntu hoary
Posts: 6

Rep: Reputation: 0
there is no folder called /etc/sysconfig on my computer


debian sarge.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot set ESSID with iwconfig leapingfrog Linux - Wireless Networking 37 09-15-2008 03:54 AM
Cant change ESSID with iwconfig svenbox Linux - Hardware 1 04-27-2005 05:54 AM
iwconfig - can't set essid simon_w Linux - Wireless Networking 5 04-13-2005 09:23 PM
iwconfig shows essid, unable to connect rjcrews Linux - Wireless Networking 8 12-21-2004 04:59 PM
Problems setting ESSID on WPC11 with iwconfig DustOffTryAgain Linux - Networking 1 07-22-2003 10:09 PM


All times are GMT -5. The time now is 04:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration