LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2006, 10:19 PM   #1
MailleMan
LQ Newbie
 
Registered: Jun 2004
Location: Colorado, USA
Distribution: LFS 6.2
Posts: 25

Rep: Reputation: 15
Question Can't Connect To WEP Wireless Network


Hi Folks,

I'm running a semi-fresh Slackware 10.2 installation, with whatever 2.4.x kernel comes by default. I have installed ndiswrapper and configured my drivers by adding both bcmwl5.sys and bcmwl5a.inf (I have a Dell TrueMobile 1400 card and for some reason, I think both have to be added for it to work).
The wireless card appears to be configured correctly, because it shows up to the system and all. But I cannot connect to my network. I seem to be able to configure the card correctly (though for some reason, there are two networks visible - XXXXXXXXX on ch. 9, and xxxxxxxxx on ch. 11; it's caps vs. no caps, and I'm just blanking out the essid). The only one that I can get it to see is xxxxxxxxx on channel 11. Here is the output of my iwconfig after configuring the card:

wlan0 IEEE 802.11g ESSID:"XXXXXXXXX"
Mode:Auto Frequency:2.462 GHz Access Point: BA:EC:6E:9F:58:1C
Bit Rate:54 Mb/s Tx-Power:46 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:XXXX-XXXX-XX Security mode:restricted
Power Managementff
Link Quality:100/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

After I configure it, I can have it up in ifconfig as follows:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:784 (784.0 b) TX bytes:784 (784.0 b)

wlan0 Link encap:Ethernet HWaddr 00:90:4B:1A:35:C5
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Memory:faff6000-faff8000

Now, if I try to run dhcpcd wlan0, it takes a while and does nothing; it seems that the network device disappears from ifconfig after I do that. Here is the result of ifconfig after the dhcpcd command:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:784 (784.0 b) TX bytes:784 (784.0 b)

Anyone have any ideas? While I won't be around this network for too much longer, at least for a while, I would like to know why this isn't working. If anyone has any suggestions, please let me know - thanks!

- Daniel
 
Old 05-18-2006, 02:07 PM   #2
halbotj
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
I have the same issue, are you using WEP? I can get an ip address if I disable the WEP, but as soon as I enable it again I nothing. My card is a Proxim using the orinoco.cs driver.
 
Old 05-18-2006, 02:59 PM   #3
MailleMan
LQ Newbie
 
Registered: Jun 2004
Location: Colorado, USA
Distribution: LFS 6.2
Posts: 25

Original Poster
Rep: Reputation: 15
I'm using WEP; my family has a laptop running Windows connected wirelessly to the router, so I don't want to disable WEP to see what happens.
 
Old 05-22-2006, 03:27 PM   #4
gnuie379
LQ Newbie
 
Registered: May 2006
Distribution: FC4 / KNOPPIX 4
Posts: 1

Rep: Reputation: 0
connecting to wireless router

I seem to have the same trouble: connecting to a router that has a WPA-PSK network with a TKIP encryption , i'm running FC4 and knoppix 4 also i cant seem to get etherreal or airsnort to run i have a broadcom card
any ideas,
thanks
 
Old 05-23-2006, 05:04 AM   #5
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Quote:
Originally Posted by MailleMan
Hi Folks,

wlan0 IEEE 802.11g ESSID:"XXXXXXXXX"
Mode:Auto Frequency:2.462 GHz Access Point: BA:EC:6E:9F:58:1C
Bit Rate:54 Mb/s Tx-Power:46 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:XXXX-XXXX-XX Security mode:restricted
Power Managementff
Link Quality:100/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Have you tried with 'open' authentication as a pose to restricted out of curiosity..?
Link quality 100/100 looks a little dodgy..
Is the router is definately set to be giving DHCP addresses?
Is it your network you are connecting to? Maybe they have MAC filtering . in which case you can authenticate with the correct key and unless you have a MAC that it recognises its not going to let you play.

If you do #dhcpcd <device> and it times out then yes, you will find the device is 'down' again in ifconfig.
It will timeout if 1) you are out of range from the router. 2) the key is incorrect (even with the above iwconfig result this can happen) 3) if they have MAC filtering setup or they are not infact using DHCP

is the restricted value automatically there or are you typing #iwconfig wlan0 key restricted s:asciipassphrase

it looks like me like you have the wrong key.. OR they have MAC filtering enabled OR they do not use DHCP maybe try password in 'hex' . sometimes some NICsjust wont play with other routers in Ascii mode.
 
Old 05-23-2006, 05:06 AM   #6
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Quote:
Originally Posted by halbotj
I have the same issue, are you using WEP? I can get an ip address if I disable the WEP, but as soon as I enable it again I nothing. My card is a Proxim using the orinoco.cs driver.
If you connect to your router using ascii make sure you use:
#iwconfig <device> key s: password
If you are using the HEX key then use
#iwconfig <device> key password

Last edited by -=Graz=-; 05-23-2006 at 05:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using iwconfig to connect to a wireless network. No WEP radicalrain Linux - Wireless Networking 2 05-03-2008 10:09 PM
Connect to Wireless Network RySk8er30 Linux - Wireless Networking 8 11-19-2007 01:55 AM
Wireless Connection Problem with Home WEP Network tmort Linux - Wireless Networking 4 04-12-2006 09:11 PM
can't connect to my wireless network hedpe Linux - Wireless Networking 14 01-28-2005 02:47 PM
How to get on a 40 bit WEP encrypted wireless network with an Intersil Prism2 card? msouden Linux - Wireless Networking 1 11-03-2003 07:02 AM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration