LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices



Reply
 
Search this Thread
Old 11-24-2013, 07:36 PM   #1
kevinyeandel
Member
 
Registered: Jun 2008
Posts: 49

Rep: Reputation: 16
openvswitch, errors getting it installed on 3.4.68-9.el6.centos.alt.x86_64


Hi

Wanting to get cloudstack up and running on CentOS6.4 but ran into a problem installing vswitch. So started from scratch with new, clean VM to get this bit sorted.


Rpm's for vswitch compile OK and I've put all the steps at the bottom.
I'm running
yum localinstall /home/ovswitch/rpmbuild/RPMS/x86_64/kmod-openvswitch-1.11.0-1.el6.x86_64.rpm

and the errors go something like
<snip>
Error: Package: kmod-openvswitch-1.11.0-1.el6.x86_64 (/kmod-openvswitch-1.11.0-1.el6.x86_64)
Requires: kernel(nla_find) = 0xcd279169
<snip>

Available: kernel-debug-2.6.32-358.23.2.el6.x86_64 (server)
kernel(kmem_cache_destroy) = 0x546abb07
Installed: kernel-3.4.68-9.el6.centos.alt.x86_64 (@server)
Not found
Available: kernel-3.4.46-8.el6.centos.alt.x86_64 (server)
Not found
Available: kernel-3.4.50-8.el6.centos.alt.x86_64 (server)
Not found
Available: kernel-3.4.53-8.el6.centos.alt.x86_64 (server)
Not found
Available: kernel-3.4.54-8.el6.centos.alt.x86_64 (server)
Not found
Available: kernel-3.4.59-8.el6.centos.alt.x86_64 (server)
Not found
Available: kernel-3.4.61-9.el6.centos.alt.x86_64 (server)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest



Steps from DVD install/first login

yum update
yum clean all
yum install wget openssl-devel rpm-build gcc make redhat-rpm-config kernel-devel*
useradd ovswitch
reboot
login ovswitch
(create and exec cont.sh below)
#!/bin/bash
wget http://openvswitch.org/releases/open...-1.11.0.tar.gz
tar xvfz openvswitch-1.11.0.tar.gz
cd openvswitch-1.11.0
mkdir -p /home/ovswitch/rpmbuild/SOURCES
cp ../openvswitch-1.11.0.tar.gz /home/ovswitch/rpmbuild/SOURCES/
cp rhel/openvswitch-kmod.files /home/ovswitch/rpmbuild/SOURCES/
rpmbuild -bb rhel/openvswitch.spec
rpmbuild -bb rhel/openvswitch-kmod-rhel6.spec



Any clues to fixing this will be much appreciated.

Thanks

Kevin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba-3.6.9-151.el6.x86_64 Problems after config. waypc Linux - Networking 1 08-01-2013 01:54 AM
gcc-4.4.6-4.el6.i686 conflicts with file from package gcc-4.4.6-4.el6.x86_64 linuxandtsm Linux - Newbie 1 03-26-2013 02:19 PM
compat-libstdc++*-33-3.2.3-69.el6 (x86_64) download timed out error mraj Red Hat 1 03-06-2013 02:16 AM
Errors in ext4 on 2.6.32-279.14.1.el6 in CentOS 6.3 Skaperen Linux - Kernel 1 12-11-2012 09:47 AM
Printing issue on Linux 2.6.32-71.el6.x86_64 tayyabq8 Linux - Newbie 2 09-30-2011 05:14 AM


All times are GMT -5. The time now is 07:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration