LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-27-2008, 07:04 PM   #1
M$ISBS
Member
 
Registered: Aug 2003
Posts: 820

Rep: Reputation: 30
Why is the start button In K3B greyed out?


Cannot use K3B cuz the start button is always greyed out. I have ugraded to current version, set permissions, tried DVD, CD-R, CD-RW, disks with same result.

Anyone encounter this before?

Could it be that K3B is not seeing the drive? When I load and eject from K3B it works.
 
Old 11-28-2008, 12:54 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,796

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
I've tried to create conditions in K3B that leave the start button greyed out. I can only get the greyed out button if:
a) there is no empty cd/dvd disk in the drive.
b) there is a disk in the drive, but it isn't blank.
c) there is a blank disk in the drive, but I haven't selected an .iso to burn.

So, try putting a blank cd/dvd in the drive, then start K3B, and finally, select the .iso to burn (Tools menu, burn .iso image).

Do you still get the greyed out button?

You could also try putting the blank disk in the drive, then start K3B from the command line. Do you get error messages in the console?
 
1 members found this post helpful.
Old 11-28-2008, 11:16 PM   #3
M$ISBS
Member
 
Registered: Aug 2003
Posts: 820

Original Poster
Rep: Reputation: 30
This issue might be related to another issue I am having with trying to mount drives.
I can read DVD disks from the drive this tells me there is data on the disk but the start button is still greyed out.
I put a couple different brands of blank DVDS in the drive and the button is still greyed out.
I have selected ISO files to burn and its still greyed out.

Could this be a permissions problem? even though I logged in as root and still have the same issue.
This is part of the console messages when I run k3b from command line.
There are a few failed messages but I do not know what they mean.

/dev/hdd resolved to /dev/hdd
/dev/hdd is block device (64)
/dev/hdd seems to be cdrom
(K3bDevice::Device) /dev/hdd: init()
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 24
ascq: 0
(K3bDevice::Device) /dev/hdd: MODE SENSE length det failed.
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 24
ascq: 0
(K3bDevice::Device) /dev/hdd: MODE SENSE with real length 65535 failed.
(K3bDevice::Device) /dev/hdd: modeSense 0x05 failed!
(K3bDevice::Device) /dev/hdd: Cannot check write modes.
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 24
ascq: 0
(K3bDevice::Device) /dev/hdd: MODE SENSE length det failed.
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 24
ascq: 0
(K3bDevice::Device) /dev/hdd: MODE SENSE with real length 65535 failed.
k3b: [void K3bMediaCache::clearDeviceList()]
/dev/hdc resolved to /dev/hdc
(K3bDevice::DeviceManager) dev /dev/hdc already found
/dev/hdd resolved to /dev/hdd
(K3bDevice::DeviceManager) dev /dev/hdd already found
(K3bDevice::DeviceManager) found config entry for devicetype: LITE-ON DVDRW SOHW
-1633S
(K3bDevice::DeviceManager) found config entry for devicetype: LITEON CD-ROM LTN5
26D
k3b: (K3bCdrecordProgram) could not start /opt/schily/bin
k3b: (K3bMkisofsProgram) could not start /opt/schily/bin
k3b: (K3bCdrecordProgram) could not start /usr/lib/java/jre/bin
k3b: (K3bMkisofsProgram) could not start /usr/lib/java/jre/bin
k3b: (K3bExternalBinManager) Cdrecord 2.1.1a23 features: gracetime, overburn, cd
text, clone, tao, cuefile, xamix, suidroot, plain-atapi, hacked-atapi, short-tra
ck-raw, audio-stdin, burnfree
k3b: (K3bExternalBinManager) 2 1 1 a23 seems to be cdrecord version >= 1.11a02,
using burnfree instead of burnproof
k3b: (K3bExternalBinManager) seems to be cdrecord version >= 1.11a31, support fo
r Just Link via burnfree driveroption
Devices:
------------------------------
Blockdevice: /dev/hdc
Generic device:
Vendor: LITE-ON
Description: DVDRW SOHW-1633S
Version: BS0H
Write speed: 3324
Profiles: DVD-ROM, DVD-R Sequential, DVD-RW Restricted Overwrite, DVD-RW S
equential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Read Cap: DVD-ROM, DVD-R, DVD-R Sequential, DVD-RW, DVD-RW Restricted Over
write, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Write Cap: DVD-R, DVD-R Sequential, DVD-RW, DVD-RW Restricted Overwrite, DV
D-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW
Writing modes: SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R,
Restricted Overwrite
Reader aliases: /dev/hdc
------------------------------
Blockdevice: /dev/hdd
Generic device:
Vendor: LITEON
Description: CD-ROM LTN526D
Version: 9S01
Write speed: 0
Profiles: CD-ROM
Read Cap: CD-ROM
Write Cap: Error
Writing modes: None
Reader aliases: /dev/hdd
------------------------------
kdecore (KAction): WARNING: KActionCollection::operator+=(): function is severel y deprecated.
k3b: (K3bFileTreeView::addCdDeviceBranches)
k3b: (K3bFileTreeView::addCdDeviceBranches) done
k3b: (K3bFileTreeView::addCdDeviceBranches)
k3b: (K3bFileTreeView::addCdDeviceBranches) done
k3b: kernel version: 2.6.21.5-smp
k3b: (K3bCore) System problems:
k3b: - none -
 
Old 12-23-2008, 04:09 PM   #4
digital8doug
Member
 
Registered: Aug 2006
Location: Near Binghamton, NY-the recent FLOOD zone
Distribution: Sabayon 351, Mepis8, oSuse11.3, Kubuntu8.1, Fed10, Slack12.1 #426299 RLU
Posts: 145
Blog Entries: 1

Rep: Reputation: 15
oSuSE 11.1 k3b not seeing optical device. BUT rest of system does

K3b on latest openSuSE release is not seeing any optical devices. Seems something internal to oSuSE settings ?*?
oSuSE Device Notifier itself shows as recently plugged in.

Dolphin File Manager shows files on recorded media, BUT
k3b says nothing there, whether blank or recorded. Tried changing default settings, no improvement.
Settings / Configure k3b / Devices-Setup CD/DVD Drives Readonly or Writer=none.
Add Device /dev/cdrom or /dev/sr0 Error =Could not find an additional dev at /dev/cdrom
Not sure where how to modify permissions
Did not recall problem on RC1 on this machine.
As OP indicates k3b is not seeing the drive

Last edited by digital8doug; 12-25-2008 at 12:10 PM. Reason: WILL TRY SAME W/ DIFFERENT DISTRO-is working fine Kubuntu 9.04 A2. Same version of k3b ! STILL NOT WORKING W/ oSUSE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
send/receive button greyed out in Evolution drum Slackware - Installation 2 04-15-2008 03:37 AM
Vector 5.1 SOHO. Start button/K button, Sound card suseforge VectorLinux 0 01-30-2006 01:14 PM
Amarok: Musicbrainz button greyed out Gay R0b0t Yoper 4 05-24-2005 12:49 AM
start button and taskbar j_developer Linux - Newbie 1 09-09-2002 02:29 PM
For some reason I can't compile a .cpp file with kdevelop, the button is greyed out. Manyguns Programming 1 07-16-2001 11:27 AM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration