LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-05-2013, 02:57 PM   #1
linuxquestions_forum_use
LQ Newbie
 
Registered: Dec 2010
Posts: 9

Rep: Reputation: 0
Starting vsftpd for vsftpd: 500 OOPS


If I'm runnign vsftpd and I make a change to my vsftpd.conf file and want to restart vsftpd, what command do I type?


I tried:

sudo /etc/init.d/vsftpd restart

and

service vsftpd restart

but all I got was:

Starting vsftpd for vsftpd: 500 OOPS: vsftpd: not configured for standalone, must be started from inetd

I suppose I could reboot the PC, but figured there was a easier way just to restart vsftpd.

Thanks!
 
Old 04-05-2013, 04:25 PM   #2
linosaurusroot
Member
 
Registered: Oct 2012
Distribution: OpenSuSE,RHEL,OpenBSD
Posts: 668
Blog Entries: 2

Rep: Reputation: 169Reputation: 169
If vsftpd is started from inetd then it's normally not running (confirm with ps) and starts running (and reads vsftpd.conf)after inetd detects the traffic. So do some FTP activity and test whether your new config works.
 
Old 04-05-2013, 04:30 PM   #3
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 767

Rep: Reputation: 154Reputation: 154
It sounds like you have listen=NO coded in your vsftpd.conf. Code listen=YES if you want it to run standalone. That will allow you to restart it with the "service vsftpd restart" command.

In order to restart vsftpd when it is running from inetd, you need to restart inetd, or you can give it a HUP signal.

as root:

/etc/init.d/inetd restart (or /etc/rc.d/inetd restart)

or

killall -HUP inetd

Last edited by Z038; 04-06-2013 at 12:17 AM.
 
Old 04-10-2013, 04:33 PM   #4
linuxquestions_forum_use
LQ Newbie
 
Registered: Dec 2010
Posts: 9

Original Poster
Rep: Reputation: 0
I haven't tried it yet, but I think I need to use this command:

# /etc/init.d/xinetd reload or
# /etc/init.d/inetd reload*
 
Old 04-11-2013, 11:51 AM   #5
jefro
Guru
 
Registered: Mar 2008
Posts: 10,265

Rep: Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257Reputation: 1257
I was looking for a new issue with opensuse on vsftp and came across a lot of posts on that issue. I get the feeling one said to change a name some place to just ftp but do some web searches for this. It is pretty common.
 
Old 04-11-2013, 09:13 PM   #6
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,093

Rep: Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995Reputation: 1995
Post #2 sounds right to me.
If its been installed to run from inetd (usually xinetd on Linux), then you need to check the cfg file in /etc/xinetd.d (one per service).
As above, xinetd does the actual listening and activates relevant service ONLY on receiving a request for that service.
One the request has been fulfilled, the (called) svc shuts down again.
The key line is 'disable = yes/no' in the eg vsftpd cfg file under /etc/xinetd.d.

Section 42.5 http://www.linuxtopia.org/online_boo...ion/index.html. In fact there are several sections relating to xinetd there.
Also note xinetd responds to tcp_wrappers ie hosts.allow, hosts.deny, so check those as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting vsftpd for vsftpd: 500 OOPS: SSL: cannot load RSA certificate MisterTickle Linux - Server 2 02-11-2011 07:41 PM
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 05:59 PM
VSFTPD > 500 OOPS: vsf_sysutil_bind Bobus Linux - Networking 0 07-27-2006 05:36 PM
vsftpd on RH4 - starting it gives 500 OOPS: could not bind listening IPv4 socket chucker8 Linux - Software 1 07-14-2006 02:39 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration