LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-22-2003, 10:49 PM   #1
perfectly_dark
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
Unhappy Sound modules unavailable in kernel 2.6


Hi,
I've just compiled the new 2.6 kernel and it boots up fine however, I have no sound. When ever I try to do something involving sound I get an error. When I use the soundcard detection utility, I get a message saying "The maestro3 driver could not be loaded. This sound card may not be compatible with Red Hat Linux". It is compatible because it worked under the 2.4 kernel. Here's what an lsmod gets me:

Module Size Used by
ide_cd 40900 0
cdrom 35264 1 ide_cd
ipv6 255392 8
lp 11652 0
autofs 16928 0
e100 63080 0
ohci1394 35240 0
microcode 6656 0
hid 25216 0
button 6008 0
agpgart 32328 0
nvidia 1705516 12

no sound modules are loaded. So I check in /usr/src/linux-2.6.0/drivers and there is no sound folder. When I go to /lib/modules/2.6.0/kernel/drivers and there is no sound folder as well. However, there is a sound folder in /lib/modules/2.6.0/kernel but it only has an oss folder and no maestro module. I specifically selected for the maestro3 driver to be loaded as a module and sound support built into the kernel (later reinstalled kernel with sound as a module) when I was compiling so I don't understand why it isn't working. Any one have any ideas on what I can do?
 
Old 12-23-2003, 01:32 AM   #2
je_fro
Member
 
Registered: Nov 2002
Location: /texas/austin/home/desk
Distribution: Gentoo
Posts: 341

Rep: Reputation: 30
Are you using redhat? Redhat is expecting a custom redhat kernel, and I don't know how it will behave if you use a vanilla one.
 
Old 12-23-2003, 01:55 AM   #3
perfectly_dark
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 4

Original Poster
Rep: Reputation: 0
I'm using Fedora Core 1. Possibly, but I still don't know why there are no sound modules in any of the kernel directories.
 
Old 12-23-2003, 02:55 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Do a modprobe maetsro, That will tell you if it can find the module and if it does it will try to load it for you. In the 2.6 kernels however, I think OSS is no longer really used. ALSA is now used. That could be your problem. Usually the ALSA modules are called something like snd-maestro. My lsmod gets me this:

parport_pc 24808 1 (autoclean)
lp 6368 0 (autoclean)
parport 23040 1 (autoclean) [parport_pc lp]
ide-cd 28608 0 (autoclean)
cdrom 28672 0 (autoclean) [ide-cd]
serial 45956 0 (autoclean)
isa-pnp 27812 0 (autoclean) [serial]
vfat 9292 1 (autoclean)
fat 29176 0 (autoclean) [vfat]
nls_cp437 4348 3 (autoclean)
ntfs 48864 1 (autoclean)
i830 73376 1
agpgart 25284 11
snd-seq-oss 23232 0 (unused)
snd-seq-midi-event 3424 0 [snd-seq-oss]
snd-seq 37616 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 35652 0 (unused)
snd-mixer-oss 11184 0 [snd-pcm-oss]
snd-intel8x0 17128 0
snd-ac97-codec 35160 0 [snd-intel8x0]
snd-pcm 56256 0 [snd-pcm-oss snd-intel8x0]
snd-timer 14404 0 [snd-seq snd-pcm]
snd-page-alloc 5360 0 [snd-intel8x0 snd-pcm]
gameport 1484 0 [snd-intel8x0]
snd-mpu401-uart 2944 0 [snd-intel8x0]
snd-rawmidi 12832 0 [snd-mpu401-uart]
snd-seq-device 3764 0 [snd-seq-oss snd-seq snd-rawmidi]
snd 29476 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm
-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart
snd-rawmidi snd-seq-device]
soundcore 3428 6 [snd]
e100 43628 1
usbkbd 2908 0 (unused)
usb-uhci 21772 0 (unused)
keybdev 1696 0 (unused)
mousedev 3768 1
hid 18980 0 (unused)
usbcore 56448 0 [usbkbd usb-uhci hid]
input 3264 0 [usbkbd keybdev mousedev hid]
af_packet 11944 1
apm 9224 0 (unused)
rtc 6108 0 (autoclean)
unix 14152 27 (autoclean)

You'll notice all the ALSA modules start with an "snd-". If the modprobe command doesn't do anything then do a find /lib/modules/2.6.0 -iname *maestro*, If that comes up with nothing change the "*maestro*" to an "snd*".

Last edited by adz; 12-23-2003 at 02:56 AM.
 
Old 12-23-2003, 09:14 AM   #5
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Rep: Reputation: 15
Did you install:

module-init-tools 0.9.10

Do:
$depmod -V

To check if you got them.
 
Old 12-24-2003, 01:16 AM   #6
perfectly_dark
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 4

Original Poster
Rep: Reputation: 0
Yes, module-init-tools 0.9.15-pre4 are installed. The only located modules were radio-maestro when I searched for maestro. When I searched for snd I got snd-rtctimer, snd-mixer-oss, snd-pcm-oss. snd-mixer-oss was already loaded, I loaded pcm and rtctimer and still no sound...I just don't have the maestro3 module...
 
Old 12-24-2003, 05:18 AM   #7
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Rep: Reputation: 15
Have you checked your .config to see if you really enabled Maestro3 ALSA driver?
 
Old 12-24-2003, 10:33 AM   #8
delta9
Member
 
Registered: Dec 2003
Distribution: Gentoo
Posts: 66

Rep: Reputation: 15
You could try to build the modules directly from the alsa source at www.alsa-project.org instead of using the source from the kernel, alsa provides pretty detailed installation notes too.
 
Old 12-24-2003, 02:14 PM   #9
perfectly_dark
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, I fixed the problem, I was accidentally skipping 'make modules' when compiling the kernel. So I recompiled and reinstalled, still no sound. But this time, modules are there, so I modprobe'd everything that started with snd and went into alsamixer and turned up the volume and sound works! However, I still have some probems. The volume control in Gnome worked the first time I inserted all the modules but I have not been able to get it to work agian. When I click it it says "Could not open mixer device /dev/sound/mixer" But sound plays. Also, volume defaults to 0 and muted when computer boots. How can I change this? I also added modules by modprobe'ing each in /etc/rc.d/rc.local, is this ok? Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound modules after compiling kernel-2.6.11.11 on Slackware 10.1 Basel Slackware 11 06-17-2005 05:38 PM
Loading sound modules into Kernel rgbrock1 Linux - Hardware 1 05-09-2005 02:48 PM
kernel 2.6.5 and sound modules rgiggs Mandriva 1 06-18-2004 03:12 PM
kernel 2.6.4 modules sound and modem positiveinflux Linux - Newbie 2 04-04-2004 05:21 AM
How do you install modules for your sound card into kernel sanfran49 Linux - Software 1 02-15-2004 12:57 AM


All times are GMT -5. The time now is 04:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration