LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-03-2002, 10:27 AM   #1
echid
LQ Newbie
 
Registered: May 2002
Posts: 11

Rep: Reputation: 0
Question Sendmail is so slow to start!


Well I seem to have done something, actually I installed the POP3/IMAP RPM for RH7.2...

And now when Linux boots it stops on the Starting Sendmail line for like 3 minutes then continues on like nothing is wrong. Everything works fine except when I have to restart Sendmail it does the customary 3 minute wait each time!

Any ideas why installing that RPM would slow down Sendmail's start time?
 
Old 05-03-2002, 02:08 PM   #2
kill-hup
Member
 
Registered: Aug 2000
Location: NY - USA
Distribution: Slackware
Posts: 109

Rep: Reputation: 15
Name resolution problem?

Not sure what the POP/IMAP RPM had to do with it, but slow sendmail starts normally stem from name resolution problems. Is your machine's local hostname in /etc/hosts or valid in your DNS config?
 
Old 05-03-2002, 04:23 PM   #3
echid
LQ Newbie
 
Registered: May 2002
Posts: 11

Original Poster
Rep: Reputation: 0
...

my local host name is in the /etc/hosts

but I am not sure what you mean by the DNS config (newbie)

could you perhaps expand on that....

thanks.
 
Old 05-03-2002, 05:58 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
yeah that's quite a common problem...

check the output of /etc/mail/error.log or similar after starting it andit should make some comments about being unable to find the host.. waitign 60 seconds... or something like that. you need to ensure that /etc/hosts is right, and also /etc/mail/access (i think.. it's something in the dir) contains the right ip/name pair for your system
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail start up and sending mail slow sohmc Linux - Software 2 06-04-2005 06:47 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
Very slow to start sendmail & sm-client services dhsieh Linux - Software 4 07-15-2004 01:38 AM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 02:55 PM
Sendmail slow as MUD Cor Koelewijn Linux - Software 3 05-31-2004 03:25 PM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration