LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-12-2005, 10:28 PM   #1
Drolith
LQ Newbie
 
Registered: Nov 2005
Posts: 14

Rep: Reputation: 0
Question pure-ftpd help.


Ok I installed pure-ftpd, I created a user/user group for it...but whenever I try to connect to it using for example (ftp://user@555.555.555.555) I get
"530 Authentication failed, sorry" but I'm using correct password, and when I try to login as root I get "530 sorry, but I can't trust you" any clue what could be wrong? I'm a linux n00b so give me some details. :P

I use suse9.3, and Gnome for interface.

Last edited by Drolith; 11-12-2005 at 10:40 PM.
 
Old 11-13-2005, 04:19 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,389

Rep: Reputation: 97
there are different authentication methods available. u can set the mode with the -l option when starting pure-ftpd. as far as i remember if u set it to "unix" it will read /etc/passwd for authentication. u can set a minimu or maximum user id, too, that allows i. e. to connect as roor or not. Take a look at man pure-ftpd...
cheers,j
 
Old 11-13-2005, 01:24 PM   #3
Drolith
LQ Newbie
 
Registered: Nov 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Ignore...

Last edited by Drolith; 11-13-2005 at 01:51 PM.
 
Old 11-13-2005, 01:50 PM   #4
Drolith
LQ Newbie
 
Registered: Nov 2005
Posts: 14

Original Poster
Rep: Reputation: 0
can connect to it using smart FTP but it disconnects shortly after entering passive mode (not familiar with smartFTP)it does what my browser does...connects correctly with username/password then sits there for a while and then gives me this(after entering passive mode):
" MLSD
0 bytes transferred. (N/A/s) (0 ms)
Timeout (40s).
Active Help: http://www.smartftp.com/support/kb/index.php/74
Client closed the connection.
Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
"
But I can connect using console commands from both (windows,linux). I just want browser access so my friends can access/view the contents of these accounts without software or needing to know how to use console.

also why wont my dir or ln command not work when connected through linux console...if I try them it sais "227 Entering Passive Mode (192.168.1.102.229.99)"...does that if I try any command it doesn't like.

Last edited by Drolith; 11-13-2005 at 03:51 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd roofy Linux - Software 6 03-05-2007 04:06 AM
pure-ftpd help hongman Linux - Software 16 04-06-2005 11:18 AM
Pure-ftpd Yoinx Linux - Software 0 10-18-2004 12:12 PM
Pure-ftpd zaicheke Linux - Software 2 08-19-2004 06:20 PM
Pure FTPD help oACEo Linux - Newbie 2 12-07-2003 11:34 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration